Anfänger benötigt eure Hilfe

#1
Guten Tag,

ich habe vor einiger Zeit versucht einen Quadcopter zu bauen und habe aufgrund von mehreren Fehlschlägen das Projekt nicht weiter verfolgt. Allerdings habe ich mich jetzt dazu entschieden das Projekt wieder anzugehen.

Die Idee war damals einen Quadcopter zu bauen der für lange Flugzeiten ausgelegt ist.

Setup:
FC: AUAV-X2
ESC: TURNIGY Plush 18amp Speed Controller
Motor: Turnigy Multistar 4225-390Kv 16Pole
Batterie: Turnigy nano-tech 8400mah 3S 40~80C Lipo Pack
Fernsteuerung: FrSky Taranis X9D Plus

Den Rahmen habe ich mir aus Carbonrohren selber gebaut.

Ich habe den Copter nie zum fliegen bekommen. Jedes mal wenn ich starten wollte ist der Copter nicht gerade abgehoben sondern ist zur einer Seite hin abgedriftet. Ich habe mich auch nie wirklich getraut mal richtig Gas zu geben. Ein Satz Propeller wurde schon beschädigt. Die Flugversuche wurden im Stabilize Mode durchgeführt. Dieser Mode erschien mir am sinnvollsten.


IMG_20181116_022358.jpg
IMG_20181116_022422.jpg

Ich bin mir nicht sicher ob Vibrationen das Problem verursachen. Kann ich den Log auslesen um dieses Problem auszuschließen?

Die Fernsteuerung habe ich so eingestellt (Mode 2) das ich mit dem linken Knüppel Gas gebe. Beim kalibrieren der Fernstuerung im Mission Planner verändere ich allerdings den Pitch mit dem linken Knüppel. Jetzt musste ich die Channel an der Fernbedienung so einstellen das ich mit dem rechten Knüppel Gas gebe um im Mission Planner mit dem linken Knüppel Gas zu geben. Sehr verwirrend!

Der Plan ist mich Step für Step vorzuarbeiten. Also ein Probelm nach dem anderen abzuarbeiten. Ich bin für Vorschläge das oder die Probleme systematischer anzugehen offen.

Ich bedanke mich für eure Hilfe im Vorraus!
 

Alex B.

heimlicher Mitleser
#2
Hallo,

also zunächst bitte nicht versuchen zu Starten, wenn der Kopter nicht richtig eingestellt ist.
Testen auch bitte ohne Propeller.

Wie du die Fernsteuerung eingestellt hast, ist erstmal nur eine Aussage darüber, wie die Knüppel in der Taranis zu betrachten sind.

Wichtiger ist, dass du die Mixer (Ausgaben) so einstellst, das die Reihenfolge der Signale über den SBUS auch dem auf deine FC entsprechen!

Alex
 
#3
Ich habe bei allen ESC´s den Throttle Weg angelernt.

Außerdem habe ich die Einstellungen der ESC´s mit der Programmierkarte geprüft (siehe Bild). Sind diese so in ordnung?

Die Fernbedienung habe ich so eingestellt das der Mittelwert bei Pitch Roll und Yaw 1500 beträgt.

IMG_20181116_134804.jpg Unbenannt.png

Habt ihr noch Ideen was ich zuvor testen oder einstellen sollte bevor ich einen weiteren Versuch im Stabilize Mode wage?
 

Alex B.

heimlicher Mitleser
#4
Hallo,
Es mag simple klingen, aber die Drehrichtung der Motoren/Propeller ist richtig?

Ist der Beschleunigungssensors richtig kalibriert?

Vielleicht versuchst du erstmal im Arco Mode zu starten, damit du sehen kannst ob er grundsätzlich richtig reagiert. Es kann sein das der Stabilzed Mode nicht richtig parametriert ist.

Alex
 
#5
Hallo Alex,

ja die gegenüber liegenden drehen gleich herum. Das eine Paar mit dem Uhrzeigersinn und das andere gegen den Uhrzeigersinn.

Ich wollte über der Mission Planner die einzelnen Motoren drehen lassen allerdings bekomme ich eine Fehlermeldung "Command was denied by Autopilot" obwohl der Safety Switch betätigt ist.
 
RCLogger

FPV1

Banggood

Banggood

Oben