APM Arducopter Tuning Guide - Teil 3

#21
@robocop: ich kenn die 9xr nicht so gut, aber grundsätzlich solltest du mal am Sender sicherstellen, daß das Poti auch wirklich einen durchgehenden Wertebereich abdeckt und am Sender gegebenenfalls alle Sticks/Schalter und Poti mal kalibrieren.
Weiters müssen am APM über den Mission-Planner die einzelnen Kanäle kalibriert werden.
Dann siehst Du dort auch schon ob Kanal 6 auch wirklich so gut wie stufenlos verstellbar ist.

Somit sollte auch sichergestellt sein, daß Du dann Kanal 6 fürs Tuning verwenden kannst um nahezu beliebige Werte zwischen MIN und MAX einzustellen.
 

aargau

Erfahrener Benutzer
#22
@kornette: hört sich nicht so gut an. Die Brücke ist definitiv durch, habe sogar extra nochmals durchgetrennt.
Aber der Kompass bringt die Daten noch.

Weisst du per Zufall was die Brücke durchtrennt? ein Datenkanal oder die Stromzufuhr für den Sensor?
 
#23
@aargau: Ich hab den Artikel um einen Ausschnitt des Schaltplans erweitert. Hier sieht man, daß man mittels Durchtrennung von SJ6 die Datenleitung (SDA) zum integrierten Kompass kappt.

D.h. du hast nach durchtrennen der Brücke ohne Anschluß eines externen Kompass noch immer Kompass Werte und keine I2C fehler im MP?
 

Robocop592

Neuer Benutzer
#24
HiHo,
oh Mann, genau das wars. Habe am Anfang nur die 4 Kanäle kalibriert.
Später den Rest nicht mehr.
Ab und zu hat man ein Brett vorm Kopf.
Jetzt funktioniert alles so wie ich es mir vorgestellt habe.
War genau der richtige Tipp den ich gebraucht habe, super.
Bis denn, Ich.
 

beastyboy80

Erfahrener Benutzer
#25
dein Kanal 6 ist nur als Schalt Kanal ausgelegt.. und nicht Stufenlos Schaltbar...

das war der Grund warum ich mir die Graupner geholt hab...die hat noch 2 Analog Poties als Drehregler

kornetto;bt1663 hat gesagt.:
@robocop: ich kenn die 9xr nicht so gut, aber grundsätzlich solltest du mal am Sender sicherstellen, daß das Poti auch wirklich einen durchgehenden Wertebereich abdeckt und am Sender gegebenenfalls alle Sticks/Schalter und Poti mal kalibrieren.
Weiters müssen am APM über den Mission-Planner die einzelnen Kanäle kalibriert werden.
Dann siehst Du dort auch schon ob Kanal 6 auch wirklich so gut wie stufenlos verstellbar ist.

Somit sollte auch sichergestellt sein, daß Du dann Kanal 6 fürs Tuning verwenden kannst um nahezu beliebige Werte zwischen MIN und MAX einzustellen.
 

aargau

Erfahrener Benutzer
#26
Danke für die Erweiterung um den Schaltplan! Leider funktioniert er bei mir wirklich, kann es mir auch nicht erklären aber ist so. Wenn es die Stromzufuhr gewesen wäre, hätte ich es noch einigermassen logisch erklären können, da ich ein externen 3v3 Regler verwende.

Aber ich denke mit dem Kompass hab ich keine Probleme. Ich habe gerade eben im Stand das teil laufen lassen (mit Props) und eine Abweichung von nicht mehr als 1-2° im Missionsplaner gesehen. Kann man im Log irgend wo auch die Kompass werte anzeigen lassen?
 
#27
aargau;bt1680 hat gesagt.:
Aber ich denke mit dem Kompass hab ich keine Probleme. Ich habe gerade eben im Stand das teil laufen lassen (mit Props) und eine Abweichung von nicht mehr als 1-2° im Missionsplaner gesehen. Kann man im Log irgend wo auch die Kompass werte anzeigen lassen?
am besten mittels Telemetrie-Set ein tlog aufzeichnen und dann den magfield Verlauf ansehen. Wenn sich dieser während Throttle um nicht viel mehr als 30% ändert hat man gute Chancen, dass man mittels compassmot Compensation diesen Fehler wegrechnen lassen kann.
Ansonsten hilft dann halt in Deinem Fall wohl nur APM höher setzen.

Gruß,
Christian
 

aargau

Erfahrener Benutzer
#28
Ich begreiff es immer noch nicht...
Habe nun heute den externen Kompass mal fertig gelötet und zum test mal kurz das Compass Testscetch via arduino aufgespielt.
Siehe da: Kompass nicht eingesteckt: not healthy, Compass eingesteckt, Daten kommen an.
Also Funkt der Interne doch nicht mehr.

Aber: Danach wieder APM 2.9.1 geflasht und siehe da, der APM zeigt im Flight Data den Kompass dennoch an?! Aber auch im Terminal über test compass kriege ich not healthy zurück! Von wo holt der diese Daten?
Ich denke er hat wirklich keine denn ich kann den internen auch nicht Kalibrieren...
Nutzt der irgend wie den Beschleunigungssensor oder das GPS?
 
#29
Mir ist ein Missgeschick passiert, ich habe "vergessen" die Lötbrücke am Mag. Sensor von 5V auf 3,3V zu ändern.

Ist mir zu erst nicht aufgefallen, funktioniert hast er so weit ich sagen kann einwandfrei.

Jetzt bin ich unsicher ob mir dabei nicht was Kaput gegangen ist, was meint ihr?

http://s14.directupload.net/images/130728/3ogwsixv.jpg

@kornetto
Danke für die Anleitung, so langsam macht mir der APM wieder Freude.
 

aargau

Erfahrener Benutzer
#30
Das sollte nichts machen...
Auf die andere Seite wäre es wohl das ende des Mag gewesen, aber weniger Spannung bringt das teil schlimmstenfalls zum nicht Arbeiten.
 
#31
Kleine Ergänzung: Für ein externen Kompass beim APM 2.0 gibt es hier die Anleitung. :) Weiter darf ich noch erwähnen, dass bei mir der erste HCM5883L Chip scheinbar defekt war (Compass Initialisation failed) - erst der Zweite funktionierte... Der I2C-Connector ist wie folgt beschaltet: 3.3V, GND, SDA, SDL (zur Orientierung: linke Seite ESC, rechte Seite Empfänger)
 

Arduplane

Neuer Benutzer
#34
Hallo,
ich hab mal ein anliegen, ist es möglich den sonar sensor und den air speed sensor gleichzeitig zu nutzen?

wie kann ich dazu ein neues thema anfangen?
bin für alle antworten dankbar
 
#35
Gute Frage bimmi
der Wert "THR_HOLD_KP" ist beim letzten FW Update "verschwunden"

Mein Hexer liegt im ALT-HOLD Mode recht gut in der Luft, wen ich jedoch Links / Rechts Bewegungen durchführe, sinkt der Copter sehr deutlich ab, und dieser Wert sollte das doch eigentlich korrigieren. (bzw. hoffe ich)
 
Zuletzt bearbeitet:
#36
@bimmi: Die Entwickler haben im Mission Planner ziemlich aufgeräumt.
Die alten Bezeichnungen in dem Ch6 Opt Dropdown waren z.T. sehr "technisch" gehaltene Variablen-Namen.
CH6_THR_HOLD_KP heißt dort jetzt "Altitude Hold kP", was eigentlich aussagekräftiger ist.

@McMerlin: Der Baro kann bei Wind bzw. durch den beim Flug entstehenden "Fahrt"-Wind in die Irre geleitet werden. Decke deinen Baro bestmöglich ab, ggf. kannst Du auch noch mit dem Parameter INAV_TC_Z experimentieren. Hierbei gehts um die Gewichtung von Baro und Z-ACC. Ein höherer Wert reduziert dabei den Baro-Einfluss.


Gruß,
Christian
 

afri

FlugAutist
#37
@kornetto: Muss doch noch mal nachfragen, da ich ebenso wie aargau das Problem habe, dass ich anscheinend die Brücke zwischen SJ6 nicht korrekt getrennt bekomme. Ich habe schon erheblich an der genannten Stelle "abgetragen", bekomme aber mit dem Multimeter immer noch ein Durchgangssignal. Woran kann das liegen ? Mittels Lupe kann man leider auch nicht 100prozentig sehen, ob bzw. wo ggf. noch Kontakt besteht.

Gibt es vielleicht noch einen anderen Punkt, an dem man SJ6 mit Bordmitteln trennen könnte ?
 
#38
@afri: funktioniert der interne Kompass dann wirklich noch? Check mal im Mission Planner ob Du I2C-Errors bekommst, oder nicht. Bei erfolgreichem Durchtrennen sollte (ohne Anschließen eines externen Kompass) der I2C-Error Counter hochzählen.
 

afri

FlugAutist
#39
@kornetto: Im Mission Planner sagt er mir immer "Compass Initialisation failed!" Egal, ob ich den externen Kompass via I2C Port angesteckt habe oder nicht.
Ich habe auch das Problem, dass ich bei verbundenem externen Kompass nur noch die rote Status-LED am APM Board leuchten habe (also kein abwechselndes Blinken der roten und blauen LED beim start-up). Da scheint also irgendwas grundlegend faul zu sein.
Ich habe einen HMC5983 Kompass im Einsatz. Sollte der das Problem sein ? Mit einem HMC5883L ist es allerdings genau so.
 

SloMo

Erfahrener Benutzer
#40
Ich werde leider aus den vorigen Post nicht wirklich schlauer.. Unter MP 3.0.1 lief das externe Magnetometer, hab aber grade auf 2.9 gedowngraded und jetzt kommt nix mehr an.. Was ist da zu tun?
 
RCLogger

FPV1

Banggood

Banggood

Oben