AQ mit M4 und N4 "bricht aus" ...

WoSchu

Neuer Benutzer
#1
Habe seit ein paar Wochen Autoquad M4 mit N4 ...
Einstellungen mit PID ... klappt inzwischen ...
Kopter fliegt stabil (ließe sich sicher noch verbessern ...)

Aber das Hauptproblem ist, dass der Kopter meist nach ein paar Minuten stabiler Flug sich plötzlich etwas schräg stellt und "ausbricht" ... kann dann nur durch Gaswegname hart gelandet werden ...

Was ist da los???

M4 ist "hart" (Alu-Distanz-Bolzen) auf dem Frame montiert ...
Klar, vor dem Starten ruhig stehen lassen (ACC Kalibr.) und warten auf GPS-Fix ...
Vibrationen sind minimal (mit mitgelieferten 9545'er T-Motor-Props)

Ist ein Eigenbau Klappkopter (ähnlich Camcruiser, nur ca. 80% Größe und ca. 1000 Gr.)
Motoren: T-Motor Air Gear 350, Regler: AfroSlim 20A mit SimonK

PS: Hatte bisher MK Systeme und auch NAZAs von DJI ... und bei keinen der beiden ein solches Problem!
 
Zuletzt bearbeitet:
#4
Hallo!

Hier das Log-File:
http.\\okspeyer.de\AQ\069-AQL.LOG
Fehler zum Ende des Logs ... "harte Landung" im Busch und schnell ausgeschaltet (disarmed)...
Hier Parametersatz:
http.\\okspeyer.de\AQ\PARAMS_1.txt
und hier noch ein Foto des Kopters:
http.\\okspeyer.de\AQ\DSCI0001.JPG

Hoffe, die Daten nützen dir was ...
Keine Ahnung wie es anderen geht, aber rich kommen an diese Daten NICHT ran!
Empfehlung: https://www.dropbox.com/de/
 

WoSchu

Neuer Benutzer
#7
Das war im GPS-Mode, passiert aber auch im Manual-Mode ...
Im Manual-Mode lässt sich die Höhe (bei Tests 2-4m h) schlecht über Minuten halten ... und offenbar beim gibts beim AQ kein Altitude-Mode ohne GPS ...
 
Zuletzt bearbeitet:

sandmen

Erfahrener Benutzer
#8
Was hilfreich ist,
wenn Du mit GPS fliegst, das Du vorher mal den MAG Kalibrierst, und davor die benötigten Daten (IMU_MAG_DECL, IMU_MAG_INCL) speicherst.
In diesem Log, fliegst Du auschließlich im GPS mode...
Könntest Du mal den MAG kalibrieren, und dann mal im manuellen modus schweben, und davon ein log machen.
Das zweite Log, dann im GPS modus.
Du kannst Alt-Hold auf Baro erreichen, in dem Du eine neue Beta-FW nimmst.
Oder aber die GPS Antenne aus steckst...
 

WoSchu

Neuer Benutzer
#9
Du kannst Alt-Hold auf Baro erreichen, in dem Du eine neue Beta-FW nimmst.
Oder aber die GPS Antenne aus steckst...
Habe die LED2 an einem Port angeschlossen und da sehe ich dass GPS-Signal als mal für kurze Zeit ganz weg ist ... (LED2 on = GPS / LED2 langsamblinkend kein GPS-Fix nur Alt-Hold ...)

habe GPS-Antenne dann mal ganz abemacht ... da scheint der AQ ordentlich zu fliegen ... das sehe ich natürlich erst bei längerem Testen ...
Kompass ist inzwischen kalibriert ... bin halt kein Tänzer ;) Nächstens gehe ich von engen Garten auf den Acker und da seh ich mal wie es mit GPS klappt ... vielleicht bessere GPS Antenne? (Habe die 25mm GPS/Glonass antenna, 25db vom Viacopter-Shop, sollte eigentlich ok sein ...) Übrigens mit MK hatte ich da nie Probleme ...

PS: Welche Firmware (mit abschltbarem GPS Pos.Hold) ist das?
 
Zuletzt bearbeitet:

WoSchu

Neuer Benutzer
#13
Bricht nach ein paar Minuten immer noch aus ...

Dabei ist mir folgendes bezügl. GPS-Signal aufgefallen:
Die blaue LED auf M4 leuchtet nach ein paar Minuten konstant ... GPS-Fix sollte da sein.
Die LED2 habe ich auf nen FC-Ausgang (Ausgang2) gelegt. Sie sollte nach Starten und umschalten in den Hold-A/P-Modus konstant "An" sein - Tuts aber nicht, die LED2 blinkt gleichmäßig und signalisiert also "Alt-Hold" aber kein GPS-Fix ... obwohl die blaue LED auf der FC an ist.

Was hat das zu bedeuten ???

Ergänzung:
Bei MK kann ich sehen, wieviel GPS-Sats zum GPS-Fix beitragen, bei NAZA V2 mit OSD auch.
Kann ich die Zahl der Sats auch bei Autoquad sehen??? Viele Sats = guter GPS-Empfang.

ftp://ftp.autoquad.org/3/334693_2252...config_rebase/
PS: Mit dieser Firmware komme ich nicht klar ... z.B. seltsame Parameter bei der Empfänger-Einstellung ... Habe also immer noch die aqv7.1.1852-hwv8.6-ext_esc.bin drauf
 
Zuletzt bearbeitet:

sandmen

Erfahrener Benutzer
#14
Kann Dir leider nicht wirklich folgen, was Du mit der LED machst.
In der Android app gibt es hAcc und vAcc was horizontal und vertical Accurancy bedeutet.
Die Anzahl der Sateliten ist eigentlich egal. Am ende zählt wie genau das Signal ist.
Ein Wert bei hAcc ~ 2 ist ok.
Bei vAcc ist über 0.8 nur Baro an, und unter 0.8 ist GPS dabei...
 

WoSchu

Neuer Benutzer
#15
Zuletzt bearbeitet:
#16
Das meine ich: http://autoquad.org/wiki/wiki/configuring-autoquad-flightcontroller/external-signaling-ledbeeper/

Signaling patterns
Event_______LED 1___LED 2
...
Altitude Hold On solid 100ms on, 400ms off
Position Hold On solid On solid
...

Aber danke für den Tipp mit der APP und den Angben über die hAcc-Werte ...
Für die neue Firmware (tunable Parameters, waypoint live recording, alt-hold (nur mit Baro), etc) musst du zwangsläufig auch die neuste QGC verwenden. Den Expertenmodus für die Schaltersettings würde ich nicht verwenden (das tue ich mich persönlich nicht an :rolleyes:; ist eher Interessant wenn du Potis als Schalter nutzen willst).

Die Konfiguration der Kanäle geht doch super simpel:
- Kanal auswählen
- dann im Dropdown daneben auswählen bei welcher Stellung der schalten soll (LOW/MID/HIGH)
- 'Indicator' zeigt dir an wie das Signal ist (leuchtet (wenn ich das jetzt richtig in Erinnerung habe) blau wenn der Input in der entsprechenden Stellung ist); kannst du beim Einstellen jederzeit testen

Sorry, das AQ Signaling habe ich noch nie benutzt; nutze dafür eine externe HW.
Signaling ist aber in der neusten Firmware ebenfalls verbessert/erweitert.

Was hast du denn da überhaupt für eine Schaltung um die LED's anzusteuern? Du nutzt doch einen M4r6 --> hast du die an den PWM der On-board ESCs?

Wie bereits gesagt: hAcc und VAcc sind interessant, nicht die Anzahl der Sats (Merke: GNNS Antenne bringt weitere Sats; die meisten Setups die ich bislang gesehen haben nutzen nur eine GPS Antenne)
 
Zuletzt bearbeitet:

WoSchu

Neuer Benutzer
#17
Was hast du denn da überhaupt für eine Schaltung um die LED's anzusteuern? Du nutzt doch einen M4r6 --> hast du die an den PWM der On-board ESCs?

hAcc und VAcc sind interessant, nicht die Anzahl der Sats (Merke: GNNS Antenne bringt weitere Sats; die meisten Setups die ich bislang gesehen haben nutzen nur eine GPS Antenne)
a) Ausgänge direkt am N4 ... und LED-Streifen 2x3 direkt an den hinderen Booms ... (Strom reicht, s. Wiki)
b) Habe die Parameter hAcc ... "in einer Ecke" der QGC entdeckt ... und mit 35mm GPS-Antenne auf Alu-Folie gabts bisher auch kein Ausbrechen mehr ... toi, toi, toi ...

Klar werde mal die neue Firmware / QGC versuchen ...
 

WoSchu

Neuer Benutzer
#18
Klar werde mal die neue Firmware / QGC versuchen ...
Habe die neue Firmware und QGC ausprobiert - klappt gut! ... und neue QGC ist auch übersichtlicher ... fein!

Nun habe ich einen externen Empfänger (von DJI) mit Funke verwendet. Hat 7 Kanäle und ich kann dann auch die Gimbal-Neigung steuern ...Modus PPM, klappt und auch die notwendige geänderte Kanalzuordnung...


Ziel: Mini-Kopter mit Gopro ca. 500gr ... und klein verpackt mit Funke (und da ist die alte DJI von einem Phantom 1 ganz ok ...)

Nun zum Problem: an dem Empfänger lassen sich keine Kanäle invertieren ... also müsste das per Parameter-Setup gemacht werden (also etweder Roll oder Pitch invertieren , M4 drehen klar -45 oder 135 Grad, aber einer der Kanäle muss invertiert werden ... und hab ich nichts gefunden / das hab ich nicht hinbekommen ...

Hat da jemand einen Tipp???
 
Zuletzt bearbeitet:

WoSchu

Neuer Benutzer
#19
Habe noch keinen Tipp erhalten. Geht offenbar nur indem die FC "auf den Kopf gestellt wird" (flip) ... und dann müsste ich verschiedene Kabel anders führen.
Habe also doch eines der Potis in der DJI-Funke umgelötet - jetzt gehts ...
 
RCLogger

FPV1

Banggood

Banggood

Oben