Autoquad M4v2 tot

#1
Hallo,
ich glaube ich habe gerade meinen Autoquad M4v2 zerstört. Beim Messen der Spannung am ADC bin wohl idiotischerweise etwas abgerutscht und wahrscheinlich am Board einen Kurzschluss verursacht oder ein Bauteil mit einer zu hohen Spannung "versorgt".
Egal bei welcher Stromversorgung... das Board bootet nicht mehr.
Kann man das Board noch irgendwie retten bzw. rausfinden was defekt ist?
Ich stell mich schon mal drauf ein, dass ich ein neues besorgen muss [emoji20]
Danke schon mal.

Gruß,
Steppenwolf
 
#2
Hallo,
ich glaube ich habe gerade meinen Autoquad M4v2 zerstört. Beim Messen der Spannung am ADC bin wohl idiotischerweise etwas abgerutscht und wahrscheinlich am Board einen Kurzschluss verursacht oder ein Bauteil mit einer zu hohen Spannung "versorgt".
Egal bei welcher Stromversorgung... das Board bootet nicht mehr.
Kann man das Board noch irgendwie retten bzw. rausfinden was defekt ist?
Ich stell mich schon mal drauf ein, dass ich ein neues besorgen muss [emoji20]
Danke schon mal.

Gruß,
Steppenwolf
... das hört sich nach einer defekten MCU an. Du kannst ja versuchen den Microcontroller zu tauschen; so kannst du das Board u.U. wiederbeleben.
 
#5
Wenn die MCU defekt ist wirst du ihr das nur schwer 'ansehen können'.

Sorry für die Frage, aber:
- was sind das denn für unisolierte Drähte am ADC Eingang?
- wieso wolltest du da überhaupt was messen?

--> Da die Brücke zur Versorgung des on-board Empfängers nicht geschlossen ist, und die Lötpads für den externen Empfänger noch unberührt aussehen würde ich halt gerne mal wissen wo das Problem überhaupt lag.

Das R26 fehlt ist gewollt! Da der jedoch nichts mit deinem Problem zu tun hat gehe ich nicht näher drauf ein.

Die Versorgung über LiPo (1S max!!) hast du noch nicht versucht, oder? Zumindest ist kein Lot auf den entsprechenden Anschlüssen.

Was für einen Copter wolltest du denn mit der M4 aufbauen; Ladybird oder was größeres (d.h. externe ESCs)?

Jörg
 
#6
Soll was größeres werden mit ESC32v2 über CAN.
Die unisolierten Drähte waren nur ein Test für die Stromversorgung über einen 4S. Diese hat nicht funktioniert. Deshalb die Messung.
Über 1S hab ichs noch nicht versucht.
Zum Empfänger bin ich noch nicht gekommen.

Gruß,
Steppenwolf
 
#7
Soll was größeres werden mit ESC32v2 über CAN.
Die unisolierten Drähte waren nur ein Test für die Stromversorgung über einen 4S. Diese hat nicht funktioniert. Deshalb die Messung.
...
Ähhmm ... also, dass das nicht funktioniert hat ist auch nicht verwunderlich! Die ADC-Anschlüsse des M4 dienen lediglich dazu die LiPo-Spannung zu messen und NICHT zu versorgen (siehe auch http://autoquad.org/wiki/wiki/m4-microcontroller/m4-v2-power-supply-and-voltage-monitoring/)!
Der M4 kann wie folgt versorgt werden:
- USB Anschluss
- 1S LiPo
- 5V über die VUSB Pads
- 4.2V (VCOM) über den Expansion Port

Wenn du einen größeren Copter bauen willst hol dir lieber ein Expansion Board; mach es einfacher (auch mit CANed ESCs). Ich hab mir für M4+CAN ein eigenes gemacht: M4CAN http://forum.autoquad.org/viewtopic.php?f=40&t=3857&start=70#p30957

Jörg
 
#8
Ja ok....dann hab ich das missverstanden. Danke für die Info. Dann werd ich mir wohl ein Expansion-Board zulegen.

...und nen neuen M4 [emoji28]
 
#9
Mich würd noch kurz interessieren, was es mit dem Widerstand R26 auf sich hat? Vielleicht hast du noch kurz Zeit mir es zu erklären.

Steppenwolf
 
RCLogger

FPV1

Banggood

Oben