Betaflight Copter amed nicht / armed nur sporadisch

odwquad

Erfahrener Benutzer
#1
Hallo Freunde des Fliegens,
ich hätte mal wieder ein Problem.
An meinem neuen Mituko Quadrocopter funktioniert das amen nicht so wirklich, und ich weiß einfach nicht warum. Mal geht es, mal geht es nicht.....

Was ich schon gemacht habe:
  • Die Funke so eingestellt dass alle Kanäle zwischen 1000 und 2000 liegen und bei 1500 die Mitte ist.
  • den Copter nochmal neu gelevelt.
  • Verkabelung kontrolliert.
Wenn er amed dann fliegt er echt Klasse und auch stabil und ohne Fehler. Aber sobalt ich den Akku wechel armed er nicht mehr. Ab und zu hilft es, wenn ich ihn dann mit angestecktem Akku an PC stöpsle in Betaflight rein gehe und dann wieder disconnecte.

Anbei auch mal meine Log Dateien. Vielleicht helfen die jemanden weiter. ich weiß leider nicht wie ich diese in Betaflight öffne und auswerten kann.

Und zum Schluss noch mein System:
  • Shendrones Mitsuko 5 frame
  • Matek PDB-XPW W/ CURRENT SENSOR 140A & DUAL BEC
  • Multistar Elite 2204-2300KV motors
  • Wraith32 Mini BLHeli_32 25A 2-6S ESC
  • Wraith32 F7 V2 OSD F745 Flight Controller with Betaflight
  • Frsky R-XSR Micro RX 5,8GHz
  • TBS Unify Pro V3 VTX
  • RunCAM PZ0420M-L28-P camera
  • 5,8GHz Cloverleaf Antenna
  • 5x3 Propeller
  • 4S1300 Tattu battery
 

Anhänge

donvido

Erfahrener Benutzer
#2
Hast du vielleicht die maximale Zellspannung auf 4,2V gesetzt?
Dann kann es sein, dass der FC denkt, dass du eine Zelle mehr hast du der Akku insgesamt leer ist.
Wenn das der Fall ist, einfach den Standard (4,3 V) wieder herstellen.
Für die Logs gibts den Blackbox Explorer.
Beim nächsten Mal am besten noch ein diff machen im Cli und hier posten.
 

odwquad

Erfahrener Benutzer
#3
Hast du vielleicht die maximale Zellspannung auf 4,2V gesetzt?
Dann kann es sein, dass der FC denkt, dass du eine Zelle mehr hast du der Akku insgesamt leer ist.
Wenn das der Fall ist, einfach den Standard (4,3 V) wieder herstellen.
Für die Logs gibts den Blackbox Explorer.
Beim nächsten Mal am besten noch ein diff machen im Cli und hier posten.
Habe gerade mal nachgeschaut, daran lag es nicht.
folgendes ist eingestellt: 3,3V bei minimaler Zellspannung, 4,3 bei maximaler Zellspannung, 3,5 bei Zellspannung Warnung.

was ist ein diff?

Was mir gerade noch aufgefallen ist. Auf der "Einrichtungsseite" von der Betaflight Oberfläche steht:
"Arming deaktiviert aufgrund: 6"
Was hat das zu bedeuten? Google findet hier nichts.
 

odwquad

Erfahrener Benutzer
#5
ahh okay. da bin ich ja schonmal ein Schritt weiter.

"Arming disable flags: THROTTLE CLI" steht da.
 

odwquad

Erfahrener Benutzer
#6
anbei die Ausgabe des diff im Cli

# diff

# version
# Betaflight / OMNIBUSF7V2 (OB72) 3.2.0 Aug 28 2017 / 14:32:01 (b2cd729)

# name
name odwquad

# resources

# mixer

# servo

# servo mix


# feature
feature TELEMETRY
feature LED_STRIP
feature ESC_SENSOR

# beeper

# map

# serial
serial 5 32 115200 57600 0 115200

# led
led 0 15,15::CTW:2
led 1 14,15::A:0
led 2 13,15::A:0
led 3 12,15::CW:2

# color

# mode_color
mode_color 6 1 2
mode_color 7 0 0

# aux
aux 0 0 3 1800 2075
aux 1 1 0 900 1200
aux 2 4 0 1725 2100
aux 3 13 2 1725 2100
aux 4 28 0 1775 2100

# adjrange
adjrange 0 0 4 900 2100 6 4

# rxrange

# vtx

# rxfail
rxfail 4 s 900

# master
set gyro_to_use = 1
set min_check = 1000
set max_check = 2000
set motor_pwm_protocol = DSHOT1200
set bat_capacity = 1300
set ibata_scale = 236
set ibata_offset = 16
set deadband = 8
set yaw_deadband = 5
set osd_cap_alarm = 1300
set osd_vbat_pos = 2103
set osd_rssi_pos = 40
set osd_tim_1_pos = 54
set osd_flymode_pos = 2112
set osd_vtx_channel_pos = 377
set osd_current_pos = 2231
set osd_mah_drawn_pos = 2199
set osd_craft_name_pos = 2528
set osd_gps_speed_pos = 218
set osd_gps_lon_pos = 82
set osd_gps_lat_pos = 65
set osd_gps_sats_pos = 51
set osd_home_dir_pos = 302
set osd_home_dist_pos = 303
set osd_compass_bar_pos = 266
set osd_pid_roll_pos = 423
set osd_pid_pitch_pos = 455
set osd_pid_yaw_pos = 487
set osd_debug_pos = 1
set osd_power_pos = 2167
set osd_pidrate_profile_pos = 345
set osd_warnings_pos = 2473
set osd_avg_cell_voltage_pos = 2135
set osd_pit_ang_pos = 257
set osd_rol_ang_pos = 289
set osd_battery_usage_pos = 2545
set osd_nheading_pos = 311
set osd_nvario_pos = 279
set osd_esc_tmp_pos = 2514
set osd_esc_rpm_pos = 2519
set osd_stat_tim_1 = ON

# profile
profile 0

set setpoint_relax_ratio = 75
set dterm_setpoint_weight = 118
set p_pitch = 71
set p_roll = 71
set p_yaw = 60

# rateprofile
rateprofile 0

set rc_rate = 148
set rc_rate_yaw = 132
set roll_srate = 61
set pitch_srate = 61
set yaw_srate = 61

#
 

odwquad

Erfahrener Benutzer
#7
Also es scheint zu funktionieren. Habe Throttle mal in der Funke auf unter 1000 gesetzt (995). Jetzt ist der Fehler weg und es kann gearmt werden.
Dachte aber, dass alle Werte zwischen 1000 und 2000 liegen müssen.

Hoffe das war es wirklich. Werde morgen nochmal testen. :)
 

woolf3d

Neuer Benutzer
#8
Ich hatte selber heute mega stress mit dem armen, aber ab Version 3.3 kann nur gearmed werden wen du keine Verbindung zum Computer hast, sonst kommt eben der Fehler CLI.
 

fandi

Erfahrener Benutzer
#9
Dachte aber, dass alle Werte zwischen 1000 und 2000 liegen müssen.
Nein, die Werte sind je nach RC Anlage unterschiedlich,
im groben liegen die zwar in dem Bereich, (bei mir z.B. 983-1890)
Deine kannst Du im Receiver Tab aber auslesen.
Dann mußt Du die Werte an verschiedenen Stellen anpassen.
 

odwquad

Erfahrener Benutzer
#13
Ja super Video. Hätte ich das mal eher gefunden^^
Also mein Copter armed jetzt auf jeden Fall so wie er soll. Lag wirklich am Gaswert. Bin heute früh nochmal geflogen und hatte da zu erst wieder das Problem. dann habe ich in der Funke einfach den Gas Wert noch etwas runter gestellt, seit dem keine Probleme mehr.

Dankeschön. (y):love:
 
RCLogger

FPV1

Banggood

Banggood

Oben