BetaFPV Pro 2 spinnt herum

Blebbens

Erfahrener Benutzer
#1
Hallo,

meine beiden BetaFPV 75 Pro 2 (FrSky FCC) flogen nun 2 Tagen problemlos durch mein Wohnzimmer.
An Tag 3 plötzlich verlor einer der beiden plötzlich während des Flugs vor meiner Nase die Verbindung und flog auf den Boden.
Bei den weiteren Flügen verlor derselbe Copter immer wieder die Verbindung und ging zu Boden.

Die Taranis meldete eine verlorene Telemetry-Verbindung. Geändert hatte ich nichts.

Zur Fehlervermeidung habe ich die neueste Betaflight 4-Version (matek411rx, development) geflasht und das CLI-dump von BetaFPV eingespielt.

Doch weiterhin verliert der Copter die Verbindung, startet aber seit den Flügen an Tag 3 nicht einmal mehr - auch mit vorheriger Betaflight-Version.

Der Copter leuchtet grün konstant, hat also Verbindung zur Taranis.

Auch während der Copter am Configurator per USB angeschlossen ist, verliert er zur Taranis die Verbindung.

Der zweite baugleiche Copter fliegt hingegen problemlos mit selbiger Fernbedienung und BF-Version.

Beim Sturz haben wir die Cam neu gerichtet... die Antenne liegt nicht mehr unbedingt um die Kamera gewickelt, wozu diese aber auch etwas zu kurz ist. Ab Werk war die Antenne scheinbar um die Cam gewickelt. Der FC sieht völlig unbeschädigt aus.

Bei beiden Coptern steht in der Kommandozeile beim Configurator manchmal murks beim Start.

Wo kann der Fehler liegen ? Copter leuchtet grün, verliert dauernd die Verbindung, CLI dump des Herstellers ist eingespielt.
 

GerdS

Erfahrener Benutzer
#2
Du solltest NIEMALS den CLI-Dump einer älteren Betaflight-Version in eine neuere einspielen, damit ist Ärger vorprogrammiert. Flashe wieder die originale Version und lade in diese den CLI-Dump. Wenn Du updaten willst, dann solltest Du anstelle des "dump all" Kommandos lieber das neuere Kommando "diff all" verwenden, welches nur die gegenüber den Default-Werten geänderten Parameter umfasst. Siehe auch hier.

Die Schrott-Zeichen zu Beginn im Terminal sind normal, die habe ich bei meinem 75 Pro ebenfalls immer mal wieder.

Falls das nichts hilft, liegt wohl ein Hardware-Defekt im Empfänger vor, vielleicht auch ein Kabelbruch oder eine kalte Lötstelle.

Gruß Gerd
 
#3
Probier mal den D8 Mode. Das Problem hatte ich beim Mobula7 auch, mit D8 ist das weg.
Die Telemetrie lost Meldung bei Anschluss an USB ist auch normal, kommt vom seriellen Anschluss des RX.
Gruß
Christoph
 

Blebbens

Erfahrener Benutzer
#4
Kurze Gedanken dazu:
Habe gebunden mit D16-CH8.
D16, weil von BetaFPV vorgegeben und CH8 zur Latenzverringerung lt. Oscar Liang.

Würde D8 testen, frage mich aber, warum der andere baugleiche Pro2 mit D16 normal fliegt.
 

Blebbens

Erfahrener Benutzer
#5
So, einer der Pro2 werkelt fein...

Der zweite Pro 2 macht immer noch Probleme...
BetaFPV sagt: Binden in D8, DShot 300, keine Telemetrie.

Ich musste auf Betaflight vom 29.12.18 zurück, das aktuelleste konnte nicht binden.
Aber, binden in D8 zur X Lite mit neuester OpenTX (noheli) funktioniert via cli Kommando bind_rx_spi nicht. Einzig D16 haut hin.

Jetzt verliert der zweite Pro2 nicht mehr so häufig die Verbindung, aber halt manchmal doch noch.

Ich habe die BF vom 29.12.18 eingespielt ohne Full Erase und das cli dump vom Hersteller eingespielt.

Hat jemand einen Tipp, wie man in D8 bindet, wenn scheinbar nur D16 funktioniert?
Und, mache ich einen Fehler beim Flashen?
 

GerdS

Erfahrener Benutzer
#6
Du hast die X-Lite in der EU, also LBT-Version? Wenn ja, dann ist D8 vermutlich ausgeblendet, also nicht im Binde-Menü verfügbar.
Abhilfe ist einfach: Flashe die X-Lite nochmal mit OpenTX und bei der Auswahl vor dem Download von OpenTX darfst Du schlichtweg "EU" nicht ankreuzen. Danach ist die D8-Option da.
Die X-Lite ist sendet auch weiterhin im LBT-Mode, da das interne XJT-Sendemodul ja nicht umgeflasht wurde, sondern nur die Oberfläche.

Gruß Gerd
 

Blebbens

Erfahrener Benutzer
#7
Ah, ich glaube, ich hatte es nicht präzise beschrieben...
Ich habe die FCC-non-EU-Version... diese bietet die D8-Variante durchaus an... aber, Pro2 und X Lite verbinden sich in diesem Modus einfach nicht, was ich D16 kein Problem ist.
 
RCLogger

FPV1

Banggood

Banggood

Oben