ESC 4in1 Problem

#1
Hallo,
beim Umbau meines Copters (APM 2.5) habe ich die einzelnen ESC´s gegen ein 4in1 ESC getauscht.
Bei der Kalibrierung kommen zwar verschiedene Töne, die sich aber ständig wiederholen und nicht aufhören.
Die Kalibrierung kann nicht durchgeführt werden und Motoren drehen nicht.
Habe jetzt zur Überprüfung die Signalleitungen der ESC direkt an den Funkfernsteuerungs-Empfänger angeschlossen.
3 Motoren reagieren wie erwartet - Knüppel in eine Richtung Linkslauf, Knüppel in der Mitte Stop, Knüppel in andere Richtung Rechtslauf.
1 Motor verhält ich aber anders - läuft nur in einer Richtung von Null (Knüppel links oder unten) bis max. Drehzahl (Knüppel rechts oder oben.)
Ist das normal, oder ist ein ESC von den 4 defekt?
 

Bussard

Erfahrener Benutzer
#2
Der 4. wird nur nicht kalibriert sein. Stecke mal an den Kanal den Empfänger und schalte den Empfänger erst ein, wenn der Sender auf dem Kanal maximale Impulslänge hat (~2000µs). Nach dem ersten längeren Ton den Knüppel/ Impuls auf Minimum. Dann sollte er zumindest laufen und später richtig zu kalibrieren sein. Näheres in der Anleitung Deines Reglers.
Macht sich sehr einfach mit einem Servotester.
 
#3
Danke für deine Tipps.
Jetzt habe ich die Regler mit einem Servotester getestet. Das Ergebnis ist das gleiche wie mit der Funke.
Beim Konfigurationsversuch bekomme ich im oberen Bereich folgende Töne:

Melodie
lang, kurz
lang, kurz, kurz
lang, kurz, kurz, kurz
lang, kurz, kurz, kurz, kurz
dann nochmals in anderer Tonlage usw. ohne Ende!

Egal wann (sofort nach den langen Ton, oder am Ende der Aufzählung) ich den Knüppel bzw. Knopf beim Servotester herunterziehe, passiert nichts mehr, keine Töne mehr.
Also mit der Kalibrierung komme ich nicht klar.
Der vierfache Regler hat eine SimonK-Firmware, müßte demnach eigentlich gar nicht konfiguriert werden.

Durch die ewigen Wiederholungen läuft jetzt auch ein zweiter Motor nur in einer Richtung.

Jetzt wieder alles normal eingestöpselt, laufen mit dem Gasknüppel sofort 2 Motoren (diagonal) los sobald ich die Funke einschalte, obwohl MissionPlanner DISARMED anzeigt.

Also alles abschalten. Dann Copter einschalten, (Melodie kommt). Funke einschalten und Copter läßt sich
wieder nicht armen, wie am Anfang und keine der Motoren dreht.

Irgendwie drehe ich mich im Kreis herum. Gegenüber der vorherigen Ausführung hat sich an der Elektronik bis auf die ESC ´s, nichts geändert und bis zum Umbau ist der Copter einwandfrei geflogen.

Was könnte ich noch versuchen?
 

Bussard

Erfahrener Benutzer
#4
Nach der Anleitung Deines 4-fach ESCs vorgehen.

Wenn es die tatsächlich nicht geben sollte, eines der vielen leicht unterschiedlichen Manuals paßt dann schon, da mußt Du durch. Das Lesen macht keinen Spaß, und das Töne hören geht bei mir auch mit dem richtigen Blatt in der Hand viel einfacher. Hier gibt es eine Menge Manuals, auf deutsch und englisch, falls Du bei Deinem Händler/ Hersteller nicht fündig wirst.
 
Erhaltene "Gefällt mir": hardyy
#6
Leider bin ich weiterhin ratlos.
Ich kann jetzt den Vierfachregler kalibrieren. Nach dem Kalibrieren sprechen die Motoren schön gleichzeitig auf die Gaserhöhung an. Im MissionPlanner kann ich die Motoren auch einzeln überprüfen und Drehrichtung checken.
Soweit alles gut.
Nach dem Wiedereinstecken des Akku hört man auch eine Startmelodie aber ich kann nicht armen. Die Motoren drehen nicht.
Alles ist richtig konfiguriert, alles zigmal gecheckt, alles soweit in Ordnung nur am Armen scheitert es jetzt.
Es ist zum Davonlaufen. Woran kann es liegen?
 
Zuletzt bearbeitet:
#9
Was mir noch aufgefallen ist: In der Parameterliste hat ESC den Wert 0. Ist das richtig oder sollte hier eine 4 stehen (4-fach ESC)?
 
#11
So könnte ich mein Problem auch beschreiben.
Aber die Lösung ist für mich nicht nachvollziehbar
Mein Kumpel meinte, ich sollte nochmals die Seitenruderausschläge nachjustieren und plötzlich konnte ich den Flieger armen.
Was meint er mit "Seitenruderausschläge" nachjustieren? Falls damit Rollkanal gemeint ist, der ist kalibriert wie alle Kanäle zwischen 1000 und 1995.

Im Freien, d.h. auf dem Hausdach, habe ich auch getestet.
Bei 7 Satelliten und hdop 2,1 konnte ich immer noch nicht armen.
Auch die Versuche ARMIN_CHECK auf disabled und HDOP auf 200 erhöhen, brachten nichts.

Was ist mit dem Parameter ESC. Der steht auf Null. Irgendwo habe ich gelesen, den könnte man auf 3 einstellen (warum?). Habe ich auch versucht, ohne Erfolg.

Eigentlich ist alles bestens eingestellt, alles getestet, Motorentest ist ebenfalls gut. Nach dem ESC-Kalibrieren kann ich die Motoren auch rauf und runter drehen - aber nicht armen.

Man muß doch das Biest irgendwie zum Fliegen bringen!!??
 

Bussard

Erfahrener Benutzer
#12
Eigentlich ist alles bestens eingestellt, ....
Offensichtlich nicht.
Bei 7 Satelliten und hdop 2,1 konnte ich immer noch nicht armen.
Habe kaum was mit APM zu tun, aber wenn armen nur mit hdop < 2.0 funktioniert, ist >= 2 eben nicht ausreichend, mir schwirrt bei minSat auch eine 8 im Kopf rum, kann aber auch falsch sein.

Schau mal hier

Vielleicht ist das auch gar nicht apm-typisch, und andere FAQ stimmen hier auch...
 
#13
Im MP ist mir in der rechten oberen Ecke aufgefallen: Da sind ein paar grüne Balken, 0% und rot ausgeiXt.
Könnte das evtl. die Ursache sein? Soll die drahtlose Telemetry sein. Die drahtlose Verbindung zwischen PC und Copter ist aber in Ordnung. Oder ist damit etwas anderes gemeint.?
MP.jpg

Update: Die Anzeige ist wieder OK, war ein Versehen!
 
Zuletzt bearbeitet:
#14
Endlich habe ich den Copter armen können. Erst als ich hdop auf 2,5 eingestellt habe, konnte ich armen.
Mal sehen, ob ich im Freien, weiter entfernt von der Bebauung, besseren Wert einstellen kann.
Auf jeden Fall danke für die bisherige Hilfe.
 
#16
Nachhinein ist man natürlich klug.
Die Meldung High HDOP kam nur sporadisch und obwohl der Wert auch mal unter 2,0 lag, konnte ich nicht armen.
Schließlich kam ich dahinter, daß der eingestellte Wert bei 1,4 (140) lag, was kaum zu erreichen ist.
 

QuadCrash

Erfahrener Benutzer
#17
Schließlich kam ich dahinter, daß der eingestellte Wert bei 1,4 (140) lag, was kaum zu erreichen ist.
Würde ich nicht sagen, hab meist Werte von 0,7 - 0,9. Voraussetzung dafür ist, dass der Flieger nach Strom an 'ne Weile ohne "Abschattungen" die Sat-Positionen aufnehmen kann. Schau Dir mal die Werte bzw. deren Entwicklung im Tab "Status" an (1. Spalte).
 
#18
Unter Status sehe ich nur die augenblicklichen Werte. Eine Entwicklung sehe ich nicht.
Ich bin auch mit dem umgebauten Copter noch nicht geflogen. Vorläufig alles nur Tests ohne Propeller.
 

QuadCrash

Erfahrener Benutzer
#19
Nun, Du kannst doch im Status sehen, wie sich der HDOP-Wert "entwickelt". Kann man auch im Log nachvollziehen. Fliegen brauchst Du dafür auch nicht. Stell das Teil einfach draußen hin und lass den MP laufen. Interessant ist dann bspw., wenn Du selbst bzw. Dein Körperschatten für schlechte(re) Werte sorgt. Nachdem ich das mal beobachtet habe, lasse ich den Flieger immer 2-3 m von mir weg seine Satelliten finden. Der HDOP-Wert passt dann auch, ebenso wie das armen.
 
RCLogger

FPV1

Banggood

Banggood

Oben