ESC32 mehr Fragen als Antworten

wolfi187

Neuer Benutzer
#1
Hallo zusammen,

als neuer hier im Forum muss man ja irgendwo anfangen.

Bin gerade dabei einen Hexa zu basteln. Habe mich gleich zu beginn auf die Autoquad FC und ESC fixiert, da ich auch arbeitstechnisch viel mit den STM32 Prozessoren und Leistungselektronik zu tun habe.
Nachdem ich Weihnachten einen Rahmen von mikrokopter geschenkt bekommen habe hat es ein bisschen gedauert bis man was zeigbares produziert hat.
  • Mikrokopter Hexa frame
  • 6 Robbe roxxy 2827-26
  • 6 Graupner 10-5
  • 6 ESC32
  • 1 Autoquad FC

Nach 2 Wochen des rumkalibrierens der ESC´s habe ich nun jede menge Werte gesammelt.
Das ganze Unterfangen hat so lange gedauert weil ich beim ersten Versuch die Erfahrung machen musste, das ohne Fixerung des Gerätes, die pure Gewalt eines Motors schon ausreicht um bekanntschaft mit der Wand zu machen. Also erstmal einen Halter gebaut um das Biest einzusperren und ein paar neue Propeller (auch auf Reserve) zu kaufen.




Danach habe ich auch noch den UARt Stecker um eine raste falsch draufgesteckt, was der Prozessor irgendwie nicht lustig fand und meinte danach zur Heizung zu werden. Also Prozessor getauscht und nun läuft alles.

Nun zu den eigentlich Problemen:
Leider gibt es keine Werte für die Kombi welche von den Entwicklern freigegeben wurde also Loggen.
Habe alle Werte an einem Netzteil bei 11,1 Volt und 20 Ampere gemacht.
Die Kalibrierung bei 9Ampere zum spielen begrenzt.
Da man 6 Motoren hat sollte eigentlich 6 relativ identische Werte FF1,2 CL1,5 rauskommen.
Motor 1:
2,87931E-07
3,18050E-03
5,16826E-01
1,01028E-03
4,31401E-02
-1,52983E-05
9,67161E-01

Motor 2:
1,53658E-30
2,88481E-13
3,93536E-01
1,01819E-03
4,86145E-02
-1,51234E-05
9,62153E-01

Motor 3:
3,12586E-08
1,18235E-03
4,08763E-01
1,03139E-03
2,57152E-02
-3,96690E-06
9,35307E-01

Motor 4:
3,25840E-08
1,15953E-03
4,78879E-01
9,53539E-04
8,31955E-02
-4,64348E-06
7,00507E-01

Motor 5:
1,47378E-36
2,30122E-17
3,41656E-01
1,04429E-03
4,72932E-02
-8,41022E-06
8,96427E-01

Motor 6:
3,45040E-08
1,17703E-03
3,22703E-01
1,05272E-03
5,94544E-02
-1,70546E-05
8,77453E-01

Wie kommen die dramatisch unterschiedlichen Werte von Motor 2 und 5 bei den FF1,2 zu stande.
Weiterhin laufen die sowas von langsam in die Endgeschwindigkeit.
Ich habe die Werte für CL1-5 gemittelt und für die FF´s der "guten Motoren" gemittelt:
3,27822E-08
1,17297E-03
4,05708E-01
1,02603E-04
4,96255E-02
-1,58254E-05
6,77296E-01

und reingeladen. Alles war wunderbar. Alle Motoren laufen gut.
Vielleicht hat jemand eine Idee was sowas verursacht und wie genau die Werte sein müssen.
Leider habe ich Windows und somit keine Möglichkeit die Logfiles in einer Grafik mir anzeigen zu lassen.

Gruß
wolfi187
 
RCLogger

FPV1

Banggood

Banggood

Oben