F411 Wing mag noch nicht armen

chebiqe

Erfahrener Benutzer
#1
Ich wags schon gar nicht mehr was zu posten. Ständig neue unerklärliche Probleme.
Aber was solls, von alleine komm ich nicht drauf.

Lage wird erkannt. Servos reagieren auf Bewegung und Stickeingaben.
Nun bewegen sich auch die Stickeingebebalken korrekt. Nur armen kann ichs nicht.


Jetzt ist dieses 'Settings validated' ständig rot. Laut der wenigen Seiten die ich zu dem Thema fand liegt das an DShot. Was mit meinem BLHeli-Regler aber nix zu tun hat.

In der RCGruppe frug mich jemand warum ich 50 statt 400MHZ eingestellt habe. Ich habs dann halt mal umgestellt auf 400. UND. Jippi, im INAV Motor Master lies sich jetzt der Motor sogar drehen!

'Problem gelöst' dachte ich, ...aber das ist einfach nicht reproduzierbar. :poop:

Weder das gelbe ARM!Icon an das ich mihc errinnere ist zu sehen, noch hilft der Buzzer. Dieser piepst nicht wie beim Omnibus beim Modewexeln, sonder fängst nach einiger Zeit an im Sekundentakt zu piepen.

Wie kann ich wohl diese settings validieren?

postedit:
Das fällt mir gerade im Status auf: Invalid setting: nav_mc_braking_speed_threshold
MC_breaking? Multicopter advance tuning? Ich hab da nix eingestellt!



Status

System Uptime: 765 seconds
Current Time: 2041-06-28T01:04:00.000+00:00
Voltage: 1.48V (3S battery - CRITICAL)
CPU Clock=84MHz, GYRO=MPU6000, ACC=MPU6000, BARO=BMP280
STM32 system clocks:
SYSCLK = 84 MHz
HCLK = 84 MHz
PCLK1 = 42 MHz
PCLK2 = 84 MHz
Sensor status: GYRO=OK, ACC=OK, MAG=NONE, BARO=OK, RANGEFINDER=NONE, OPFLOW=NONE, GPS=NONE
Stack size: 6144, Stack address: 0x20020000, Heap available: 1676
I2C Errors: 0, config size: 4647, max available config: 16384
ADC channel usage:
BATTERY : configured = ADC 1, used = ADC 1
RSSI : configured = none, used = none
CURRENT : configured = ADC 2, used = ADC 2
AIRSPEED : configured = none, used = none
System load: 5, cycle time: 1000, PID rate: 1000, RX rate: 47, System rate: 9
Arming disabled flags: RX CLI SETTINGFAIL

Invalid setting: nav_mc_braking_speed_threshold (invalid klingt nicht gut)


Diff
System Uptime: 765 seconds
Current Time: 2041-06-28T01:04:00.000+00:00
Voltage: 1.48V (3S battery - CRITICAL)
CPU Clock=84MHz, GYRO=MPU6000, ACC=MPU6000, BARO=BMP280
STM32 system clocks:
SYSCLK = 84 MHz
HCLK = 84 MHz
PCLK1 = 42 MHz
PCLK2 = 84 MHz
Sensor status: GYRO=OK, ACC=OK, MAG=NONE, BARO=OK, RANGEFINDER=NONE, OPFLOW=NONE, GPS=NONE
Stack size: 6144, Stack address: 0x20020000, Heap available: 1676
I2C Errors: 0, config size: 4647, max available config: 16384
ADC channel usage:
BATTERY : configured = ADC 1, used = ADC 1
RSSI : configured = none, used = none
CURRENT : configured = ADC 2, used = ADC 2
AIRSPEED : configured = none, used = none
System load: 5, cycle time: 1000, PID rate: 1000, RX rate: 47, System rate: 9
Arming disabled flags: RX CLI SETTINGFAIL
Invalid setting: nav_mc_braking_speed_threshold

# diff

# version
# INAV/MATEKF411 2.1.0 Feb 25 2019 / 17:02:49 (65b0ec142)
# GCC-7.3.1 20180622 (release) [ARM/embedded-7-branch revision 261907]

# resources

# mixer
mmix 0 1.000 0.000 0.000 0.000

# servo mix
smix 0 4 0 -100 0
smix 1 3 0 -100 0
smix 2 4 1 100 0
smix 3 3 1 -100 0

# servo

# feature
feature -TX_PROF_SEL
feature PWM_OUTPUT_ENABLE

# beeper

# map
map TAER

# serial

# led

# color

# mode_color

# aux
aux 0 0 2 900 1700
aux 1 1 1 900 1175
aux 2 2 1 1800 2100
aux 3 26 2 900 1175
aux 4 10 1 1300 1700
aux 5 27 3 900 1150
aux 6 28 3 1875 2100
aux 7 11 3 1650 1900

# adjrange

# rxrange

# temp_sensor

# osd_layout

# master
set acc_hardware = MPU6000
set acczero_x = 119
set acczero_y = -52
set acczero_z = -226
set accgain_x = 4072
set accgain_y = 4086
set accgain_z = 4031
set mag_hardware = NONE
set baro_hardware = BMP280
set pitot_hardware = NONE
set spektrum_sat_bind = 7
set align_board_yaw = 900
set platform_type = AIRPLANE
set model_preview_type = 8
set nav_mc_braking_speed_threshold = 5140
set nav_mc_braking_disengage_speed = 15
set nav_mc_braking_timeout = 1400
set nav_mc_braking_boost_factor = 0
set nav_mc_braking_boost_timeout = 1200
set nav_mc_braking_boost_speed_threshold = 1700
set nav_mc_braking_boost_disengage_speed = 10
set nav_mc_braking_bank_angle = 136
set nav_fw_cruise_thr = 1863
set nav_fw_min_thr = 1000
set nav_fw_bank_angle = 2
set nav_fw_climb_angle = 0
set nav_fw_dive_angle = 44
set nav_fw_pitch2thr = 244
set nav_fw_loiter_radius = 100
set nav_fw_cruise_speed = 40
set nav_fw_land_dive_angle = 0
set nav_fw_launch_velocity = 5000
set nav_fw_launch_accel = 0
set nav_fw_launch_detect_time = 11538
set nav_fw_launch_idle_thr = 20

# profile
profile 1


# battery_profile
battery_profile 1
 

chebiqe

Erfahrener Benutzer
#3
Hat (noch) keinen GPS-Sensor.

Ich hab noch gar nix rumverändert. (Vom Omnibus weis ich dass ich AngleWinkel vergrössern muss, aber soweit bini noch nicht)
Nur einmal ne ältere Version probiert (als ich noch rumgetüfftlet hab wies den Empfänger erkennen.


EDIT.

hab gerade alles resetet. Neu eingestellt. Das ging erstaunlich fix.
Nu is das gelbe Icon da, und die Settings sind endlich validiert.

Läuft.
 
Zuletzt bearbeitet:
RCLogger

FPV1

Banggood

Banggood

Oben