INAV Autolaunch richtig einstellen

brandtaucher

Erfahrener Benutzer
#2
Habe mal die Empfehlungen aus dem Video sowie weitere Infos zusammengepackt. Text unten entsprechend kopieren, in eine Word-Datei einfügen und dann die Werte nach eigenen Vorstellungen ändern und anschließend in die CLI einfügen. So hat man seine Autolaunch-Einstellungen immer parat.

Was ich noch nicht so recht rausfinden konnte, ist nav_launch_velocity = 300. Ich habs zwar gefunden, werde aber noch nicht so richtig schlau daraus. Wird im Video auch nicht erwähnt.

Weiterer Input und Korrekturen natürlich willkommen!

# Grundlegende CLI-Befehle (Eingabe ohne #)
# help - Zeigt CLI-Befehle
# get nav_fw_launch - zeigt Deine aktuellen Autolaunchwerte an
# save - Änderungen in der CLI speichern
# exit - verlässt CLI - speichern nicht vergessen
# diff - zeigt nur die zum Standard veränderten Einstellungen
# dump - zeigt alle gespeicherten Einstellungen

# Befehle des INAV LAUNCH Modes

---- Kopieren unter dieser Überschrift ----

#Maximaler Wurfwinkel - wird Winkel überschritten, erfolgt kein Autolaunch
#Erlaubter Bereich: 5 - 180, Standard 45, Empfehlung 180 Grad, dann wird jeder Wurf erkannt
set nav_fw_launch_max_angle = 45

#Gasposition beim Autostart, 1700 = 70 %
#Erlaubter Bereich: 1000 - 2000, Standard 1700, Empfehlung: eher möglichst hoch, gerade bei großem Steigwinkel, schwachen Motoren oder schweren Modellen
set nav_fw_launch_thr = 1700

#Motordrehzahl nach Scharfstellen vor LAUCH-ERKENNUNG (gefährlich bei Heckmotoren)
#Erlaubter Bereich: 1000 - 2000, Standard 1000 (=0%), Empfehlung bei schwachen Motoren oder Klapppropellern 1200 bis 1400 (20 bis 40%)
set nav_fw_launch_idle_thr = 1000

#Zeitspanne (ms) zwischen Wurferkennung und Motorstart
#Erlaubter Bereich: 0 - 5000, Standard 500, Empfehlung 200 (0,2 Sekunden)
set nav_fw_launch_motor_delay = 500

#Zeitspanne, bis Motor auf volle eingestellte Drehzahl geht (ms)
#Erlaubter Bereich: 0 - 1000, Standard 100, Empfehlung 100
set nav_fw_launch_spinup_time = 100

#Steigwinkel bei Autolaunch in Grad
#Erlaubter Bereich: 5 - 45, Standard 18, Empfehlung bei stärkeren Motoren 25 bis 30, mind. 20, 18 ist sehr wenig.
set nav_fw_launch_climb_angle = 18

#Beschleunigungswert, bei dem AUTOLAUNCH erkannt wird
#Erlaubter Bereich: 1000 - 20000, Empfehlung 1500 bis 1600 bei schweren Modellen
set nav_fw_launch_accel = 1863

#Zeitraum in Millisekunden, in dem der Beschleunigungswert zur Erkennung des Autolaunch überschritten werden muss
#Erlaubter Bereich: 10 - 1000, Standard 40 kann bleiben
set nav_fw_launch_detect_time = 40

#Zeitspanne (ms) in dem der Launchmodus nicht unterbrochen wird, auch nicht durch Stick-Eingaben
#Erlaubter Bereich: 0 - 60000, Standard 0, Empfehlung 2000 (2 Sekunden), um nicht versehentlich den Autolaunch zu unterbrechen
set nav_fw_launch_min_time = 0

# Zeitraum, in dem der Autolaunch durchgeführt wird, danach gelten Einstellungen der Fernsteuerung inklusive Gas, Modus, etc.
# Erlaubter Bereich: 0 - 60000, Standard 5000, Empfehlung 10000 (10 Sekunden, kann durch Stickeingaben unterbrochen werden, aber erst nach Ablauf launch_min_time)
set nav_fw_launch_timeout = 5000

#Höhe in cm, bei dem der Launchmode automatisch abgebrochen wird
#Erlaubter Bereich: 0 - 60000, Standard 0, Empfehlung 50 (Meter) = 5000
set nav_fw_launch_max_altitude = 0

set nav_fw_launch_velocity = 300
#Erlaubter Bereich: 100 - 10000, Standard 300

---- Kopieren bis über dieser Unterschrift ----
 
Zuletzt bearbeitet:
#10
Der Beitrag ist zwar schon etwas älter, aber ich hole ihn mal hoch, weil AutoLaunch bei mir nicht funktioniert. Ich mache eigentlich alles so, wie es verlangt wird.
1 AutoLaunch aktiviert
2 Armen
3 Gas setzten ( ich nehme hier immer Vollgas )
4 Werfen

Ich habe das schon mehrfach mit unterschiedlichen Modellen und FCs ( Matek 405 Wing und 411 Wing ) probiert, immer wieder das gleiche Ergebnis
Im aufgezeichneten Video ist zu erkennen, das im Moment des Wurfs der FC wieder in den normal Betrieb ( also in den Mode, den ich nach dem AL habe will ) zurück geht und deshalb der Wing auch nicht steigt.
Glücklicherweise haben wir es zu zweit probiert, so konnte ich rechtzeitig eingreifen und es gab keinen Crash.
Der FC ist ein Matek 411Wing, INAV 2.5.1

Hier meine Parameter
set nav_fw_launch_velocity = 300
set nav_fw_launch_accel = 1600
set nav_fw_launch_max_angle = 180
set nav_fw_launch_detect_time = 40
set nav_fw_launch_thr = 2000
set nav_fw_launch_idle_thr = 1000
set nav_fw_launch_motor_delay = 200
set nav_fw_launch_spinup_time = 100
set nav_fw_launch_min_time = 0
set nav_fw_launch_timeout = 10000
set nav_fw_launch_max_altitude = 50
set nav_fw_launch_climb_angle = 20

hat jemand eine Idee, warum das bei mir nicht funktioniert

Gruss
Klaus
 
#11
Wirfst du selbst? Kann es sein, dass sich die Gimbals durch den Wurf bewegen? Jede Steuerbewegung bricht den Launch ab.
 

mastersurferde

Erfahrener Benutzer
#13
Hast Du einen Buzzer am Flieger? Damit wird der Autolaunchmode eindeutig signalisiert.
Mit Climb-Angel 20 bin ich nie zurecht gekommen. Ein Wert von 30 führt hier eher zum Erfolg.
Gruß
 
#14
nein, ich werfe nicht selber, sondern mein Kumpel und die Sticks am Sender fasse ich erst dann, wenn ich sehe, das AL nicht funktioniert
Und ein Buzzer ist auch dran, der piept allerdings nicht, wenn ich AL aktiviere.

Ich habe hier mal aus dem Video der Brille den Start raus geschnippelt
Login - Dropbox
 
#16
set nav_fw_launch_max_altitude = 50 dürfte falsch sein, da dieser Wert in cm angegeben wird.
1596571046086.png
Beim Wurf ist der Flieger ja schon höher als 50cm, also wird der launch mode gleich abgeschaltet.
 
#18
@ReinhardZ Danke für den Tip bzw die Korregierung meiner Settings, scheinbar war es das. Ich hatte das eben mal zu Hause im Garten ausprobiert, der Buzzer piept, wennn ich AL aktiviere, nach eine herzhafte Ruck läuft der Motor auch hoch, im OSD Display steht dann auch weiterhin AutoLaunch, Stick Movement beendet dann AL.
Aber shame on me... das hätte ich selber merken müssen, alle Eingaben bei INAV werden in cm vorgenommen ( warum auch immer, kein Mensch wird zB fürs Loitern 71,25cm angeben ).

Wie auch immer, es funktioniert, heute Abend dann Feldversuch

Gruss
Klaus
 
RCLogger

FPV1

Banggood

Banggood

Oben