INAV Modes mit F405

hobby1946

Erfahrener Benutzer
#1
Hallo,

ich bräuchte mal Hilfe beim Einstellen der INAV Modes.

Ich habe auf meinem Mode-Schalter : Manuell - Rate - Angle.
Zusätzlich noch auf einem anderen Kanal NAV-RTH.

Diese Einstellungen funktionieren auch (werden blau beim Umschalten)
und reagieren entsprechend.

Wenn ich nun den FC arme, springt der Mode auf Angle und der Mode-Schalter zeigt keinerlei Wirkung mehr.

Außerdem bekomme ich kein Gas auf S1.

Was stimmt da nicht ?
 

hobby1946

Erfahrener Benutzer
#3
Nach vielen Versuchen habe ich folgendes festgestellt:

Nach dem Armen wird automatisch auf Angle-Mode geschaltet .
Kein Gas möglich.

Erst wenn man bei Gas 0 (-100%) Quer oder Höhe steuert, stellen sich die Modes wieder richtig
und man kann Gas geben.

Code:
# diff

# version
# INAV/MATEKF405SE 2.0.1 Oct 31 2018 / 19:28:11 (a04e68aaa)

# resources

# mixer
mmix 0  1.000  0.000  0.000  0.000

# servo mix
smix 0 3 0 100 0
smix 1 4 1 100 0
smix 2 5 2 100 0
smix 3 6 0 -100 0

# servo

# feature
feature -OSD
feature MOTOR_STOP
feature GPS
feature PWM_OUTPUT_ENABLE
feature FW_LAUNCH

# beeper

# map

# serial
serial 0 1 115200 38400 0 115200
serial 3 2 115200 57600 0 115200
serial 30 32 115200 38400 57600 115200

# led

# color

# mode_color

# aux
aux 0 1 4 1900 2100
aux 1 8 6 1900 2100
aux 2 10 4 900 1075

# adjrange

# rxrange

# osd_layout

# master
set acc_hardware = MPU6000
set acczero_x = 66
set acczero_y = -31
set acczero_z = -208
set accgain_x = 4062
set accgain_y = 4080
set accgain_z = 4013
set mag_hardware = NONE
set baro_hardware = BMP280
set pitot_hardware = NONE
set motor_pwm_rate = 50
set failsafe_procedure = RTH
set model_preview_type = 14
set gps_sbas_mode = AUTO
set inav_w_z_baro_p =  0.350
set nav_rth_allow_landing = NEVER
set nav_rth_altitude = 7000

# profile
profile 1


# battery_profile
battery_profile 1


#

Modes:

vor armen
va1.JPG
21.JPG

nach armen
na1.JPG
va11.JPG
 

olex

Der Testpilot
#5
Genau, "feature FW_LAUNCH" verrät es. Der Flieger armt sofort in den Launch-Modus und wartet auf den Wurf, deshalb wird kein Gas angenommen. Wenn du den rechten Stick bewegst wird Launch abgebrochen und der Flieger verhält sich wieder normal.
 

hobby1946

Erfahrener Benutzer
#6
uuaaahhh .....

Danke für die schnelle Hilfe !
Das mit Launch war keine Absicht.
Das hat sich itgendwie "eingeschlichen" ....

Alles OK.
 

olex

Der Testpilot
#8
Ja, mit Standardeinstellungen muss der Flieger mindestens 5m vom Startpunkt entfernt sein damit der Modus aktiv wird. Lässt sich irgendwo in den Settings ändern, evtl. nur über CLI.
 
RCLogger

FPV1

Banggood

Banggood

Oben