kann APM 2.5 nicht armen

Marko 66

Neuer Benutzer
#1
Hallo
Ich habe meinen Q-Copter bereits geflogen.
Nachdem sich mein Regler 30A durch Kurzschluß ( blankes Kabel ) verabschiedet hat, ersetzte ich diesen durch einen Baugleichen mit 25 A. Der Motortester zeigte, dass alle Motoren drehen. Soweit so gut. Alle Steckverbindungen wurden genauso wie vorher angeschlossen (extra Fotos gemacht :D).
An meiner alten Fernsteuerung (mc12) wurde ebenfalls nichts verändert. Alle Einstellungen blieben unverändert.
Ich fliege mit dem Frsky Modul und hatte nie Probleme.
Verbunden ist mein APM mit dem Missions Planner Version 1.3.41 .
Keinerlei Probleme bei connect. Beim kalibrieren funktioniert der Kompass,die drei Achsen und das GPS mit externen Kompass sowie alle Ausschläge von Gas,Quer,Höhe und Seite. Mein nachgerüsteter Schalter für Stabi,Hold und Loiter ist ebenfalls ok.
Jetzt beginnen die Schwierigkeiten.Obwohl alles soweit eingestellt ist bekomme ich keinen -erledigt- Haken bei RC verbunden.
Nun aber Strom an den Copter. Es ertönt das normale all ready Signal vom Regler. Sogar die Motoren wollen loslegen, zucken aber nur ganz leicht im Rythmus. Ja, der Empfänger hat Bindung mit der Funke, getestet mit Servo.
Um alles auszuschließen, nahm ich sogar meine Taranis mit niegelnagelneuem Empfänger, ohne Erfolg.
Ich habe wirklich schon alles getestet was ging. Ich startete immer im Stabi Modus. Natürlich habe auch auch den Gasweg neu angelernt (sehr oft ! )
Bin nun langsam mit meinem Latein am Ende und hoffe auf Hilfe. Ganz sicher ist es wieder nur eine "Kleinigkeit" die den Flieger am Boden hält.
 

rose1203

Erfahrener Benutzer
#4
Hi, zum Testen schalt doch mal die Prearm Checks aus (im MP), dann siehst du ob es dann geht. Dann aber wieder aktivieren und prüfen woran es liegt, normalerweise gibt es doch im MP HUD genaue Hinweise warum nicht gearmt wurde.
 

Marko 66

Neuer Benutzer
#5
Danke für die schnellen Antworten
Die prearm Ausschaltfunktion habe ich leider in meinem Menü noch nicht gefunden.
Als Fehleranzeige erscheint Prearm no GPS fix.
Auch mit abgesteckten GPS/Kompass geht nichts.
 

leo2e

Erfahrener Benutzer
#6
Hallo,
bei iNav gibts die Option das sich die Motoren ohne Satfix nicht armen lassen. Ev. ist das bei dir auch so?
 

rose1203

Erfahrener Benutzer
#7
Danke für die schnellen Antworten
Die prearm Ausschaltfunktion habe ich leider in meinem Menü noch nicht gefunden.
Als Fehleranzeige erscheint Prearm no GPS fix.
Auch mit abgesteckten GPS/Kompass geht nichts.
Hi, dann würde ich die pre-arm-check nicht ausschalten. Findest du in full parameter list. In der Wohnung ist es auch problematisch einen 3dfix zu bekommen. Versuchs mal draussen, kann auch beim ersten Mal etwas länger dauern. Dann kannst du bestimmt armen.
 

Marko 66

Neuer Benutzer
#9
Ja, dass mit den nichtgefundenen Sateliten in der Wohnng stimmt schon, doch an meinem Basteltisch kann ich über 6 Sateliten verfügen die durch eine durchgehende blaue Lampe signalisiert werden. Auch die Idee mit dem Teil nach draußen zu gehen ist mir schon gekommen,ohne Erfolg. Schade, heute finde ich leider keine Zeit zum basteln.

Vielen Dank für Euer Interesse
 

leo2e

Erfahrener Benutzer
#10
Hallo,
stimmen die "Servo"wege von 1000 - 2000?
 

fandi

Erfahrener Benutzer
#11
Wenn Du den APM standardmäßig im Missionplaner eingestellt hast,
benötigst Du für einen GPS fix mindestens 6 Sat´s und einen HDOP kleiner als 2.
Den HDOP kleiner 2 ist in einem Gebäude fast unmöglich.
Der Wert wird die im Missionplaner auf der Karte, unten links angezeigt.
Lösung: Du schaltest das Pre Arm Check so weit aus (gefährlich) oder Du stellst den angeforderten HDOP Wert so ein, das es erst mal passt (weniger gefährlich).
Wenn Du Geo-Fence eingeschaltet hast, wird der vollständige GPS Fix auch benötigt.

Gefährlich ist: der APM merkt sich die letzte bekannte Home Position, wenn der beim Armen noch die vom letzten Flug gespeichert hat, und dann in der Luft einen GPS Fix bekommt, würde der bei einem RTL zu diesen Homepoint fliegen, evtl. als Failsafe.
den er vom letzten Flug noch kennt. das ist dann ein immer wieder gern gesehener Fly-Away...evtl. Richtung China,
wenn der noch nie einen anderen Homepoint kannte.
 

Marko 66

Neuer Benutzer
#13
Positive Rückmeldung,der Q-Copter geht wieder !
Nachdem ich gestern alle Daten mit einem Kumpel via Internet abgeglichen hatte und zur Sicherheit nochmals alle Kabel entfernt wurden, testeten wir gleich noch die Motoren mit der Motortestfunktion im APM.
Auf jeden Fall hörte nach dieser Aktion plötzlich das "Intervall piepen" auf und das normale "ready to go" der Motoren ertönte (ein verhaltenens Grinsen in meinem Gesicht).
Jetzt konnte es nicht mehr weit sein :))
Alle Servowege und die Drehrichtungen der Motoren sind zu diesem Zeitpunkt bereits ok, doch warum geht das Ding noch immer nicht ?? Mein Kumpel meinte, ich sollte nochmals die Seitenruderausschläge nachjustieren und plötzlich konnte ich den Flieger armen und die Motoren fingen endlich wieder an sich zu drehen. Sicher könnt ihr euch vorstellen,dass ich mir ein - Jaaaa endlich - nicht verkneifen konnte.

Also,falls jemand das selbe Problem hat, einfach mal diesen Weg versuchen.
 
RCLogger

FPV1

Banggood

Banggood

Oben