Keine Flips im Acro Mode? Und wo RC Rates? - MegaPirateNG 2.9 Beta

sandrodadon

Fliegender Maschi
#1
Hi Leute.
Ich habe jetzt endlich MegaPirateNG 2.9 auf mein Crius AIOP v1.1 Board geworfen und bin total begeistert.
Loiter und RTH funktionieren besser als je zuvor unter MultiWii.

Aber ein paar Dinge stören mich noch:

1: Ich habe den Acro Mode aktiviert und kann keine Flips machen - Er hört bei ca 85° Schieflage auf und dreht sich nicht weiter. Woran liegt das und wieso macht MegaPirate das?

2: Wo kann ich die RCRate ändern? Ist ja auch nicht unwichtig für Flips

Ansonsten läuft alles gut, Acro soll für mich aber auch wirklich Acro sein ;)
Für mich fühlt es sich weiter an wie Stable.
LG
Sandro

PS: Bin gerade ganz tief in den APM Optionen - Kann es am ACRO_TRAINER enable liegen?
Wieso ist sowas vor-aktiviert?
Aber dort geht es ja nur ums Leveln, nicht um eine Flip-Sperre oder?
Vielleicht ACRO_BAL_ROLL auf 0 anstatt 0,2 ?
 
Zuletzt bearbeitet:

sandrodadon

Fliegender Maschi
#2
Anscheinend habe ich die Antwort im 2.9.1 Changelog gelesen (Kommentare) - Werde es heute auf dem Feld testen
Achtung, im Gegensatz zu MultiWii muss man hier anscheinend den Expo im Sender einstellen !
Hatte eben Acro_P auf 7 und hätte mich im Zimmer fast umgesäbelt (315°/S)


These things are first and foremost for people to learn to fly ACRO. A beginner can adjust these settings to get flying characteristics from a smooth STABILIZE to a rock solid ACRO by adjusting the auto balance percentage. For your taste I would recomend:
ACRO_BAL_PITCH of 0
ACRO_BAL_ROLL of 0
ACRO_P of 4.5 to 9 (202.5 deg/s to 405 deg/s)
ACRO_TRAINER,1 (0 if you want to do flips but you can't do loops yet)


It also is very good for high speed FPV flying. I find I can get very good video by setting the
ACRO_BAL_PITCH of 0
ACRO_BAL_ROLL of 100
ACRO_P of 4.5
ACRO_TRAINER,1
This lets me set my pitch for speed and then leave it there but the auto balance on roll keeps my camera level and I use Yaw to navigate.


For a beginner that wants to learn to fly ACRO I would suggest starting with
ACRO_BAL_PITCH of 100
ACRO_BAL_ROLL of 100
ACRO_P of 4.5
ACRO_TRAINER,1

Then slowly reduce ACRO_BAL_PITCH and ACRO_BAL_ROLL to 0 as you feel comfortable then you can increase ACRO_P if you like (be careful it gets FAST).


Hope this explains why we have done it this way. I would be very interested in getting your feedback on the current ACRO performance. I hope to improve this further to work int he body frame soon.
 
Zuletzt bearbeitet:

sandrodadon

Fliegender Maschi
#3
So ein letzter Beitrag noch:

1: ES KLAPPT ! Flips sind möglich - Deutlich größer als bei MultiWii aber ich habe ACRO_P ja noch nicht hoch gedreht ;)

2: Die Flips über die Roll Achse klappen, die Flips über die Pitch Achse klappen.
ABER:
Flips über beide Achsen (quasi Stick nach unten links) klappen NICHT.
Dort fängt er sich wieder selbstständig auf und blockiert mitten im Flip.

Hat da jemand eine Idee oder Lösung?
Vielleicht ACRO_AXIS?
Sonst gibt es nicht viel einzustellen

LG
Sandro
 

sandrodadon

Fliegender Maschi
#5
Hi Franky - Genau auf so eine Antwort habe ich gehofft - Danke !
Werde es heute ausprobieren - Der beschnittene Acro Mode ist das einige was mich im moment noch stört.

Meine bisherigen Settings:

ACRO_BAL_PITCH of 0
ACRO_BAL_ROLL of 0
ACRO_P of 4.5
ACRO_TRAINER = 0
AXIS_ENABLE = 1
Damit gehen Flips schon ganz gut aber noch nicht so toll wie bei MultiWii (z.B. auch nicht über 2 Achsen gleichzeitig)

Desshalb werde ich jetzt noch folgendes ändern:
AXIS_ENABLE = 0
ACRO_P werde ich auch hoch setzen auf 6 oder 7
Aber nur in Verbindung mit einem stärkeren Expo im Sender (MultiWii hatte glaube ich 0,65 Expo)

Ich werde die Tage berichten ;)
Danke für deine Antwort
 
Zuletzt bearbeitet:
RCLogger

FPV1

Banggood

Banggood

Oben