Kk mini Motoren drehen immer weiter auf

#1
Hallo erstmal.

Ich habe vor einiger Zeit meinen ersten eigenen Quad zusammengestellt, besitze allerdings Erfahrung mit professionellen Geräten. Ist praktisch mein erstes Do-it-yourself Bastelprojekt. Nachdem ich ihn konfiguriert hatte bin ich raus auf die Wiese und habe festgestellt, dass er immer nach links giert. Also zurück auf den Arbeitstisch.
Dort fiel mir dann auf dass der Quad sein Standgas nicht hält! Wenn ich von Idle auf 2 gehe, also Minimum Throttle, dann drehen alle Motoren an und sind dann auf einer angemessenen Geschwindigkeit. Jedoch drehen die Motoren danach immer weiter auf, als ob ich den Throttle auf Maximum ziehen würde. Wenn ich die Escs direkt an den Empfänger anschließe passiert dies hingegen nicht, muss also am KK liegen. Da ich inzwischen mit meinem Latein am Ende bin hoffe ich ihr könnt mir dabei helfen dies zu beheben.

Ich verwende einen KK-Mini mit Steveis aktueller Firmware (1.19S1?), 4 AfroESCs mit aktuellem SimonK. Der KK ist zentral auf dem Quad montiert. Bei Receiver-Test sind die Sticks alle korrekt eingestellt, bei Receiver-Sliders verändern sich die Werte auch nicht ohne Eingabe.Throttle Sticks Scaling ist auf 90. Minimum Throttle steht auf 10, könnte theoretisch auch auf 7 runter aber wozu. Quad Acc wurde mit Wasserwage kalibiert, ist sicherlich nicht perfekt aber sollte zumindest nicht für solch ein komisches Verhalten sorgen. ESCs wurden auch kalibiert.
 

Arakon

Erfahrener Benutzer
#2
Wenn das Ding auf dem Tisch steht drehen einige der Motoren stetig weiter hoch, weil der FC versucht, die Schräglage auszugleichen.. und die hast du mit Sicherheit, da du das Teil nicht 100% exakt so ausgerichtet hast, wie es beim Kalibrieren war.
Das ist völlig normales Verhalten.
Das Gieren kann sehr gut an der Funke liegen, hast du im Receiver Test alles auf 0/Idle stehen, wenn du die Sticks nicht anfasst?
 
#3
Ja die Vermutung mit der Schräglage hatte ich auch zuerst, aber dann dürften nicht alle Motoren gleichmäßig aufdrehen. Im Receiver Test ist alles ok, deswegen wundert es mich ja.
Ich hab vorne nen andersfarbigen Prop drauf, aber der ist vom selben Hersteller und hat eigentlich die gleichen Werte. Werde morgen trotzdem mal den vorderen Prop wechseln, vielleicht löst sich damit das Gier-Problem.

Nachtrag:
War gestern, trotz starkem Wind, draußen und habe noch einige Testflüge gemacht. Bei den Motoren hat Arakon recht, die drehen bei einem Bekannten auch auf wenn man den Quad einfach auf Standgas stehen lässt. Finde ich interessant, hatte ich so nicht erwartet weil das bei den "großen" Multikoptern bei mir sonst nicht so vorkommt.
Der Flug selbst war eher nicht so doll. Die PID Werte stimmen halt überhaupt nicht und das Ding fliegt sich schrecklich schwammig. Muss ich mich die Tage mal ran setzen. Leichtes gieren habe ich gefühlt immer noch, aber gestern war einfach viel zu viel Wind um irgendwas vernünftig testen zu können.
 
Zuletzt bearbeitet:

bananenflip

Neuer Benutzer
#4
So, war jetzt mehrfach mit draußen. Meistens war wenig bis kein Wind. Der Quad giert immer nach links. Ich muss definitiv alle paar Sekunden zurück gieren, was meines Erachtens nach einfach nicht sein darf. Hatte auch die Props gewechselt und habe jetzt überall die gleich(farbigen) drauf. Macht allerdings keinen Unterschied. Wäre für weitere Vorschläge/Hinweise dankbar. :)
Ansonsten mach ich das Board morgen mal platt und stell alles nochmal neu ein...
 

brandtaucher

Erfahrener Benutzer
#5
Stimmt der Schwerpunkt?
 

bananenflip

Neuer Benutzer
#6
Naja so halbwegs. Ohne Akku sorgen die Stromkabel dafür, dass es auf der Rollachse nicht ganz stimmt. Hatte es mit dem Akku mal ausbalanciert, hat aber gefühlt nichts gebracht. Die Nickachse stimmt eigentlich, ist ja auch nichts schief verbaut.
Der Selbstbau-Quad (MultiWii) von einem Kollegen sieht da ganz anders aus, da sind die Arme teils überhaupt nicht symmetrisch (weil schief gebohrt :D ), geschweige dass der Schwerpunkt austariert ist. Und das Ding steht einfach in der Luft, da gibts nichts zu meckern. Wobei mein Quad auch relativ ordentlich steht, bis auf das gieren halt.
 

brandtaucher

Erfahrener Benutzer
#7
Naja so halbwegs. Ohne Akku sorgen die Stromkabel dafür, dass es auf der Rollachse nicht ganz stimmt. Hatte es mit dem Akku mal ausbalanciert, hat aber gefühlt nichts gebracht. Die Nickachse stimmt eigentlich, ist ja auch nichts schief verbaut.
Der Selbstbau-Quad (MultiWii) von einem Kollegen sieht da ganz anders aus, da sind die Arme teils überhaupt nicht symmetrisch (weil schief gebohrt :D ), geschweige dass der Schwerpunkt austariert ist. Und das Ding steht einfach in der Luft, da gibts nichts zu meckern. Wobei mein Quad auch relativ ordentlich steht, bis auf das gieren halt.
Kann man alles machen, ist aber murks. Die FC regelt das weg, solange Reserven da sind. Bei extremen Manöver kann sowas einem den Copter kosten, weil aufgrund des Ungleichgewichts der Copter überzogen wird und sich dann wegdreht.

Sind bei Dir alle Propeller komplett frei oder wird der Propellerabtrieb unregelmäßig durch Rahmenteile, Kabel etc. beeinflusst?
 

bananenflip

Neuer Benutzer
#8
Nein da hängt nichts. Hab mal ein Bild vom Quad hinzgefügt (Kabel vom Empfänger ersetze ich noch durch ein paar kürzere). Werde jetzt erst einmal den KK resetten und ein paar ordentliche Carbonprops (11x5, aktuell 9x5) drauf schrauben. Falls das nichts bringt werde ich den Quad ordentlich ausbalancieren und schaun ob das was bringt.
IMG_0252.JPG
 
RCLogger

FPV1

Banggood

Banggood

Oben