Loitermode in Megapirate?

#1
Hallo zusammen,

da ich mich erst seit kurzem überhaupt mit dem Thema Multicopter beschäftige und mir nun meinen ersten selbstgebauen Quad zusammen geschustert habe kommen natürlich auch gaaaaaannnnz viel Fragen.

Die Hardware ist schon zusammengebaut, 520er Rahmen, emax Motoren und ESC, FC ein AIOP V1.1 von HK mit einem Neo 6m GPS Modul und einem Orange RX615.
Als Software läuft die MPNG 3.1.5 und Compass und ACC sind calibriert, GPS zeigt auch nach kurzer Zeit einen 3D Fix.
Erste Schwebeversuche heute bei Windstille waren sehr gut :) im Stabilze Mode liegt das Teil schon sehr ruhig mit minimalem Drift (ungetrimmt) in der Luft und das mit Grundeinstellungen ... habe ich mit Multiwii nie so hinbekommen ... schalte ich jedoch in den Loiter Mode, zappelt der Kopter kurz und driftet dann relativ schnell in eine Richtung ab und lässt sich nicht wirklich steuern, zurück auf Stabilze fängt er sich sofort wieder und ist normal steuerbar.

Ich muss allerdings zugeben das ich bissher weder das Baro abgedeckt habe noch irgendwelche Einstellungen geändert habe ;)

Vielleicht kann mir aber doch jemand einen Tip geben was ich als nächstes einstellen sollte oder machen sollte da mir doch die Erfahrung fehlt ... :confused:

LG AgimA
 

hulk

PrinceCharming
#2
Baro abdecken ist pflicht. Vibrationen einmal mitloggen.wenn das board das überhaupt kann....nicht jedes crius hat flashspeicher.
Dann schauen ob die compass orientierung stimmt....mit einem handycompass vergleichen.
Deklination auf Auto lassen..hat bei immer gereicht.
Compassmot durchführen. Abweichung größer 30% fc höher setzen und noch einmal testen. Alternativ einen externen compass verwenden.
Prinzipiell noch das schwebegas einstellen.
 
#3
Ok ... Baro ist abgedeckt zunächst noch provisorisch, ich denke ich werde eine platte über die FC setzen die dann auch den Schaumstoff hält. Compass passt ... Loggen kann das Board wohl nicht zumindest habe ich das so rausgelesen... Compassmot wird gemacht sobald die neuen Akkus da sind ... GPS ist bei 8 -10 Sat. recht genau lt. Anzeige auf dem Tablett teilweise sogar unter 2 m ... FC sitzt schon ca 5 cm von der Stromversorgung entfernt, ok der Akku nicht ?! Aber das müsste ich dann ja sehen wenn ich Compassmot mache richtig ?
Und Schwebegas einstellen muss ich erstmal lesen wie das geht ^^

LG AgimA
 
#5
Hmmm ... wie ich grade feststellen musste geht das mit dem Compassmot nur wenn ein Strom- Spannungssensor angeschlossen ist ... und der kommt erst noch ... also auf die ToDo Liste damit.

LG AgimA
 
#8
Dann hab ich wohl was falsch gemacht ...oder es geht via Blauzahn nicht. Habe es sowohl über den Mission Planner als auch über den Planner 2.0 probiert bei beiden keine Anzeige oder so... Na egal bin jetzt die Woche über eh nicht zu Hause ...werde es am WE nochmal probieren
Btw. Compass scheint aber zu passen simple Mode in Stabilize geht hervoragend. :)

LG AgimA
 
RCLogger

FPV1

Banggood

Banggood

Oben