OPenXsensor: Ein schneller Einstieg

Bussard

Erfahrener Benutzer
Ich hatte mir halt vorgestellt ohne Moderation, praktisch Copy und Paste, das auch nach längerer Zeit nix in der Fülle der Beträge verloren geht, wäre schade. ...
Nach 3 Minuten ist der erste Kommentar zu einem Beitrag da, der einen weiteren nach sich zieht.
Funktioniert nur wie bei der Wissensdatenbank angedacht, braucht aber eben laufende Pflege= Moderation.
Alternative: eigene Initiative mit Webseite und Gastbeiträgen.

Gruß
 

Gruni

Erfahrener Benutzer
Hallo zusammen,
Heute kam Post, zwei Tütchen in Silofolie😀
Meine Bestellung waren 3x 3.3v 8MHz und 3x 5V 16MHz.

Leider steht hinten nicht drauf, was was ist.....
Hab den Inhalt von Tüte 1 links untereinander gelegt, Inhalt Tüte 2 rechts untereinander.
Einziger Unterschied ist das Bauteil direkt oberhalb RAW, nämlich Aufschrift 5 und rechts Aufschrift 000.
Die Aufschrift auf dem Quarz ist sogut wie nicht lesbar.
Gibt es eine Möglichkeit die Type irgendwie auszulesen?

Grüsse Gruni
 

Anhänge

Gruni

Erfahrener Benutzer
Hallo zusammen,
Hab jetzt mal eine Lupenbrille über die LED Lupe gehalten und den minimalen Schärfebereich genutzt.
Und Tatsache: da kann man tatsächlich den mikroskopisch kleinen Eindruck auf den Quarzen und die Gravur, wenn auch sehr schwer lesbar auf dem Regler lesen.
Auf dem vermutlich 3,3v Ardu haben alle drei Ardus jeweils 8irgendwas auf dem Quarz und 4irgendwas auf dem Regler.
Auf dem vermutlich 5v Ardu steht auf dem Quarz/Resonator jeweils A. Und S8R... auf dem Spannungsregler.

Aber ohne doppeltgemoppelte Lupe vermutlich keine Chance auf ident. Ausser vielleicht ein Auslesen des Ardus selber, falls das möglich ist....

Grüsse Gruni
 

kalle123

Jugend forscht ....
Hi Gruni, du Mann von Welt.

Glaube, den Link zum YT Video hat ich in div. Foren schon ein Paar mal gepostet.


Nebenbei, machst du jetzt in Serienproduktion?

LG KH
 

Gruni

Erfahrener Benutzer
Hallo Kalle, Du Forscher ;->
Ja, das Video kannte ich, das hattest Du ja mal gepostet. Zu Konverterzeiten hatte ich mich nie drum gekümmert, vielleicht gabs ja deswegen mit der Jetikonvertiererei so blöde Probleme.

Anyway: An den Sensoren bestand bis dato nie wirklich Bedarf. Bisher haben wir immer die SM Unisense benutzt, da auch hier die unterschiedlichen Protokolle genutzt werden können.
Als ich vor ein paar Tagen gesehen habe mit wie wenig Aufwand zB das Vario "gebaut" werden kann, da konnte ich einfach nicht nein sagen ;->
Da wir Frsky, Jeti und MPX einsetzen kann man ja nicht widerstehen. Und vielleicht hab ich jetzt mal endlich ein Erfolgserlebnis mit den Ardus.:):):)

Grüsse vom Niederrhein an den Niederrhein, Gruni
 

Gruni

Erfahrener Benutzer
Hallo zusammen,
das erste Vario funktioniert (BMP280) mit Frsky.
Ich habe dann mal die basic_config.h auf das Jeti-Protokoll geändert.
Nach dem umflashen den Sensor an einen alten (einen der ersten) R6 angeschlossen, die Jetibox an meiner Evo mit Jeti-Modul zeigt unter MX aber nur ._._._._. an.
Funktioniert das .INO nur mit Jeti-EX?

Das MPX-Equippment treibt sich im Moment in France bei Pascal rum... kanns also nicht testen.

Hott wäre noch vorhanden, da ist aber der Sender ausserhäusig.

Grüsse Gruni
 

Gruni

Erfahrener Benutzer
Hallöle,

ich habe jetzt 3 Varios mit BMP280 zusammen, die löterei wurde immer besser, jetzt habe ich wohl die Beste lösung gefunden, sehr guter Kompromiss aus mechanischer stabilität und Kompaktheit.
Die Progerei mit dem FTDI reinstecken und unter leichtem biegen gefiel mir gar nicht, daher habe ich ne Buchsenleiste maximal in der Höhe abgeschliffen und eingelötet. Habe aber 90Grad Winkelbuchsenleisten bestellt, dann wird das ganze noch flacher..

Jetzt kommt der Problembär:
Frsky funktioniert,
JETI macht Probleme. Ich habe jetzt nen 6er EX-rx zur Verfügung. Mit der Jetibox am TG-EX gibts wieder nur die ._._._._._._.-Linie angezeigt. Das selbe wie unter Duplex ohne EX.
Klappt die Anzeige eventuell nur mit Jeti-Sendern?

MLink kommt hoffentlich morgen oder Sonntag dran.

Fragende Grüsse Gruni
 

kalle123

Jugend forscht ....
Gruni, du Mann der Praxis, schaff dir doch z.B. mal nen Unisense-E an. Der funktioniert mit allen deinen Systemen. Und dann siehst du auch, op deine Kette 'Sensor - RX - TX Modul - TX Display' funktioniert.

Damit kannst du dann Einiges aus der Kette raus streichen und dich auf die verbliebenen Punkte - oXs Konfiguration und auf deine Lötkunst konzentrieren.

Bei Jeti kann ich nicht helfen. Und MLink funktioniert. Punkt!

Grüße KH
 
Hallöle,

ich habe jetzt 3 Varios mit BMP280 zusammen, die löterei wurde immer besser, jetzt habe ich wohl die Beste ..

Jetzt kommt der Problembär:
Frsky funktioniert,
JETI macht Probleme. Ich habe jetzt nen 6er EX-rx zur Verfügung. Mit der Jetibox am TG-EX gibts wieder nur die ._._._._._._.-Linie angezeigt. Das selbe wie unter Duplex ohne EX.
Klappt die Anzeige eventuell nur mit Jeti-Sendern?
Fragende Grüsse Gruni
Gruni,
die angehängte Konstellation funktioniert mit Jeti. Dies habe ich bei Vereinskollegen getestet. Jedoch habe ich bei denen den MS5611 verwendet, egal. Eventuell musst du beim MP280 die VARIOHYSTERESIS auf 5 stellen, der MS5611 ist so gut, dass du die Angleichung nicht benötigst.

Da du den oXs im Normalfall nur einmal mit Firmware betankst, kannst dir die gewinkelten Stecker sparen.
Mit Jetibox und tralala machst du Winkelzüge. Keine Ahnung wie sich dass auf die Telemetrie auswirkt.
 

Anhänge

Gruni

Erfahrener Benutzer
Hallo Kalle, du Forscher,

ich glaube dass wir diese Diskussion schon hatten;-)
Ich/Wir verwende die SM unisense schon seit Jahren mit Frsky,Jeti, Mlink.
Von daher sind die Ketten abgeklärt.
Wie sich nach einem intensiven Internetrechercheabend parallel zur RTL dancing und pochering-Veranstaltung gezeigt hat, gibt es den .-.-.-.-. Effekt bei mehreren Jetiusern.
Das hat wohl nix mit Hard/Software problemen seitens oXs zu tun, sondern mit dem Einleseverhalten der Jetisender. Da ich keinen Jetisender habe, sondern "nur" Module in Evo, Cockpit und 3030 und das EX TG2 fur die Tanja, ist das fur meinereiner schwer nachzuvollziehen. Der Telemetriekonverter für Jeti liegt funktionslos gaaaaaaaaanz hinten auf dem Modulfriedhof und wartet auf Wiederauferstehung.

Bei uns auf dem Platz sind mittlerweile etliche Jetisenderuser, da werde ich mal nachforschen. Der Platz wurde unten Bestimmungen wieder freigegeben. Schaun wir mal.

PS, danke Robert. Da wir die Jetimodule in diversen Sendern nutze ist die Nutzung der JB reine Notwendigkeit und tatsachlich ein recourcenschonender Winkelzug. ;-))

Grüsse Gruni
 
Hallo Gruni,
bei der Jeti Telemetrie gibt es zwei Protokolle, ein Text und ein Datenprotokoll. Die Jetibox kann nur die Texte aus dem Textprotokoll anzeigen. Und so ein Text wird bei oXs nur bei der Durchflussmessung übertragen, sonst halt die .-.-.-.-.. Ein Jetisender kann aber beides und zeigt auch alle oXs Werte an.

Gruß Dirk
 

kalle123

Jugend forscht ....
Gruni, hast recht. Darüber (unisense) haben wir uns schon mal unterhalten. Ist aber Jahre her ... ;)

Zu den 6 pol Anschluss am Pro Mini. Ich löte die angewinkelten Pins da fest an, aber brauch zum Flashen nur TX, RX, GND und 5V. Einer der beiden freien Pins nehm ich mit GND und 5V für die Telemetrie zum Empfänger. Muss ich halt auf der 'Umverpackung' des oXs notieren, aber für mich die einfachste Lösung.

Frohes Schaffen - KH
 

Gruni

Erfahrener Benutzer
Hallo zusammen,
nachdem ich die Varios mit BMP280 mit Frsky und MPX am laufen habe, war/ist jetzt ein GPS am Start.
Das Modul ist Huckepack auf nem 16MHz/5V Promini installiert.
INO entsprechend Frsky und dem GPS angepasst, geflasht und an den SPort vom Test-RX8Rpro angeschlossen.

Zunächst passiert mal nichts beim Suchen der Sensoren, nur RSSI und RxBat. War wohl klar, da noch keine Sats gefunden wurden.
Also das Pack auf die Terasse gelegt und suchen gelassen. Nach ein paar Minuten ging das GPS-Modul von Dauerrot auf Blinkrot, GPS sollten also gefunden sein.
Leider werden aber beim Sensorsuchlauf keine Daten/Sensoren gefunden.

Spasseshalber habe ich mal ein Oszi in die Datenleitung zum SPort eingeschleift, erstmal ein Vario. Dann das GPS.
Das Oszimuster ähnelt! dem Muster vom Vario. Ich vermute also mal, daß der Signalpegel ok ist, über die Signalinhalte kann ich erstmal nichts sagen. Optisch sieht es aber zumindest ähnlich aus.

Am GPS-Modul selber gibts nur 4 Anschlüsse, GND, VCC, RX und TX.
Die TX-Leitung wurde wie in der Anleitung beschrieben mittels Jumper unterbrechbar gemacht.
Die RX-Leitung ist über einen 10kOhm-R an den Ardu D6-Pin angebunden.
Die beiden SCL und SDA Anschlüsse gibt es nicht am Sensor, wenn ich es richtig verstanden habe sind diese Leitung auch "nur" für den Kompass.

Was kann das sein?

Ich will mir noch ein paar BN280 oder BN180 bestellen, da die Dingers aber ne ziemliche Lieferzeit haben musste ich erstmal ne lokale Quelle anzapfen. Preis ist mit unter 10Euro ok. Baugrösse ist auch ok, kleiner brauch ich es im Moment nicht. Externe Antenne ist blöd, aber ok, zum Testen ist das ok.

Irgend eine Idee?

Grüsse Gruni
 

Anhänge

QuadCrash

Erfahrener Benutzer
Also das Pack auf die Terasse gelegt und suchen gelassen. Nach ein paar Minuten ging das GPS-Modul von Dauerrot auf Blinkrot, GPS sollten also gefunden sein.
Leider werden aber beim Sensorsuchlauf keine Daten/Sensoren gefunden.
Klingt danach, als hättest Du RX/TX nicht über Kreuz verbunden.
 

Gruni

Erfahrener Benutzer
Hallo QC,

Im Plan steht eigentlich GPS RX auf D6 und TX auf Ardu RX.

Und so ist es angeschlossen. Ich bau es morgen nochmal auseinander..... Man weiss ja nie...

Grüsse Gruni
 

kalle123

Jugend forscht ....
Gruni, wenn hier ein GPS Modul ankommt, erst mal an nen USB Uart und so an den PC dran hängen. (Und wenn du keinen Uart zu Hand hast, ein Nano oder Uno geht auch. Und wenn du kein Terminal Programm auf dem Rechner hast, das Terminal der Arduino IDE nehmen.)

Da solltest du dann schon sehen, was das GPS Modul macht, bevor du das an nen Arduino Pro Mini 'ran pappst' mit oXs.

Gerade mal gemacht, sollte so was 'ausspucken'.



Was hast du denn überhaupt für ein Modul? Die Dinger sind so groß wie ein 1 Cent Stück.

Gruß KH

PS. ... und pack dir mal U-Center auf den Rechner. Sieht aktuell hier mit einem M8N so aus



Nix dolles, das Modul liegt hier neben mir auf dem Schreibtisch und die Jalousie ist halb runter.

Wenn das nicht funktioniert, brauchst du gar nicht erst mit oXs anzufangen.
 
Zuletzt bearbeitet:
RCLogger

FPV1

Banggood

Banggood

Oben