PID Einstellungen

keilie

Erfahrener Benutzer
#1
Hallo Autoquad Nutzer,

habe endlich nach über einem Jahr mal den Autoqud M4 in einen Kopter verbaut und habe gestern den ersten Testflug absolviert.
Als langjähriger Wookong und NAZA Nutzer habe ich so meinen Respekt vor den tausenden Parametern und deren genaue Einstellung gehabt, dass ich mich lange gescheut habe den guten Autoquad zu verbauen und dann auch damit zu fliegen.

Jetzt habe ich zwar fliegbare Einstellungen gefunden aber bin bei weitem nicht damit zufrieden.

Hier ein kurzes Video vom Erstflug und die dazugehörigen PID Einstellungen

https://vimeo.com/200676806

Die Eckdaten vom Kopter:

ca. 1500g Abfluggewicht
ESC32 uber CAN
T-Motor 4006
17'' Props

Wie man im Video erkennen kann schwingt der Kopter nach einem leichen Windstoß lange und ausgiebig nach. Mir ist allerdings nicht ganz klar welchen Parameter ich verändern soll.

Vielen Dank im voraus

Reiner
 

Anhänge

r0sewhite

Erfahrener Benutzer
#2
Hallo Reiner,

das wundert mich bei Deinen PIDs nicht wirklich. Angle P ist mit 30 extrem weit unter einem durchschnittlichen Wert. Kriegst Du ihn echt nicht höher? Das langsame Auspendeln wird an Deinem Rate D liegen, der mit 300 auch extrem niedrig ist und dafür sorgt, dass Dein Copter stark verzögert reagiert.
 

keilie

Erfahrener Benutzer
#3
Ok werde ich mal versuchen
Das mit Rate D gefällt mir auch nicht aber bei höheren Werten hatte ich massive Probleme, dass die Motoren überhaupt rund laufen. Es ging soweit , dass einzelne Motoren einfach ausgegangen sind. Das war auch ein Grund warum ich den den Autoquad immer wieder zur Seite gelegt habe.
Ich werde den Kopter wie im Video auf der Autoquadseite zwischen zwei Bänder spannen und versuchen die Werte weiter hoch zu drehen.
Soll ich erst mit Angel P beginnen und welcher Wert wäre wünschenswert? Der Kopter soll nur sehr gemächlich und möglichst stromsparend unterwegs sein. Er muß auch nicht für stärkeren Wind geeignet sein, dafür habe ich andere Modelle. Er sollte halt nur nicht beim leichtesten Windhauch so lange auspendeln.

Reiner
 

r0sewhite

Erfahrener Benutzer
#4
Wenn Du die Regelung mit D so weit abwürgen musst, damit die Motoren auch ja keinen plötzlichen Schub kriegen, stimmt mit Deiner ESC-Konfiguration irgendwas nicht. Hast Du ESC32? Wenn ja, v2 oder v3? Die Motoren dürfen bei gar keinem Gasstoß ausgehen, egal wie stark er ist.

Bei Angle P würde ich zumindest versuchen, über 100 zu kommen. Darunter hatte ich noch nie.
 

keilie

Erfahrener Benutzer
#5
Habe ESC32 V3 an CAN Bus
Die Motoren gehen nicht bei einem Gasstoß aus sondern bei langsamen vorsichtigenm Gas geben.
Habe anfangs auch die Motoren und ESCs in verdacht gehabt und mehrfach Motoren und ESCs und auch CAN Adressen getauscht hat aber alles keinen Erfolg gebracht.
Die ESCs laufen mit den Motoren über Servotester und auch mit Ansteuerung über USB Problemlos und sauber und sind alle sorgfältig kalibriert.
 

r0sewhite

Erfahrener Benutzer
#6
Die Kalibrierung sagt ja nichts darüber aus, ob die ESCs ordentlich konfiguriert wurden. Wenn sie ausgehen, dann in der Regel wegen Kommutierungsverlust. Ich würde den Fehler mal provozieren und dann mit der Konsole den Fehlercode am ESC auslesen. Wenn die Kommutierung verloren geht, dann kriegst Du das meistens mit richtigem Timing und evtl. Switching Frequency in den Griff. Mit Deinen PID-Werten des AQ solltest Du jedenfalls keinerlei Rücksicht darauf nehmen müssen.
 

keilie

Erfahrener Benutzer
#7
Ok wiekann ich mit der Konsole den Fehlercode auslesen? Habe mit der Konsole noch nicht gearbeitet.
Wo finde ich die Beschreibung zu den Komandos?
 

keilie

Erfahrener Benutzer
#9
Die Kalibrierung sagt ja nichts darüber aus, ob die ESCs ordentlich konfiguriert wurden. Wenn sie ausgehen, dann in der Regel wegen Kommutierungsverlust. Ich würde den Fehler mal provozieren und dann mit der Konsole den Fehlercode am ESC auslesen. Wenn die Kommutierung verloren geht, dann kriegst Du das meistens mit richtigem Timing und evtl. Switching Frequency in den Griff. Mit Deinen PID-Werten des AQ solltest Du jedenfalls keinerlei Rücksicht darauf nehmen müssen.
Habe noch mal alle möglichen Einstellungen an den ESC's ausprobiert, aber alles bringt nur bedingt Erfolg.

Wenn ich das Timing vergrößere wird es ein wenig besser aber die Probleme mit den stopenden Motoren bleiben. Bei Veränderung in Richtung 0° wird es noch viel schlimmer.

Wenn ich die Switching Frequency verändere hat es keine merlichen Auswirkungen. Die Motoren klingen in bestimmten Bereichen nur fürchterlich.

Das einzige was hilft ist das Braking auszuschalten. Das möchte ich allerdings nicht, da die Motoren dann ca. 8% mehr Leistung benötigen.

Hat jemand noch eine Idee?

Danke Reiner
 
#10
Habe noch mal alle möglichen Einstellungen an den ESC's ausprobiert, aber alles bringt nur bedingt Erfolg.

Wenn ich das Timing vergrößere wird es ein wenig besser aber die Probleme mit den stopenden Motoren bleiben. Bei Veränderung in Richtung 0° wird es noch viel schlimmer.

Wenn ich die Switching Frequency verändere hat es keine merlichen Auswirkungen. Die Motoren klingen in bestimmten Bereichen nur fürchterlich.

Das einzige was hilft ist das Braking auszuschalten. Das möchte ich allerdings nicht, da die Motoren dann ca. 8% mehr Leistung benötigen.

Hat jemand noch eine Idee?

Danke Reiner
poste mal deine esc32v3 parameter (alle bitte!). 4006er sollten damit schnurren wie ein Kätzchen --> denke mal dass da was nicht stimmt. Kalibriert sind die schon, oder?
 

keilie

Erfahrener Benutzer
#11
Die T4006 laufen am Servotester wie auch über das Configuration Utility über USB Anschluß perfekt ohne die kleinste Macke perfekt rund auch bei jeglichen Drehzahlveränderungen über die Telemetry Einstellungen.

Die Fehler treten nur M4 auf wo ich die ESCs über CAN betreibe.

so hier die ESC32v3 Parameter
 

Anhänge

#12
Die T4006 laufen am Servotester wie auch über das Configuration Utility über USB Anschluß perfekt ohne die kleinste Macke perfekt rund auch bei jeglichen Drehzahlveränderungen über die Telemetry Einstellungen.

Die Fehler treten nur M4 auf wo ich die ESCs über CAN betreibe.

so hier die ESC32v3 Parameter
O.K. eines zum Anfang: Die ESC32V3 sind super schnell was ein Neustart angeht; das musst du nicht mitbekommen wenn der am Config Utility hängt. Das Ansprechverhalten kannst du gut testen indem du von idle auf Vollgas wechselst. Das ganze dann ein paar mal schnell hintereinander. Sobald es auch nur ansatzweise 'ranzt' ist das Timing noch anpassungsfähig.

So, jetzt mal auf die Parameter bezogen:
SWITCH_FREQ= 64kHz? Bist du dir sicher dass du das bei dem großen Motor wirklich so hoch schrauben willst/musst? Das 'höchste' was ich bislang mal genutzt habe waren 36kHz mit einem 2213er Motor --> würde die bei deinem Motor in die Region von 24KHz als Maximum legen.

Start_Voltage sollte bei einem 17in Prop passen; der braucht einen ordentlichen Schubs. Was aber keinen Sinn macht ist der Start Current; den lege ich selbst bei Props in der Region von 9-10in schon über 1A --> mal deutlich anheben!

In den AQ Settings hast die PWM_RPM_SCALE auch auf 4000 geändert?
Wie sieht dein CAN BUS beim M4 aus? Abschlusswiderstand ist einer dran, oder?

Noch was: Advance würde ich eher größer machen! Ob es passt merkt man am Startverhalten: Aushalten -> idle -> ausschalten -> idle ---> der muss IMMER starten!!
 
Zuletzt bearbeitet:

keilie

Erfahrener Benutzer
#13
O.K. eines zum Anfang: Die ESC32V3 sind super schnell was ein Neustart angeht; das musst du nicht mitbekommen wenn der am Config Utility hängt. Das Ansprechverhalten kannst du gut testen indem du von idle auf Vollgas wechselst. Das ganze dann ein paar mal schnell hintereinander. Sobald es auch nur ansatzweise 'ranzt' ist das Timing noch anpassungsfähig.

So, jetzt mal auf die Parameter bezogen:
SWITCH_FREQ= 64kHz? Bist du dir sicher dass du das bei dem großen Motor wirklich so hoch schrauben willst/musst? Das 'höchste' was ich bislang mal genutzt habe waren 36kHz mit einem 2213er Motor --> würde die bei deinem Motor in die Region von 24KHz als Maximum legen.

Start_Voltage sollte bei einem 17in Prop passen; der braucht einen ordentlichen Schubs. Was aber keinen Sinn macht ist der Start Current; den lege ich selbst bei Props in der Region von 9-10in schon über 1A --> mal deutlich anheben!

In den AQ Settings hast die PWM_RPM_SCALE auch auf 4000 geändert?
Wie sieht dein CAN BUS beim M4 aus? Abschlusswiderstand ist einer dran, oder?

Noch was: Advance würde ich eher größer machen! Ob es passt merkt man am Startverhalten: Aushalten -> idle -> ausschalten -> idle ---> der muss IMMER starten!!
Also wenn ich im Config Utility die ESC's und von idle auf Vollgas wechsele und auch mehrfach schnell hintereinander ist alles ok, Motor läuft immer an. Habe Start Current trotzdem mal auf 2A hoch gesetzt.

Bei einer SWITCH_FREQ = 64 KHz läuft der Motor am ruhigsten und braucht den wenigsten Strom.
Habe allerdings auch von 4Khz angefangen schon alles ausprobiert - bringt für mein Problem keine Änderung.

Mir ist nicht bewußt, dass ich PWM_RPM_SCALE verändert habe. Was macht der Parameter genau und welchen wert sollte ich einstellen?

Abschlusswiderstand ist am CAN BUS dran. Habe den BUS so wie im Wiki beschrieben aufgebaut, das sollte so passen.

Advance erhöhen auf den Maximalwert von 28° bringt so gut wie keine Veränderung am Feherverhalten nur der Stromverbrauch steigt um ca. 16%. Habe aber von 0° bis zu 28° alles schon ausproiert.
Was mich allerdings verwundert ist, das ich im Config Utility 30° einstellen kann und im ESC speichen kann aber wenn ich die Daten wieder aus dem ESC auslese bin ich wieder bei 28°

Habe auch schon zum Test weitere zusätzliche Elkos dran gemacht, bringt aber auch nichts.


PS: Habe ESC32v3 an einem anderen Kopter mit U8 Motoren an 8s und einer Wookong ohne Propleme am laufen - ich glaube nicht das es an den ESC Einstellungen liegt.
 
Zuletzt bearbeitet:
#14
..
Bei einer SWITCH_FREQ = 64 KHz läuft der Motor am ruhigsten und braucht den wenigsten Strom.
Habe allerdings auch von 4Khz angefangen schon alles ausprobiert - bringt für mein Problem keine Änderung.

Mir ist nicht bewußt, dass ich PWM_RPM_SCALE verändert habe. Was macht der Parameter genau und welchen wert sollte ich einstellen?
...
Advance erhöhen auf den Maximalwert von 28° bringt so gut wie keine Veränderung am Feherverhalten nur der Stromverbrauch steigt um ca. 16%. Habe aber von 0° bis zu 28° alles schon ausproiert.
Was mich allerdings verwundert ist, das ich im Config Utility 30° einstellen kann und im ESC speichen kann aber wenn ich die Daten wieder aus dem ESC auslese bin ich wieder bei 28°
...
PWM_RPM_SCALE wird durch die Kalibrierung ermittelt, ist die maximal erreichbare Drehzahl des Antriebs.

Wenn du schreibst du hast alles probiert heißt das dann dass du immer einen vollen Kalibrierlauf gemacht hast, Parameter speichern, power cycle und Stress-test? Wenn du Advance bzw. die Switching frequency änderst müssen auch FF1TERM und FF2TERM dazu passen, sonst macht das wenig Sinn. Die bekommst du aber nur wenn du nach ändern der Parameter eine volle Kalibrierung machst.

CAN ist deutlich schneller als ein analoger PWM, nur zur Info.
 

keilie

Erfahrener Benutzer
#15
Ja habe nach allen Veränderungen Advance bzw. die Switching habe einen vollen Kalibierlauf gemacht, habe damit schon Stunden zugebracht.
Noch eine Frage zur Kalibrierung bei welcher Spannung sollte man die Kalibrirung am besten machen. Voller Akku, leerer Akku oder halb voller Akku? Ich habe immer in etwa eine mittlerer Spannung genommen.

Habe gerade noch eine Feststellung gemacht, und zwar wenn der Kopter mit den Landebeinen auf dem Tisch steht ist in den Fällen wo die Motoren stehenbleiben vorher eine recht hohe Eigenschwingung und Resonanz des gesamten Kopters zu beobachten. Wenn ich den Kopter dagegen auf eine Styroporplatte stelle treten die Resonazen nicht auf und die Motoren gehen auch nicht aus.
Ich denke die zu hohen Schwingungen könnten das Problem sein.
 
#16
Ja habe nach allen Veränderungen Advance bzw. die Switching habe einen vollen Kalibierlauf gemacht, habe damit schon Stunden zugebracht.
Noch eine Frage zur Kalibrierung bei welcher Spannung sollte man die Kalibrirung am besten machen. Voller Akku, leerer Akku oder halb voller Akku? Ich habe immer in etwa eine mittlerer Spannung genommen.

Habe gerade noch eine Feststellung gemacht, und zwar wenn der Kopter mit den Landebeinen auf dem Tisch steht ist in den Fällen wo die Motoren stehenbleiben vorher eine recht hohe Eigenschwingung und Resonanz des gesamten Kopters zu beobachten. Wenn ich den Kopter dagegen auf eine Styroporplatte stelle treten die Resonazen nicht auf und die Motoren gehen auch nicht aus.
Ich denke die zu hohen Schwingungen könnten das Problem sein.
stell bitte mal ein paar Fotos von dem Kopter ein sowie eine log Datei. Würde mal den Vibrationslevel ansehen
 

keilie

Erfahrener Benutzer
#18
Habe mal eine Frage an die Experten hier: Mir ist aufgefallen, dass ich Angel P im manuell Mode wesentlich höher stellen kann als im Altitude Mode ohne das der Kopter anfängt sich aufzuschwingen? Ich war immer der Meinung die PID Werte soll man im Manuell Mode einstellen. Warum ist das so oder was kann das Problem sein. Ich denke sogar, dass dieser Effekt bei mir für die Abstürze verantwortlich ist, da ich die PID's immer nur im manuell Mode eingestellt habe.
VG Reiner
 
Zuletzt bearbeitet:
RCLogger

FPV1

Banggood

Banggood

Oben