Reptile S800 zappelt um die Querachse

#1
Mein S800 fängt im Modus FBWA immer mal wieder an, um die Querachse zu zappeln. Kurz in MANUELL zurück, danach geht es wieder im FBWA. FC ist Omnibus F4 pro mit Arduplane 4.0.9. Ich habe schon mehrfach AUTOTUNE gemacht. Es wird aber nicht besser. AUTOTUNE mache ich folgendermaßen: Flugmodus AUTOTUNE einschalten, kurz hoch, kurz tief ... das Ganze ca. 6 mal. Dann umdrehen , weil ich den Flieger nicht mehr gut sehen kann, und zurück fliegen. Dann wieder umdrehen und das Ganze wieder ca. 6 mal. Alles ca. 5 mal, also ca. 5x6 kurz hoch, kurz tief. Dann auf FBWA geschaltet. Vielleicht ist es nicht ganz richtig, bzw. was kann ich an den Einstellungen ändern, damit er richtig fliegt.

Danke für Tips
Horst
 

QuadCrash

Erfahrener Benutzer
#3
Als erstes prüfe bitte mal, ob die FC richtig gelevelt ist. Dafür den Flieger in Flugstellung so auflegen, dass die Flächenunterseits waagerecht ist und dann die Nase ca. 1-2 Grad anheben. Ist im HUD vom Mission Planner die Horizontlinie dann mittig? Wenn nein, Calibrate Level durchführen (nicht Calibrate Accel).

Ist SERVO_AUTO_TRIM=1 in den Parametern gesetzt? Wenn nein, bitte auf 1 setzen, die FC trimmt dann die Ruder in FBWA automatisch aus und übernimmt die Werte für MANUAL.

Zum Autotune:

Der Flieger fliegt gerade in eine Richtung. Nun den Querruder-Stick kurz ganz nach links bewegen und dann sofort ganz nach rechts. Das mehrfach hintereinander wiederholen. Wenn der Flieger zu weit weg ist, erst umdrehen und dann wieder Querruder links/rechts geben. Das insgesamt mindestens ca. 20x wiederholen.

Nun dasselbe Spiel mit dem Höhenruder wiederholen. Höhenruder voll auf Tiefe, dann sofort voll Höhe ziehen und das ebenfalls mindestens 20x wiederholen.

Die Autotune-Funktion speichert alle 10 Sekunden den aktuellen Stand ab. Je öfter man diese Rollund Nickbewegungen durchführt, desto besser wird das Tuning.
Wichtig sind diese 10 Sekunden, wenn Du zu früh Autotune abschaltest, werden die Änderungen nicht gespeichert ... Also nach dem Autotune mindestens noch 10 Sekunden mit aktiviertem Autotune normal weiterfliegen.
 

olex

Der Testpilot
#4
Wenn du in Autotune nur "hoch/tief" wechselst, lernt er nur die Pitch (Nick) PIDs an, aber nicht die Roll (Quer) Achse. Du musst auch scharfe links-rechts Kurven fliegen, dann lernt er die Roll-PIDs auch und die Querachse wird sich beruhigen.
 
#6
Mit Querachse meine ich Nickachse. Rollachse (Längsachse ?) habe ich im AUTOTUNE auch gemacht. Also Querruder links/rechts. SERVO_AUTO_TRIM ist die ganze Zeit auf 1. Ich habe jetzt Calibrate Level noch mal neu gemacht, da die Horizontlinie etwas unterhalb der Mitte war. Danke erstmal für eure Tips. Probieren wird diese Woche wohl erstmal nichts wegen schlechtem Wetter.
Nochmal zum AUTOTUNE. Ich schaffe nicht 20x am Stück. Dann ist der Flieger weg. Ich schaffe ca. 6 - 7 mal, dann muss ich umdrehen um das Gleiche wieder zu machen. Während der ganzen Zeit ist AUTOTUNE eingeschaltet. AUTOTUNE erst kurz vor der Landung ausschalten. Ist das so richtig ?
 

QuadCrash

Erfahrener Benutzer
#7
20x am Stück Autotune geht auch nur via FPV ;). Ansonsten so wie von Dir beschrieben. Autotune kannst Du ausschalten, wenn nach dem letzten "Tune" gut 10 Sekunden vergangen sind. Dann sind die Werte in der FC gespeichert. Nicht mit Autotune landen ...

Nochmal zum Tune selbst: Du gibst voll Tiefe, wartest aber nicht bis der Flieger die Lage eingenommen hat, sondern wechselst sofort auf voll Höhe ziehen. Und wieder zurück ... Sieht dann ungefähr wie ein Delphin im Wasser aus. Das gleich gilt für die Querruder, quer voll links und sofort auf voll rechts und zurück.
 
#11
Nachdem ich Calibrate Level neu gemacht habe, habe ich es gestern noch einmal probiert. Nachdem ich bestimmt 20 x Autotune mit Quer und Höhe gemacht habe, ist das Zappeln weg. Dafür muss ich aber im MANUAL-Modus neu trimmen. Er taucht sonst weg.
 

QuadCrash

Erfahrener Benutzer
#12
Dafür muss ich aber im MANUAL-Modus neu trimmen. Er taucht sonst weg.
Dann trimm in MANUAL so das er schön gerade fliegt, lande und trage die Werte der Balken im Servo-Output dort als Trim-Mitte ein. Im Sender den Trim dann wieder nullen.

Damit müsste er in MANUAL und FBWA gleich fliegen. Kannst Du durch Umschalten einfach testen.

Das alles aber nur mit SERVO_AUTO_TRIM=0.
 

Leo1962

Erfahrener Benutzer
#13
Einfach so wen das model um die Querachse labil wird ohne Stabi System muss in der regel nur etwas mehr Blei in die Nase gegeben dann war das Model zu schwanzlastig
 
RCLogger

FPV1

Banggood

Banggood

Oben