acsp4 unter ardupilot zeigt keine Werte an

gfacek

Erfahrener Benutzer
#1
Hallo,

ich baue derzeit einen etwas größeren Quadcopter auf Basis eines Tarot 650 Sport auf. Die Flugsteuerung soll ein original Pixracer übernehmen. Hierzu habe ich auch ein Power Module von Arsov, das ACSP4.

Zunächst wollte ich mal wieder PX4 eine Chance geben, und bin wie immer sehr positiv von der Konfiguration gestimmt. Leider vergesse ich immer, dass man dort PID manuell einstellen muss und wechsle anschließend wieder auf ArduPilot. Unter PX4 konnte Voltage und Current ziemlich korrekt ausgelesen werden, im Mission Planner bekomme ich das allerdings nicht einmal ansatzweise hin. Es werden keine Werte angezeigt. Ich bin der Meinung bereits alle Kombinationen ausprobiert zu haben, aber alles ohne Erfolg.

Setzt das so jemand zufällig ein, und kann mir einen Tipp geben?

VG Tobi
 

XXSnoopy

Neuer Benutzer
#2
Hallo Tobi

damit läuft es bei mir:
original Pixracer und ACSP4

BATT_AMP_OFFSET,0
BATT_AMP_PERVLT,40
BATT_CAPACITY,8000
BATT_CRT_MAH,0
BATT_CRT_VOLT,0
BATT_CURR_PIN,3
BATT_FS_CRT_ACT,0
BATT_FS_LOW_ACT,0
BATT_FS_VOLTSRC,0
BATT_LOW_MAH,0
BATT_LOW_TIMER,10
BATT_LOW_VOLT,14.5
BATT_MONITOR,4
BATT_SERIAL_NUM,-1
BATT_VOLT_MULT,13.62027
BATT_VOLT_PIN,2

Gruß Jürgen
 

gfacek

Erfahrener Benutzer
#3
Danke Jürgen hierfür. Ich habe ganz vergessen hier meine Lösung zu posten...das hatte ich nur in der ArduPlane Community gemacht. Sorry...

Ich hatte mal versucht mittels QGroundControl die Konfiguration in der ArduPilot-Firmware zu setzen. Damit konnte ich dann die Einstellungen im Mission Planner rausholen.
Sensor muss "Other" sein, FC Ver. "The Cube or Pixhawk".
In irgendeinem Forum hatte Arsov mal die Settings für den Volt- und Currentsensor gepostet: 13,4545 Volt multi and 36,3636 Amps per Volt.
 
RCLogger

FPV1

Banggood

Banggood

Oben