BitsyLED - Flugmodell-Beleuchtung von flyandy

Bussard

Erfahrener Benutzer
#1
Hier hat im englischsprachigen Forum der user flyandy ein interessantes, aktuelles Projekt namens BitsyLED vorgestellt, mit dem man eine dynamische Modellbeleuchtung mit LED-Streifen bauen kann, ähnlich dem hier leider vor Jahren eingeschlafenen Projekt flightstripe.

Ich wollte das Teil mal testen, die Arduino-Grundprogrammierung lief auch problemlos durch, aber bei der Bedienoberfläche, einem Javascricpt-Programm für den Chrome-Browser, scheitere ich. Das Programm bekomme ich nicht "händisch" installiert, wie in der Beschreibung erwähnt. Bei mir wird immer nur der Quelltext angezeigt. Ob es an meinen Sicherheitseinstellungen oder sonstwas liegt, ich weiß es nicht.

Kann mir jemand mit Sachkunde sagen, wie man so ein JS-Programm zum laufen unter Win10 bekommt?

Danke und schönen Abend, Bussard
 

Bussard

Erfahrener Benutzer
#2
Habe mir das Ganze wohl eine Woche zu früh gezogen, inzwischen gibt es eine 3. Version mit Installationsfile, weil Go...le die App-Unterstützung eingestellt hat. Jetzt wirds wohl werden.
 
#5
Hey Bussard! Unterstützen kann ich bei bitsyled nicht, aber ich bin gespannt. Flightstrip habe ich damals nähmlich auch gesehen, kam aber nicht voran. Habe dann aber ein Arduino Script gefunden, dass ich angepasst habe. Damit steuert nun der ATTiny85 per Throttle, Logik und Aux Kanal die Neopixel und weitere leds am RC Auto. Ist auch sexy

Grüße

Merv X.png
 

Bussard

Erfahrener Benutzer
#6
Hallo CrashFX, ja, die Hardware kann minimalistisch sein, letztlich setzt man aber sowas nicht täglich ein, und zumindest ich muß mich nach 1, 2 Monaten Abstinenz wieder in die "Programmierung" eingewöhnen. Das FlightStrip-Programm läuft bei mir ja auch top, nur ist es nie "fertig" geworden in der Hinsicht, daß Falscheingaben abgefangen werden. Und dann geht auf einmal gar nichts mehr nach einem falschen Click. Man findets dann, ist aber nicht intuitiv zu bedienen.

Da erhoffe ich mir hier letztlich mehr, weil der Autor noch dran ist und es weiter entwickelt und sicher auch auf Feedback wartet (er spricht u.a. Deutsch). Mal sehen, wann ich dazu komme, die ganzen Effekte auszutesten. Momentan 2 Hobbys intensiv und etliche Baustellen ...
 

stock

Erfahrener Benutzer
#11
Hallo Bussard,

wie hast du denn die Verbindung zwischen dem Configurator und dem Arduino hinbekommen?

Ich sitze jetzt seit vier Stunden am PC und scheitere.

Mein Aufbau ist ein Arduino Nano (alter Bootloader)
Habe sowohl als Target in der Arduino IDE den Nano als auch den ProMini versucht - ohne Erfolg.

Configurator mit Admin Rechten usw.

Kein Zeichen - es bleibt bei "connecting"

Gruß und schonmal Danke

Edit:
Configurator: 0.6.2
Firmware: 1.0.3
 

Bussard

Erfahrener Benutzer
#12
Mein "Nano" ist auch noch mit altem Bootloader. Ein paar Tage nach den ersten erfolgreichen Tests kam die Version 0.6.2. rauf, auf die ich auch gleich aktualisiert hatte.
Danach bei mir ebenfalls ein Steckenbleiben bei connecting, was ich aber bei mir/ meinem Rechner als Ursache vermutete, weil zeitgleich auch Win10-Updates kamen und ich da einen Security-Error vermute(te). Mit Deinen Erfahrungen kann es aber auch mit dem Versionsupdate zusammenhängen. Eine ReInstallation der ersten Version brachte übrigens keine Änderung.
Habe mit dem Nano nicht groß weiter probiert, weil ich mir über OSHpark ein paar Leiterplatten bestellt hatte, die sind vorgestern gekommen, ich kam aber noch nicht zum Bestücken. Dann muß dort auch noch der BL gebrannt werden, dazu ist auch erst noch wieder basteln angesagt. Dauert ein paar Tage.

Ist wohl am Besten, den Autor mal anzuschreiben, ob er das nachvollziehen kann.
 
Zuletzt bearbeitet:

stock

Erfahrener Benutzer
#14
Danke schonmal für die Antwort.

Ja, die config.h. habe ich auf Arduino umgestellt.

Und ebenfalls wie bei dir bringt ein downgrade auf die zwei nächst-früheren Versionen keine Änderung.
 
RCLogger

FPV1

Banggood

Banggood

Oben