F3 V4 Board mit Cleanflight und Spektrum Satelite

#1
Hallo Leute,

Ich habe mich, nun da das schöne Wetter wieder lockt dran gemacht meinen "Zwerg" flugfähig zu machen :)
In dem kleinen ist ein F3 V4 Board verbaut, welches mit aktuellem Cleanflight betreiben werden soll, so weit hab ich bereits Erfahrung und über die Jahre immer mal wieder den ein oder anderen Copter gebaut. Allerdings habe ich hier mit dem Board jetzt einige Probleme..

https://www.banggood.com/de/F3-V4-F...B-Current-Sensor-p-1102946.html?rmmds=myorder

Im wesentlichen läuft es, alle Motoren, Sensoren etc. funktionieren (ACC is mehr als ausreichend),
das wurde alles in der Cleanflight Chrome App eingestellt und getestet, funktioniert. Was aber nicht funktioniert ist der Empfänger.. Ich verwend eine Spektrum DX6 (neu, schwarz) und einen Spektrum AR7700 Satelitenempfänger, diese beiden wurden miteinander gebunden (nur Funke + Sat/Empfänger) als auch via CLI in Cleanflight, beides funktionierte ohne Fehler.

Verkablet wie folgt:
3 poliges Kabel an den Satelit (U3RX, 5V und GND) direkt vom Board, in den Einstellungen alles auf Spektrum 2040 bit, und die Funke meldet auch die Verbindungen, es sieht im wesentlichen aus als würde alles funktionieren, allerdings kann ich nicht armen als auch die Sender-Befehle scheinen nicht zu funktionieren, ich kann keine Stickeingaben in den Cleanflight Settings erkennen..

Ich habe hier nun schon bestimmt 10h Trial Error, Kabel überprüft, Software Settings, etc.. aber kann das Ding nicht zum funktionieren überreden.. hat hier jemand nen Tip? Eine funktionierende Anleitung (im Internet gibt es diverese Videos und Anleitungen dazu aber meist nur unvollständig oder not working)? Ich wäre mittlweile echt dankbar für jede Hilfe!

Danke schon mal, falls jemand helfen kann :)


lg
 

Bussard

Erfahrener Benutzer
#2
Ich kenne die Spektrum-Empfänger nicht, aber Dein Problem könnte an einer falschen Signalpolarität liegen.
Falls das der Fall ist:
- wenn Der verwendete Eingang per CLI invertiert werden kann, das einfach aktivieren.
- ansonsten würde ein Signalinverter (hier schon oft veröffentlicht) mit 2(1) Widerstand und 1 Transistor helfen.

Gruß
 
#3
Hallo,

Danke für die Antwort @Bussard!
Davon hatte ich bisher nix gehört, verstehe ich das richtig, das man diesen Signalinverter benötigt wenn keine 3.3V verfügbar sind?
Ich ging ehrlich gesagt davon aus dass es kein Problem wäre mit 5V zu betreiben, da der AR7700 3-9V Eingangsspannung übernimmt.. aber ich muss heute Abend erst testen ob es in meinem Setup einen Unterschied macht, wenn die 3.3V benutzt werden.

Jedenfalls hab ich diese 3 Pins verwendet und direkt den Satelit (also nur das kleine Ding, nicht den ganzn Empfänger) angeschlossen, das ist so noch richtig, ja?
(Ich hatt ebisher keinen Satelitenempfänger, nur "normale" :)

002b8818-16f2-4ecf-9b46-11369c5d9a13.jpg

lg
 

Bussard

Erfahrener Benutzer
#5
@Arakon: Danke.

... Davon hatte ich bisher nix gehört, verstehe ich das richtig, das man diesen Signalinverter benötigt wenn keine 3.3V verfügbar sind?
Ich ging ehrlich gesagt davon aus dass es kein Problem wäre mit 5V zu betreiben, da der AR7700 3-9V Eingangsspannung übernimmt.. (Ich hatte bisher keinen Satelitenempfänger, nur "normale" :)
Dann teste mit einem "normalen" Empfänger, der an die +5V angeschlossen sein kann, der Signalpegel ist dennoch nicht zu hoch für den FC. Bei 3V3 kann es eher vorkommen, daß der Signal-Pegel nicht hoch genug ist.


Ein Inverter "dreht" das Signal um, aus dem oberen Signal macht er das untere usw.
Invert.jpg


Ein Pegelwandler erhöht oder vermindert die Signalspannung (-höhe).

Gruß
 
#6
Hallo Leute,

Also ich habe Gestern Abend wieder einige Stunden versucht das Ding flugfähig zu bekommen, aber leider nichts..
Habe zum Schluss dann die Verkabelung auf PPM für den AR7700 geändert, das sind die selben Pins am Board, aber halt anders an den Empfänger angeschlossen (PPM) und die Einstellungen in Cleanflight dementsprechend auf PPM und Spektrum Modulation eingestellt. Dann hab ich den verkabelten Empfänger mit meiner DX6 gebunden -> erfolgreich.
Dass wars dann leider aber auch schon.. Mehr funktioniert leider nach wie vor nicht.

Das Board selbst erkennt die Motoren, Sensoren und verarbeitet diese auch richtig, also für ACRO, das reicht mir aus :)
Nur eben keine eingaben im Servomonitor, kein Armen möglich, etc..

Ich weiß nicht mehr was ich noch testen soll :(
 
#7
Guten Abend liebe Leute,

Ich komme gerade von einier ausgiebigen "testing-session" zurück und kann folgendes berichten:

Die Verkabelung habe ich wieder wie zuvor, also Spektrum Serial (SPEK) direkt an den Sateliten vom "AR7700" Empfänger,
danach habe ich Betaflight geflasht und alle erforderlichen Settings für meinen Frame sowie RX/TX vorgenommen. Im CLI Tab hatte ich dann mit folgenden Befehlen Glück und konnte bzw. kann den Sateliten zumindest "temporär ?" binden:

set spektrum_sat_bind=9
set spektrum_sat_bind_autoreset=0
save

Danach rebootet das Board und ich kann die DX6 binden, Sender meldet "erfolg", der Satelit leuchtet dauerhaft und ich sehe die Eingaben im "Receiver" Tab in Betaflight! Das ist bisher schonmal ein rießen Erfolg :D
Allerdings, sobald ich dann die Verbindung trenne und einen Akku anstecke und das Board neu gebootet hat ist der Sat automatisch wieder im "bind" mode. Das habte ich versucht mit:

set spektrum_sat_bind_autorst=0
save

zu ändern.. aber es funktioniert leider nicht, jedes mal nach dem reboot geht der Satelit in "bind" mode, ich kann auch binden und es sieht sehr gut aus aber nach einem reboot (wenn ich den akku einlege) ist die verbindung wiederweg.. :(

Kommt das jemanden bekannt vor?
 
#8
Guten Morgen :)

Ich habe das letzte Wochenende damit verbracht meine kompletten Settings (nun Betaflight) über den Haufen zu werfen,
die Verkabelung vpn 5V auf 3.3V zu ändern, neu eingerichtet und gebunden -> klappt auf Anhieb.
Danach erstmal 2 Akkus mit zunehmend Leistung geflogen und etwas nachkalibiert, und was soll ich sagen, es fliegt sich wunderbar,
das letzt Board welches ich hatte war noch ein NAZE von der erstn Generation, da wurde schon einiges verbessert :D

Alles in allem funktioniert nun der Spektrum SAT, meine Swiftcam mit dem built in VTX und einfach alles, perfekt :)
 
RCLogger

FPV1

Banggood

Banggood

Oben