FrSky Stromversorgung Redundancy Bus-20 (RB-20)

#1
Hallo,

hat jemand Erfahrungen gesammelt beim Betrieb des RB-20 in Flugmodellen?

Ich betreibe ein solches Modul in einem Segler mit 2 Empfängern (G-RX8 im S-Bus Betrieb) und einem FrSky Brushless-Regler Neuron 80, dessen Smart-Port am RB-20 hängt (S.Port). Die Telemetriedaten werden auch schön an meinen Sender (S10 Express) übermittelt, allerdings meldet er mir laufen "Power overload" und "Servo overload", sowie in unregelmäßigen Abständen futuristische Strom- (> 165 A), Spannungs- und Höhenwerte (> 1000m) im Log. An der Stromversorgung der ganzen Einheit kann es nicht liegen, da ich eine stabilisierte Spannung von 6V an den RB-20 führe. Beim Blick auf die Internetseite von FrSky habe ich festgestellt, dass die Firmware des RB-20 aus dem Jahr 2018 (August) stammt. Für hilfreiche Informationen wäre ich sehr dankbar.

Gruß Udo
 

FJH

Erfahrener Benutzer
#3
Du hast die letztaktuelle Firmware für die RB 20 selber geflasht, oder? Wenn nicht, dann solltest du das als erstes machen. Dann schreibst du, dass du offenbar die RB20 mit der SBEC Spannung vom Regler versorgst, das scheint mir die Schwachstelle deiner Alarmprobleme zu sein, der max. Strom ist stark begrenzt und es sind offenbar Spannungseinbrüche, die dir dann deine Alarme auslösen. Der SBEC des Neuron ist ganz sicher nicht für einen RB20-Betrieb ausgelegt. Ein anderer User berichtete auch von solchen Alarmen mit einer BEC-Versorgung, die waren weg, nachdem er die Stabilisierungsspannung auf 6V hochgesetzt hatte.
 
#4
Hallo QuadCrash,

alles nach Vorschrift. Beide Empfänger sind im Modellspeicher gebunden. Telemetrie ist auf Ch1 bis Ch16 eingestellt, da ich 9 Servos am RB-20 angeschlossen habe. Alles HV-Servos.

Gruß Udo

screenshot_x10express_20-04-23_13-15-05.png
 

FJH

Erfahrener Benutzer
#5
Wenn du doch HV-Servos installiert hast, dann brauchst du doch keine (ab)geregelte Versorgungsspannung. Ich würde an deiner Stelle mal einen LiFePo-Akku direkt anschliessen.
 
#6
Dann schreibst du, dass du offenbar die RB20 mit der SBEC Spannung vom Regler versorgst
... Nein das habe ich nicht geschrieben. Ich habe geschrieben, dass ich eine stabilisierte Spannung (6 Volt) an den RB-20 führe. Stromquelle ist ein LiPo 2S 3800, stabilisiert werden die 6 Volt über einen Jeti MAX BEC 2D EX Plus mit Magnetschalter.
 

FJH

Erfahrener Benutzer
#7
Okay, da habe ich dich missverstanden. Und die 6V-Versorgung über den Jeti MaxBEC sollte da eigentlich auch reichen, jedenfalls für verbaute Servos in einem Segler.
 
#8
Wenn du doch HV-Servos installiert hast, dann brauchst du doch keine (ab)geregelte Versorgungsspannung. Ich würde an deiner Stelle mal einen LiFePo-Akku direkt anschliessen.
Das ist insoweit richtig. Allerdings hatte ich im ersten Aufbau ein Servo eingesetzt, das leider nur bedingt "HV" konnte (ich glaube 6,8 Volt) und das ist dann beim Einschalten mit einer "nicht abgesicherten" Versorgungsspannung über einen 2S LiIon direkt "abgefackelt". Dank des RB-20 ist der Rest heil geblieben. Da der RB-20 laut Beschreibung ab 4 Volt arbeitet, habe ich mich zu dem "abgesicherten Modus" entschieden, zumal die Servos klaglos ihren Dienst verrichten.
 

FJH

Erfahrener Benutzer
#10
Hast du vielleicht stromhungrige Servos installiert? Ich würde jedenfalls mal einen Versuch machen mit einer direkten LiFePo-Versorgung.
 

FJH

Erfahrener Benutzer
#12
Die Ursache der Datenausreisser könnten auch beim G-RX8 liegen, über den ja alle Telemetriedaten laufen Der ist eigentlich bekannt für solche Ausreisser. Nehme an, dass du die "alte" ACCST v1 Firmware benutzt und nicht die neue v 2.1.0, oder? Du könntest also theoretisch zwei Dinge machen. Zum einen einen anderen Telemetrieempfänger nehmen und schauen, wie es sich damit verhält. Zum anderen könntest du auf die neue v2.1.0 Firmware gehen und damit testen.
 
#14
Genau! Außerdem benutze ich 2 Empfänger mit ACCESS 1.1.3. Ich vermute Mal, dass die Firmware des RB-20, die aus 2018 stammt, mit dem neuen ACCESS Protokoll nicht klar kommt. Ich bekomme auch ständig Meldungen über "Empfangssignal schwach" und "Empfangssignal kritisch". Diese Meldungen habe ich nicht bei Modellen, bei denen ich ohne den RB-20 fliege.
Leider kenne ich keinen Weg um die Herren Entwickler von FrSky dazu zu bewegen, sich der Sache anzunehmen, obwohl das Teil doch stark beworben wird.

Gruß Udo
 

QuadCrash

Erfahrener Benutzer
#15
Ich vermute Mal, dass die Firmware des RB-20, die aus 2018 stammt, mit dem neuen ACCESS Protokoll nicht klar kommt.
Du nutzt den SBUS-Ausgang des RX, da spielt ACCESS eher keine Rolle.

Mach mal ein paar Screenshot von Einstellungen der Empfänger in der Funke, insbesondere auch die Optionen. Lassen sich die 14ms in obigen Screenshot auch erhöhen? Auf bspw. 18ms?
 

FJH

Erfahrener Benutzer
#16
Genau! Außerdem benutze ich 2 Empfänger mit ACCESS 1.1.3. Ich vermute Mal, dass die Firmware des RB-20, die aus 2018 stammt, mit dem neuen ACCESS Protokoll nicht klar kommt. Ich bekomme auch ständig Meldungen über "Empfangssignal schwach" und "Empfangssignal kritisch". Diese Meldungen habe ich nicht bei Modellen, bei denen ich ohne den RB-20 fliege.
Leider kenne ich keinen Weg um die Herren Entwickler von FrSky dazu zu bewegen, sich der Sache anzunehmen, obwohl das Teil doch stark beworben wird.

Gruß Udo
Die RB20 sieht nur das SBus-Signal der Empfänger und gibt an diese per SPort die Telemetriedaten. Die RB20 weiss nicht mit welchem Protokoll die Empfänger laufen, interessiert ihn auch nicht. ACCESS 1.1.3 ist bekannt für Telemetrie-Fehlermeldungen, Einfrieren von Telemetriedaten und auch schwachen RSSI Signal. Habe selber aus all diesen Gründen nach kurzem ersten Test jede weiteren Tests eingestellt. Diese Probleme scheinen jetzt bei ACCESS 2.1.0 behoben. Solltest also deine weiteren Flüge nicht mehr mit der alten ACCESS Version machen.
 
#19
Habe ich gerade von der offiziellen Seite (unter Sender, Empfänger -> Firmware -> ACCESS -> 2.1.0) heruntergeladen. Für meine Sender und meine Empfänger.
Gruß Udo
 

FJH

Erfahrener Benutzer
#20
Da wäre noch was. Du solltest mal schauen, welche aktive Länge die Antennen deiner G-RX8 haben. Da wurden nämlich Empfänger ausgeliefert, mal mit 23mm aktiver Länge (also abisoliertem Ende), mal mit 32mm, habe selber welche mit beiden Längen. Korrekte Länge sollten die 32mm sein. Ggf vorsichtig auf 32mm abisolieren oder Antennen ersetzen (Anschluss IPEX 4).
 
RCLogger

FPV1

Banggood

Banggood

Oben