iNav: Omnibus F3 Pro mit Motorproblem

BenHe

Neuer Benutzer
#1
Hallo zusammen,

ich habe folgendes Problem welches ich, trotz mehrtägiger Suche in diversen Foren oder Wikis , nicht gelöst bekomme.
Falls im falschen Unterforum, bitte verschieben
Ich habe mir ein Opterra 1,2m PNP gekauft und wollte diesen mittels einem Omnibus F3 Pro Board und Inav in die Luft bringen.
Zusammengesteckt und alles an den FC gelötet ging an einem Abend, aber als ich dann Inav geflasht (V2.0.0 2018-8-20 19:30 (stable)) und meinen FrSky XSR Empfänger über UART3 zum laufen gebracht habe, ist mir nach einer Zeit aufgefallen, dass der Motor kein Signal von der Fernsteuerung QX7 bekommt.
Ich hab im Conifg-Tab den ESC- und PWM-Ausgang aktiv geschalten.
Im Receiver-Tab jedoch wird alles normal angezeigt, der Throttle-Balken bewegt sich hoch und wieder runter so wie ich den Gas-Stick bewege. Alles top, so wie bei den anderen Coptern die mein Bruder und ich aufgebaut haben. Wenn ich in den Motor-Tab springe und nach der Bestätigung das ich den Prop nicht draufhabe, den Motorschieber hochschiebe, fängt der Motor auch anzudrehen. Also kann meiner Meinung nach auch erstmal nichts falsch angeschlossen sein. Servos funktionieren auch.

Momentan ist der einzige was im Modes-Tab konfiguriert ist, der Schalter zum armen des Fliegers.

Ich vermute das irgendwas mit den Mixern (Airplane/Flying Wing – Presets: Z84) nicht stimmt, aber das wird ja im Mixer Tab angezeigt und ich kann den Motor ja auch keinem anderen Servoausgang zuordnen.

Bin mit meinem Latein so langsam echt am Ende und hoffe auf eure Hilfe.

Vielen Dank und Grüße
Benedikt

Setup nochmal im Überblick:

Fernsteuerung: FrSky Taranis Q X7
Empfanger: FrSky XSR mit Sbus
FC: Omnibus F3 Pro AIO
Flieger: Eflite Opterra 1.2 PnP
iNav-GUI: 2.0.0
Firmware: Ominbus – V2.0.0 2018-8-20 19:30 (stable)
 

Hans-Jürgen Duwe

Master of Desaster
#2
Guck mal ob Du die Autolaunch Funktion aktiviert hast.
Die gibt den Motor erst frei wenn der FC einen Wurf registriert.

Ist in den letzten Versionen automatisch aktiv.
 

brandtaucher

Erfahrener Benutzer
#3
Ich würde im Zweifel dafür einen Schalter belegen, damit Du es aktiv ausschalten kannst, um den Motor zu testen.
 
#4
Das Armen ist vermutlich ohne GPS lock gesperrt, das ist die default Einstellung. Zum Testen kann man das im CLI ändern, mit set nav_extra_arming_safety = off.

Würde ich dann aber wieder auf ON setzen, sonst wird eventuell die home position mitten im Flug gesetzt, das ist bei RTH nicht so prickelnd - ich hab's ausprobiert ;)
 
Erhaltene "Gefällt mir": fandi

fandi

Erfahrener Benutzer
#5
Das Armen ist vermutlich ohne GPS lock gesperrt, das ist die default Einstellung. Zum Testen kann man das im CLI ändern, mit set nav_extra_arming_safety = off.

Würde ich dann aber wieder auf ON setzen, sonst wird eventuell die home position mitten im Flug gesetzt, das ist bei RTH nicht so prickelnd - ich hab's ausprobiert ;)
Das wäre auch meine erste Vermutung, es gibt aber auch noch andere Dinge die ein Arming verhindern,
z.B. die Lage des Modells, oder eine fehlerhafte Kompass-Kalibration, wenn Du überhaupt einen (aktiv) hast.
Das kannst Du aber auch erkennen, wenn Du den FC am Konfigurator anschließst,
Auch ein erfolgreiches Arming wird angezeigt.
Am besten testest Du das dort, wo Kompass Störungen ausschließbar sind, und wo Du auch GPS Empfang hast.
P.S.: dein FC und deine Funke können Telemetrie, bei dem Empfänger bin ich mir nicht sicher,
die Einrichtung macht auf jeden Fall Sinn, Du erkennst Probleme dann auch leichter.
 

BenHe

Neuer Benutzer
#6
Hallo zusammen,

erstmal vielen Dank für eure Antworten.

Haben sehr geholfen, dort wo ich ansetzen musste und es hat geklappt. Der Motor dreht jetzt so wie ich das haben will.
Allerdings musste ich den NAV_LAUNCH auf einen Schalter setzten, da er sich (warum auch immer) per CLI nicht deaktivieren lassen wollte.

So siehts gerade aus:
- NAV_Launch an
- Flieger armen und dann werfen

oder flieger armen und konventionell starten :D

Also nochmals vielen Dank euch, Wetter soll ja zum langen WE besser werden und dann werde ich mal testen.

Grüße
Benedikt
 
RCLogger

FPV1

Banggood

Banggood

Oben