MegaPirateNG V2.5.5 R1 mit Flyduino Mega Probleme

Joachim08

Erfahrener Benutzer
#1
Gerade kam das Päckchen von Paul und ich habe sämtliche Stifleisten aufgelötet.
Gerade wollte ich die oben aufgeführte Software aufspielen. Muß ich dabei nur die
APM_config.h editieren ? Wo sage ich der Firmware welchen Empfänger ich nutze etc ?
Bei Multiwii war das alles übersichtlicher....

Welchen "Mission Planner" benötige ich dazu ?
Habe den MegapiratesPlanner runtergeladen aber dieser
lässt sich nicht starten, es geht kurz ein Terminalfenster auf und zu,
das wars dann.

Wer kann einem Megapirates-Noob etwas auf die Sprünge helfen ?

Die Threads bei rcgroups kenne ich aber das ist mir momentan noch
alles zu speziell....

Vielen Dank und beste Grüße

Joachim
 

Joachim08

Erfahrener Benutzer
#2
So bin ein bischen weiter. Habe mir den Mission Planner 1.0.82 runtergeladen.
Irgendwie bin ich über die Meldung mit dem Switch gestolpert. Irgendwo habe
ich dann gesehen, daß der Pin "IN" wohl auch "CLI" ist und man diesen nach Masse
legen muß damit man verbinden kann. Und siehe da es gibt eine Verbindung....

Der MissionPlanner 1.1.92 startet leider mit einer Fehlermeldung, irgendwas mit
Assembly binding loggin is turned off. Kann ich leider nichts damit anfangen...
Hat da jemand einen Tipp dazu ? Habe Windows XP mit SP 2 und Net 3.5....
Directx habe ich schon auf die neuste Version geupdated

Grüße

Joachim
 

heliluder

Erfahrener Benutzer
#3
Hallo joachim
was genau hast du von Paul gekauft
ich habe das gekauft
Flyduino MEGA Flight Controller CPU Board V2.1
Freeimu 0.4.3 10DOF (MPU 6050/ACC) (HMC 5883L Mag)(MS 5611 Baro)
FMP 04 GPS Modul (MT 3329
und das soll mit Magapirate nicht funktionieren
 

Joachim08

Erfahrener Benutzer
#4
ich habe momentan nur das Flyduino Mega. Wollte die 10 dof von Drotek morgen noch verbauen.
Deine IMU sollte doch aber laufen, oder ?
 

Polzi

Erfahrener Benutzer
#5
Servus,
wäre Cool, wenn Ihr das Ding zum Laufen bekommt, ich habe mir den Wolf gewurstelt und bin nicht so richtig zum Ende gekommen, jetzt geht es drei Wochen in den Urlaub und dann wollte ich mich nochmal hinsetzten. Mein weg bisher:

Megapirates NG WIKI (http://code.google.com/p/megapirateng/wiki/GettingStarted?tm=6) abarbeiten, also Dateien im Arduino tauschen, und hier auch die Grunddaten einstellen. Nicht vergessen, bei den Empfängern ist der Summensignal Default konfiguriert, muss also bei normalem Empfänger deaktiviert werden. Ich hatte es übersehen und lange gesucht.
Jetzt Aktuellen Mission Planer laden und starten, soweit ich im Kopf habe wird hier die Brücke nicht mehr gebraucht.
Verbindung sollte jetzt klappen. Vor vier Wochen haben dann die Sensorrichtungen leider nicht gestimmt, das Problem sollte für die Freeimu 0.4.3 jetzt erledigt sein.
Es ging Alles nur die Motoren wollten nur ab und an mal starten, hier bin ich leider hängen geblieben und mir ist die Zeit ausgegangen.

Viel Glück Euch!

Robert
 

Joachim08

Erfahrener Benutzer
#6
Ich hab leider ein Problem beim starten des neuen APM, siehe oben....
Vielleicht sollte ich auf WIN 7 umsteigen.... oder XP SP 3 installieren ?
 

Joachim08

Erfahrener Benutzer
#8
SO habe jetzt das NET 3.5 nochmal installiert und ich kann jetzt den APM Planner 1.1.92 starten.
Leider kann ich nicht mit dem Mega connecten.....
Im Terminal klappt es.

Brauche ich für die 1.1.92 ne bestimmte Firmware ?
Habe die MegapiratesNG 2.0.49 drauf
 

Joachim08

Erfahrener Benutzer
#9
Neuester Mission Planner 1.1.92 mit MegapiratesNG 2.6_R1: Starte ich die .exe und versuche zu connecten bekomme ich die Meldung: Mavlink 1.0 Heartbeat. Please upgrade your Mission Planner. This planner is for Mavlink 0.9

Starte ich dann die ...10.exe gibts beim connecten ein Timeout mit der anschliessenden Fehlermeldung:
"No Heatbeat packets received".

Warum bekommt das eine Heatbeats daß andere empfängt nichts ?
 
RCLogger

FPV1

Banggood

Banggood

Oben