NEO-7M GPS Baudrate dauerhaft speichern?

Der_Mason

Neuer Benutzer
#1
Hallo,

ich brauche mal wieder die Hilfe der Community, hab mir ein neues Gps Modul gekauft:

http://www.ebay.de/itm/201371209390?_trksid=p2060353.m2749.l2649&ssPageName=STRK:MEBIDX:IT

mein altes war defect! (Lea 6)

Ich schaffe es nicht über das U-Center die Blautrate dauerhaft zu Speichern. Einstellen lässt sich alles schreiben auch, Speicher hab ich alle angewählt!
Hab auch schon ein Config-file gespeichert und anschließen wieder drauf geschrieben.

Sobald ich die USB Verbindung trenne stell sich das GPS wieder auf die Default-werte!

hab ich irgendwas übersehen gibt es noch einen Trick?
Ich hab das ganze ja schon mal mit dem 6er GPS hin bekommen...
 

Arakon

Erfahrener Benutzer
#2
Rechts oben wäre der Chip, auf dem die Settings gespeichert werden. Der ist bei dem GPS aber offenbar nicht verbaut.
Wenn du das Ding in Verbindung mit APM nutzt, ist das aber völlig egal, die APM (oder Megapirate) Software schickt eh bei jedem Start die nötigen Settings an das GPS.
 

Der_Mason

Neuer Benutzer
#3
Aha, Interessant, Ich benutze das GPS mit nem Crius aiop V2 mit io Board und der Megapirat 3.1.5.
angeschlossen ist es an serial 01. unter anderem konnte ich den Mag auch nicht in gang bringen...
was hab ich da nur gekauft?
 

Arakon

Erfahrener Benutzer
#4
Das Board ist ein gutes Multiwii Board, aber MPG ist nur ein ziemlicher Hack von APM.. für den gleichen Preis hättest du auch ein echtes APM Board bekommen.
Der Magsensor muss an I2C ran, aber den Onboard Sensor musst du dafür erst deaktivieren.
 

Der_Mason

Neuer Benutzer
#5
Ich hab schon einen externen mag dran von daher ist das nicht so wichtig...
Das Board fliege ich schon seit einem guten Jahr mit Megapirat und war auch recht zufrieden damit!

So hab jetzt das gps angeklemmt es hat auch einen Sat fix aber Daten kommen nicht rüber auch meine gps kontroll LEDs leuchen nicht am Copter. Tx und Rx sind auch richtig angeklemmt! Also da ist nichts mit automatischer bautraten Einstellung... :(
 

Der_Mason

Neuer Benutzer
#6
So Leute,

Hab es geschafft, Fehler war das falsch eingestellte Protokoll im Megapirate Sketch (NMEA) UBX muss es sein!
Drauf gekommen bin ich auf der RC-Timer Seite:

NOTE: When connected to either APM 2.xx or Pixhawk, the firmware recognizes the ublox GPS
and sends instruction to set the baudrate to 38,400, rate to 5Hz, turn off NMEA protocol, turn on UBX protocol, as well as other settings suited for use with APM and Pixhawk meaning that the "Default parameters" are irrelevant
as they are overridden by the APM or Pixhawk firmware.

Geht also doch!!!

Vielen Dank euch!!!
 
RCLogger

FPV1

Banggood

Banggood

Oben