newbee Fragen zu M4 in einem 120mm Frame

#1
newbee Fragen zu M4 in einem 120mm Frame (gelöst)

Moin zusammen,

nach einigen Erfahrungen mit CC3D, APM / Pixhawk will ich es mit der Autoquad M4 versuchen. Da ich eine 3D Drucker besitze, habe ich mir ein kleines Frame gebastelt. Ich bin auch schon indoor geflogen und der fliegt schon ganz gut. Als Sender nutze ich eine DEVO 10 mit DeviationTX . Mit der QGroundControl for Autoquad habe ich jetzt meinen Sender eingestellt, damit auch die Flugmodis geschaltet werden können. Leider gibt es z.Z. keine M4 Erweiterung und so nutze ich die SW über USB.
Momentan gelingt es mir nicht zu armen und ich finde nicht den Grund dafür. Vermutlich habe ich eine Parameter falsch gesetzt. Auch mit GPS Fix kann ich nicht armen. Kalibrieren und speichern über den Sender funktioniert. Zu meinen Fragen
Wie kann ich herausfinden, warum das Armen nicht mehr funktioniert ?
Soll als Protokoll besser DSM2 oder DSMX eingestellt werden ?

Binden besser mit Fester ID oder ohne ?
Hier ein paar erste Bilder. Sobald der wieder fliegt kommt noch ein FPV Kamera / Sender dran.
VG HAL


 
Zuletzt bearbeitet:
#2
Hi,
willkommen in der Welt der Autoquads!

Der M4 Expander ist für deinen kleinen Hüpfer viel zu schwer! Da wirst du keine wirkliche Freude dran haben. Dann doch lieber ein KISSSYS Expander nehmen (https://viacopter.eu/multirotor-shop/autoquad-m4/kisssys-expander-for-m4-150-multicopter-store) oder sowas
SANY0024.jpg
Wiegt wie abgebildet (Inkl. Kabel) 9g --> immer noch heftig für ein 120mm Quad. Da müsste mal die 2.54mm Leisten weglassen da ja eh die on-board ESC genutzt werden (spart dann ein paar Gramm).

Würde lieber DSMX nehmen; geht aber beides Problemlos (sogar 18 Kanäle!).

Was die Flugmodi anbelangt ... wie bist du denn vorher geflogen OHNE dass du die schalten konntest? Du musst bloß dafür sorgen dass dein Kanal sich im benötigten Wertebereich befindet (lieber ein paar clicks mehr).

Hast du eine PID oder eine QUATOS FW? Wenn der QUATOS Key nicht stimmt kannst du die QUATOS FW nicht armen.
 
#3
Hallo aBUGSworstnightmare,
vielen Dank für die freundliche Begrüßung ! Für den ersten Flug hatte ich die Parameter von dem Lady Bird Standard ( dummerweise mit QUATAS ) geladen und an dem Sender nur das Protokoll umgestellt Damit waren Channel 6 + 7 auf "0" und ich konnte einen ersten indoor "Flug" ausprobieren. Für die Erweiterung hatte ich vor zunächst KISSSYS nehmen, ist aber momentan nirgendwo lieferbar. Später soll die FS in einen grösseren Copter mit dem M4 Expander.

Das mit dem QUATOS FW war ein guter Tipp . Der Key war schon bei Lieferung eingetragen aber ich muß den irgendwie gelöscht haben. Nachdem ich den jetzt wieder eingetragen haben, klappt auch das Armen wieder .
Besten Dank !
BTW. ich habe jetzt die Lady Bird Parameter ohne QUATOS geladen.
 
Zuletzt bearbeitet:
#4
..
BTW. ich habe jetzt die Lady Bird Parameter ohne QUATOS geladen.
Ähm... die Parameter müssen auch zur Firmware passen! Wenn du eine PID-Firmware hast und die mit QUATOS-Parametern fütterst kommt da genau so Murks raus wie umgekehrt!

Zu einer QUATOS-Firmware gehören auch QUATOS-Parameter; nur dafür braucht man einen Lizenz (bis 1kg gehört dazu).
Zu einer PID Firmware gehören PID Parameter; keine Gewichtsbeschränkung (gesetzliche Regelungen beachten!)
 
#5
Ähm... die Parameter müssen auch zur Firmware passen! Wenn du eine PID-Firmware hast und die mit QUATOS-Parametern fütterst kommt da genau so Murks raus wie umgekehrt!

Zu einer QUATOS-Firmware gehören auch QUATOS-Parameter; nur dafür braucht man einen Lizenz (bis 1kg gehört dazu).
Zu einer PID Firmware gehören PID Parameter; keine Gewichtsbeschränkung (gesetzliche Regelungen beachten!)
Die FW war schon geladen und ich habe daran nichts geändert. Wie erkenne ich um welche FW es sich handelt?
BTW.Inzwischen gibt es auch einen Baubericht im WF Forum
http://walkerafans-forum.de/threads/120mm-fpv-racer-mit-gps-und-autonomen-modus.2454/#post-54892
 
#6
Die FW war schon geladen und ich habe daran nichts geändert. Wie erkenne ich um welche FW es sich handelt?
BTW.Inzwischen gibt es auch einen Baubericht im WF Forum
http://walkerafans-forum.de/threads/120mm-fpv-racer-mit-gps-und-autonomen-modus.2454/#post-54892
Ob eine QUATOS FW läuft sieht man in der Statusbar
quatos-enabled-status-bar.jpg
oder der Console
firmware-quatos-communication-console.jpg

Wenn du den Quatos Lizenzschlüssel auf 0 setzt wirst du auch 'merken' ob das Quatos oder PID ist; bei QUATOS passiert nichts; lässt sich nicht armen.
 
#7
Das sieht bei mir leider anders aus und ich kann nicht erkennen , ob das eine Quatos FW ist oder nicht:
 
Zuletzt bearbeitet:
#9
ich hatte Heartbeat nicht aktiviert und deshalb keine bootmeldungen gesehen. Jetzt sehe ich die Meldungen, habe aber ein neues Problem. Ich kann Armen, aber die Motoren ( mit angestecktem Akku) laufen nicht an. Akustisch kommt beim "Gas geben" "Aktive"

Nach Armen:

Nach Gas geben



So langsam zweifel ich etwas am AQ.....
 
#11
naja vielleicht hätte ich schreiben sollen, so langsam zweifel ich an mir ;-)

Hier die Parameter:
# Onboard parameters for system MAV 004

COMM_BAUD1 115200
COMM_BAUD2 230400
COMM_BAUD3 3000000
COMM_BAUD4 460800
COMM_BAUD5 115200
COMM_BAUD6 115200
COMM_BAUD7 115200
COMM_STREAM_TYP1 2
COMM_STREAM_TYP2 0
COMM_STREAM_TYP3 0
COMM_STREAM_TYP4 0
COMM_STREAM_TYP5 2
COMM_STREAM_TYP6 0
COMM_STREAM_TYP7 0
CONFIG_VERSION 128
CTRL_DBAND_THRO 40
CTRL_DEAD_BAND 40
CTRL_FACT_PITC 0.0500000007451
CTRL_FACT_ROLL 0.0500000007451
CTRL_FACT_THRO 0.800000011921
CTRL_MAN_YAW_RT 180
CTRL_MAX 1446
CTRL_MIN_THROT 20
CTRL_NAV_YAW_RT 180
CTRL_PID_TYPE 0
CTRL_TLT_ANG_D 8400
CTRL_TLT_ANG_DM 725
CTRL_TLT_ANG_F 0.25
CTRL_TLT_ANG_I 0.00240000011399
CTRL_TLT_ANG_IM 360
CTRL_TLT_ANG_OM 1200
CTRL_TLT_ANG_P 290
CTRL_TLT_ANG_PM 725
CTRL_TLT_RTE_D 34600
CTRL_TLT_RTE_DM 9999
CTRL_TLT_RTE_F 0.25
CTRL_TLT_RTE_I 0
CTRL_TLT_RTE_IM 9999
CTRL_TLT_RTE_OM 1200
CTRL_TLT_RTE_P 0
CTRL_TLT_RTE_PM 9999
CTRL_YAW_ANG_D 0
CTRL_YAW_ANG_DM 0
CTRL_YAW_ANG_F 0
CTRL_YAW_ANG_I 1.99999994948e-05
CTRL_YAW_ANG_IM 0.0399999991059
CTRL_YAW_ANG_OM 1.25
CTRL_YAW_ANG_P 0.0500000007451
CTRL_YAW_ANG_PM 1.25
CTRL_YAW_RTE_D 240
CTRL_YAW_RTE_DM 386
CTRL_YAW_RTE_F 0.25
CTRL_YAW_RTE_I 0.725000023842
CTRL_YAW_RTE_IM 386
CTRL_YAW_RTE_OM 870
CTRL_YAW_RTE_P 1445
CTRL_YAW_RTE_PM 386
GMBL_NTRL_PITCH 1575
GMBL_NTRL_ROLL 1442
GMBL_PITCH_PORT 0
GMBL_PSTHR_CHAN 0
GMBL_PSTHR_PORT 0
GMBL_PWM_FREQ 200
GMBL_PWM_MAX_PT 2250
GMBL_PWM_MAX_RL 2250
GMBL_PWM_MIN_PT 750
GMBL_PWM_MIN_RL 750
GMBL_ROLL_EXPO 0
GMBL_ROLL_PORT 0
GMBL_SCAL_PITCH 0.0109890112653
GMBL_SCAL_ROLL 0.0142857143655
GMBL_SLEW_RATE 0.00499999988824
GMBL_TILT_PORT 0
GMBL_TRIG_CH_NEU 0
GMBL_TRIG_DIST 0
GMBL_TRIG_ON_PWM 2100
GMBL_TRIG_ON_TIM 1000
GMBL_TRIG_PORT 0
GMBL_TRIG_TIME 0
IMU_ACC_ALGN_XY 0
IMU_ACC_ALGN_XZ 0
IMU_ACC_ALGN_YX 0
IMU_ACC_ALGN_YZ 0
IMU_ACC_ALGN_ZX 0
IMU_ACC_ALGN_ZY 0
IMU_ACC_BIAS1_X 0
IMU_ACC_BIAS1_Y 0
IMU_ACC_BIAS1_Z 0
IMU_ACC_BIAS2_X 0
IMU_ACC_BIAS2_Y 0
IMU_ACC_BIAS2_Z 0
IMU_ACC_BIAS3_X 0
IMU_ACC_BIAS3_Y 0
IMU_ACC_BIAS3_Z 0
IMU_ACC_BIAS_X -0.0187944993377
IMU_ACC_BIAS_Y -0.212126299739
IMU_ACC_BIAS_Z 19.8092708588
IMU_ACC_SCAL1_X 0
IMU_ACC_SCAL1_Y 0
IMU_ACC_SCAL1_Z 0
IMU_ACC_SCAL2_X 0
IMU_ACC_SCAL2_Y 0
IMU_ACC_SCAL2_Z 0
IMU_ACC_SCAL3_X 0
IMU_ACC_SCAL3_Y 0
IMU_ACC_SCAL3_Z 0
IMU_ACC_SCAL_X 1
IMU_ACC_SCAL_Y 1
IMU_ACC_SCAL_Z 1
IMU_FLIP 1
IMU_GYO_ALGN_XY 0
IMU_GYO_ALGN_XZ 0
IMU_GYO_ALGN_YX 0
IMU_GYO_ALGN_YZ 0
IMU_GYO_ALGN_ZX 0
IMU_GYO_ALGN_ZY 0
IMU_GYO_BIAS1_X 0
IMU_GYO_BIAS1_Y 0
IMU_GYO_BIAS1_Z 0
IMU_GYO_BIAS2_X 0
IMU_GYO_BIAS2_Y 0
IMU_GYO_BIAS2_Z 0
IMU_GYO_BIAS3_X 0
IMU_GYO_BIAS3_Y 0
IMU_GYO_BIAS3_Z 0
IMU_GYO_BIAS_X -0.0545015409589
IMU_GYO_BIAS_Y -0.0386690981686
IMU_GYO_BIAS_Z -0.00237021106295
IMU_GYO_SCAL_X 1
IMU_GYO_SCAL_Y 1
IMU_GYO_SCAL_Z 1
IMU_MAG_ALGN_XY -0.0242318604141
IMU_MAG_ALGN_XZ -0.0653769895434
IMU_MAG_ALGN_YX 0
IMU_MAG_ALGN_YZ 0.00332787702791
IMU_MAG_ALGN_ZX 0
IMU_MAG_ALGN_ZY 0
IMU_MAG_BIAS1_X 0
IMU_MAG_BIAS1_Y 0
IMU_MAG_BIAS1_Z 0
IMU_MAG_BIAS2_X 0
IMU_MAG_BIAS2_Y 0
IMU_MAG_BIAS2_Z 0
IMU_MAG_BIAS3_X 0
IMU_MAG_BIAS3_Y 0
IMU_MAG_BIAS3_Z 0
IMU_MAG_BIAS_X -3.19692802429
IMU_MAG_BIAS_Y 0.177330806851
IMU_MAG_BIAS_Z 2.46686911583
IMU_MAG_DECL 0
IMU_MAG_INCL -65
IMU_MAG_SCAL1_X 0
IMU_MAG_SCAL1_Y 0
IMU_MAG_SCAL1_Z 0
IMU_MAG_SCAL2_X 0
IMU_MAG_SCAL2_Y 0
IMU_MAG_SCAL2_Z 0
IMU_MAG_SCAL3_X 0
IMU_MAG_SCAL3_Y 0
IMU_MAG_SCAL3_Z 0
IMU_MAG_SCAL_X 0.955187320709
IMU_MAG_SCAL_Y 0.975701987743
IMU_MAG_SCAL_Z 0.874859809875
IMU_PRESS_SENSE 0
IMU_ROT -135
LIC_KEY1 xxxx
LIC_KEY2 0
LIC_KEY3 0
MOT_ARM 0
MOT_CANH 0
MOT_CANL 0
MOT_FRAME 0
MOT_MAX 1050
MOT_MIN 0
MOT_PWRD_01_P 5.79595708847
MOT_PWRD_01_R 5.79595708847
MOT_PWRD_01_T 1
MOT_PWRD_01_Y -0.25
MOT_PWRD_02_P 5.79595708847
MOT_PWRD_02_R -5.79595708847
MOT_PWRD_02_T 1
MOT_PWRD_02_Y 0.25
MOT_PWRD_03_P -5.79595708847
MOT_PWRD_03_R -5.79595708847
MOT_PWRD_03_T 1
MOT_PWRD_03_Y -0.25
MOT_PWRD_04_P -5.79595708847
MOT_PWRD_04_R 5.79595708847
MOT_PWRD_04_T 1
MOT_PWRD_04_Y 0.25
MOT_PWRD_05_P 0
MOT_PWRD_05_R 0
MOT_PWRD_05_T 0
MOT_PWRD_05_Y 0
MOT_PWRD_06_P 0
MOT_PWRD_06_R 0
MOT_PWRD_06_T 0
MOT_PWRD_06_Y 0
MOT_PWRD_07_P 0
MOT_PWRD_07_R 0
MOT_PWRD_07_T 0
MOT_PWRD_07_Y 0
MOT_PWRD_08_P 0
MOT_PWRD_08_R 0
MOT_PWRD_08_T 0
MOT_PWRD_08_Y 0
MOT_PWRD_09_P 0
MOT_PWRD_09_R 0
MOT_PWRD_09_T 0
MOT_PWRD_09_Y 0
MOT_PWRD_10_P 0
MOT_PWRD_10_R 0
MOT_PWRD_10_T 0
MOT_PWRD_10_Y 0
MOT_PWRD_11_P 0
MOT_PWRD_11_R 0
MOT_PWRD_11_T 0
MOT_PWRD_11_Y 0
MOT_PWRD_12_P 0
MOT_PWRD_12_R 0
MOT_PWRD_12_T 0
MOT_PWRD_12_Y 0
MOT_PWRD_13_P 0
MOT_PWRD_13_R 0
MOT_PWRD_13_T 0
MOT_PWRD_13_Y 0
MOT_PWRD_14_P 0
MOT_PWRD_14_R 0
MOT_PWRD_14_T 0
MOT_PWRD_14_Y 0
MOT_PWRD_15_P 0
MOT_PWRD_15_R 0
MOT_PWRD_15_T 0
MOT_PWRD_15_Y 0
MOT_PWRD_16_P 0
MOT_PWRD_16_R 0
MOT_PWRD_16_T 0
MOT_PWRD_16_Y 0
MOT_START 0
MOT_VALUE2T_A1 2.46399998665
MOT_VALUE2T_A2 0.507000029087
MOT_VALUE_SCAL 3.5
NAV_ALT_POS_I 0
NAV_ALT_POS_IM 0
NAV_ALT_POS_OM 1
NAV_ALT_POS_P 0.20000000298
NAV_ALT_POS_PM 1
NAV_ALT_SPED_I 2.84999990463
NAV_ALT_SPED_IM 700
NAV_ALT_SPED_OM 700
NAV_ALT_SPED_P 200
NAV_ALT_SPED_PM 150
NAV_CEILING 0
NAV_DIST_I 0
NAV_DIST_IM 0
NAV_DIST_OM 999
NAV_DIST_P 0.5
NAV_DIST_PM 999
NAV_HDFRE_CHAN 0
NAV_LANDING_VEL 1
NAV_MAX_DECENT 1.5
NAV_MAX_SPEED 5
NAV_SPEED_I 0.00749999983236
NAV_SPEED_IM 20
NAV_SPEED_OM 30
NAV_SPEED_P 10.5
NAV_SPEED_PM 20
PPM_CHAN_MID 1512
PPM_SCALER 3
PPM_THROT_LOW 1090
QUATOS_AM1 -8
QUATOS_AM1_KNOB 0
QUATOS_AM2 -50
QUATOS_AM2_KNOB 0
QUATOS_J_PITCH 4.09999993281e-05
QUATOS_J_ROLL 4.09999993281e-05
QUATOS_J_YAW 7.89999976405e-05
QUATOS_K1_KNOB 0
QUATOS_L1_ASP -10
QUATOS_L1_K1 18.6000003815
QUATOS_MAX_OUT 1.5
QUATOS_MM_P01 0.0430000014603
QUATOS_MM_P02 0.0430000014603
QUATOS_MM_P03 -0.0430000014603
QUATOS_MM_P04 -0.0430000014603
QUATOS_MM_P05 0
QUATOS_MM_P06 0
QUATOS_MM_P07 0
QUATOS_MM_P08 0
QUATOS_MM_P09 0
QUATOS_MM_P10 0
QUATOS_MM_P11 0
QUATOS_MM_P12 0
QUATOS_MM_P13 0
QUATOS_MM_P14 0
QUATOS_MM_P15 0
QUATOS_MM_P16 0
QUATOS_MM_R01 0.0430000014603
QUATOS_MM_R02 -0.0430000014603
QUATOS_MM_R03 -0.0430000014603
QUATOS_MM_R04 0.0430000014603
QUATOS_MM_R05 0
QUATOS_MM_R06 0
QUATOS_MM_R07 0
QUATOS_MM_R08 0
QUATOS_MM_R09 0
QUATOS_MM_R10 0
QUATOS_MM_R11 0
QUATOS_MM_R12 0
QUATOS_MM_R13 0
QUATOS_MM_R14 0
QUATOS_MM_R15 0
QUATOS_MM_R16 0
QUATOS_MM_Y01 -1
QUATOS_MM_Y02 1
QUATOS_MM_Y03 -1
QUATOS_MM_Y04 1
QUATOS_MM_Y05 0
QUATOS_MM_Y06 0
QUATOS_MM_Y07 0
QUATOS_MM_Y08 0
QUATOS_MM_Y09 0
QUATOS_MM_Y10 0
QUATOS_MM_Y11 0
QUATOS_MM_Y12 0
QUATOS_MM_Y13 0
QUATOS_MM_Y14 0
QUATOS_MM_Y15 0
QUATOS_MM_Y16 0
QUATOS_M_TLT_RT 1.5
QUATOS_M_YAW_RT 1.5
QUATOS_PROP_K1 200
QUATOS_PT_KNOB 0
QUATOS_QUAT_TAU 0.0500000007451
RADIO_AUX2_CH 6
RADIO_AUX3_CH 7
RADIO_AUX4_CH 8
RADIO_AUX5_CH 9
RADIO_AUX6_CH 10
RADIO_AUX7_CH 11
RADIO_FLAP_CH 5
RADIO_GEAR_CH 4
RADIO_PITC_CH 2
RADIO_ROLL_CH 1
RADIO_RUDD_CH 3
RADIO_SETUP 8
RADIO_THRO_CH 0
RADIO_TYPE -1
SIG_BEEP_PRT 0
SIG_LED_1_PRT 0
SIG_LED_2_PRT 0
SIG_PWM_PRT 0
SPVR_BAT_CRV1 9.21014404297
SPVR_BAT_CRV2 14.8179597855
SPVR_BAT_CRV3 -58.9025497437
SPVR_BAT_CRV4 116.608200073
SPVR_BAT_CRV5 -107.419296265
SPVR_BAT_CRV6 37.7908210754
SPVR_FS_ADD_ALT 0
SPVR_FS_RAD_ST1 0
SPVR_FS_RAD_ST2 0
SPVR_LOW_BAT1 3.11999988556
SPVR_LOW_BAT2 3.11999988556
TELEMETRY_RATE 20
 
#12
Nach dem ich noch einmal den Compass Kalibriert habe zeigt er mir diesen Fehler
Link serielle Schnittstelle COM3 connected.
(MAV 004) Radio init
(MAV 004) DSM: Found CYRF6963 chip
(MAV 004) CYRF6936 on RC port 0
(MAV 004) GPS init
(MAV 004) Nav init
(MAV 004) Command interface init
(MAV 004) Motors init
(MAV 004) Control init
(MAV 004) GCS: UNABLE TO DECODE MESSAGE NUMBER 23
(MAV 004) Quatos init
(MAV 004) Control task started
(MAV 004) Gimbal init
(MAV 004) AQ S/N: 33313037-33334711-001B0020
(MAV 004) Mavlink SYS ID: 4
(MAV 004) SYS Clock: 168 MHz
(MAV 004) 7628/7692 heap used/high water
(MAV 004) 32512 of 40960 CCM heap used
(MAV 004) Radio task started
(MAV 004) Run task started
(MAV 004) CYRF: sync A
(MAV 004) GPS task task started
(MAV 004) AQ FW ver: 7.0 - EXPR rev432 b1848, HW ver: 8 rev6
(MAV 004) Disarmed
(MAV 004) Initialization complete, READY.
(MAV 004) RTC set: 2016-01-22 13:42:03 UTC
(MAV 004) CYRF: sync B
(MAV 004) CYRF: receiving
(MAV 004) Armed
 
#13
Die Parameter funktionieren sowohl für PID als auch QUATOS (wenn der richtige Lizenz-Key eingetragen ist).

Ich würde ein Load Defaults machen, write Flash, Parameter neu laden (from file), write Flash.

Bei Gelegenheit solltest du dann noch die MAG Inclination/Declination auf deinen Standort anpassen.

Laut dem Log läuft eine PID Firmware da QUATOS nicht initialisiert wird. Ich würde eh auf die neuste - auch wenn da experimentell steht - Firmware gehen (ich fliege nur solche und hatte noch nie Probleme... Ausnahme Auge/Hirn/Hand-Koordination)

Vergiss die message 23; das ist kein Problem.
 
#14
Nach Load defaults, write flash , Parameter Ladybird laden und Quatos Key eingeben, laufen die Motoren wieder. Ohne Key konnte ich Armen aber die Motoren liefen nicht ( strange )
Ich habe auch versucht die FW zu flashen aber das hat nicht geklappt.

Betriebssystem W10
AQ in BOOTLOADER MODE gestartet
W10 zeigt:

Versuchen die FW zu flashen:

andere DFU-UTIL.exe

Hast Du noch einen Tipp ?
 
#15
Nach Load defaults, write flash , Parameter Ladybird laden und Quatos Key eingeben, laufen die Motoren wieder. Ohne Key konnte ich Armen aber die Motoren liefen nicht ( strange )
Das ist nicht 'strange', das ist das normale Verhalten der QUATOS FW. Ohne Key kann man zwar armen, es passiert aber sonst nichts --> so weiß man dann dass der Quatos Key noch nicht eingegeben oder fehlerhaft ist.

Ich habe auch versucht die FW zu flashen aber das hat nicht geklappt.

Betriebssystem W10
AQ in BOOTLOADER MODE gestartet
W10 zeigt:

Versuchen die FW zu flashen:

andere DFU-UTIL.exe

Hast Du noch einen Tipp ?
Eine Frage vorweg: auf Windows 10 up-gegraded oder war das schon immer auf dem Rechner?

Info: Es gibt mit einigen USB3.0 Chipsätzen Probleme - ist bekannt - hat aber nichts mit Autoquad zu tun!

Ich hatte das gleiche Verhalten nach dem upgrade von Win7 Prof auf Win 10 --> alle M4 wurden nicht mehr erkannt (ich habe M4V1 und V2'er).
Liegt daran dass Windows den Treiber 'zerschrotet' --> folgende Vorgehensweise sollte helfen:

- Zadiag Tool tunterladen - http://zadig.akeo.ie
- M4 im Bootloader-Modus starten und an den Rechner anschließen
- Das Zadiag-Tool starten (muss nicht installiert werden). Sollte dann vergleichbar dem Screenshot aussehen.
zadig.png
Wenn das Tool zum ersten mal läuft steht 'INSTALL DRIVER' auf dem Button. Wenn der STM32 Bootloader nicht angezeigt wird bitte auf auf OPTIONS-LIST ALL DEVICES klicken.
Als Treiber dann den WINSUB auswählen (neuste Rev) und dann INSTALL klicken.
Im Device-Manager sollte das dann wie folgt aussehen:
dev-man.jpg


Die DFU-util die du verwendest (aus dem zweiten Screenshot) funktioniert auf meinem iMac mit USB3.0 Chipset tadellos.
Hier mal ein Messagedump des kompletten Vorgangs:
Code:
C:\Users\admin\Desktop\qgroundcontrol_aq-Win32-1.6.3.1\aq\bin\dfu-util.exe -a 0 -d 0483:df11 -s 0x08000000:leave -R -D C:\Users\admin\Desktop\FW-Peter_0107_RCTSpider\autoquad_quatos_m4r6extesc_peter.bin

dfu-util 0.7-msvc

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Opening DFU capable USB device...
ID 0483:df11
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 2048
DfuSe interface name: "Internal Flash  "
Downloading to address = 0x08000000, size = 206824

Download   [                         ]   0%            0 bytes
Download   [                         ]   0%         2048 bytes
Download   [=                        ]   4%        10240 bytes
Download   [=                        ]   7%        16384 bytes
Download   [==                       ]   8%        18432 bytes
Download   [==                       ]  11%        24576 bytes
Download   [===                      ]  12%        26624 bytes
Download   [===                      ]  15%        32768 bytes
Download   [====                     ]  16%        34816 bytes
Download   [====                     ]  17%        36864 bytes
Download   [=====                    ]  20%        43008 bytes
Download   [=====                    ]  21%        45056 bytes
Download   [======                   ]  24%        51200 bytes
Download   [=======                  ]  28%        59392 bytes
Download   [=======                  ]  31%        65536 bytes
Download   [========                 ]  32%        67584 bytes
Download   [========                 ]  35%        73728 bytes
Download   [=========                ]  36%        75776 bytes
Download   [=========                ]  39%        81920 bytes
Download   [==========               ]  40%        83968 bytes
Download   [==========               ]  43%        90112 bytes
Download   [===========              ]  44%        92160 bytes
Download   [===========              ]  47%        98304 bytes
Download   [============             ]  48%       100352 bytes
Download   [============             ]  51%       106496 bytes
Download   [=============            ]  52%       108544 bytes
Download   [=============            ]  55%       114688 bytes
Download   [==============           ]  56%       116736 bytes
Download   [==============           ]  59%       122880 bytes
Download   [===============          ]  60%       124928 bytes
Download   [===============          ]  63%       131072 bytes
Download   [================         ]  64%       133120 bytes
Download   [================         ]  67%       139264 bytes
Download   [=================        ]  68%       141312 bytes
Download   [=================        ]  71%       147456 bytes
Download   [==================       ]  72%       149504 bytes
Download   [==================       ]  75%       155648 bytes
Download   [===================      ]  76%       157696 bytes
Download   [===================      ]  79%       163840 bytes
Download   [====================     ]  80%       165888 bytes
Download   [====================     ]  83%       172032 bytes
Download   [=====================    ]  84%       174080 bytes
Download   [=====================    ]  87%       180224 bytes
Download   [======================   ]  88%       182272 bytes
Download   [======================   ]  91%       188416 bytes
Download   [=======================  ]  92%       190464 bytes
Download   [=======================  ]  95%       196608 bytes
Download   [======================== ]  96%       198656 bytes
Download   [======================== ]  99%       204800 bytes
Download   [=========================] 100%       206848 bytes
Download done.
File downloaded successfully
Transitioning to dfuMANIFEST state
Resetting USB to switch back to runtime mode
Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
can't detach

C:\Users\admin\Desktop\qgroundcontrol_aq-Win32-1.6.3.1\aq\bin\dfu-util.exe -a 0 -d 0483:df11 -s 0x08000000:leave -R -D C:\Users\admin\Downloads\aqv7.1.1852-hwv8.5-quatos-ext_esc\aqv7.1.1852-hwv8.5-quatos-ext_esc.bin

dfu-util 0.7-msvc

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Cannot open DFU device 0483:df11
No DFU capable USB device available
Selbes Problem wie bei dir mit einem M4V2 --> mit ZADIAG neu installiert --> Flashen funzt. Danach einen M4V1 probiert --> klappt nicht.

WENN IHR M4V1 UND M4V2 NUTZT MÜSST IHR FÜR BEIDEN DEN TREIBER NEU INSTALLIEREN!
 
#16
Das ist nicht 'strange', das ist das normale Verhalten der QUATOS FW. Ohne Key kann man zwar armen, es passiert aber sonst nichts --> so weiß man dann dass der Quatos Key noch nicht eingegeben oder fehlerhaft ist.
mh, ich hatte verstanden, dass ich keine QUATOS FW installiert habe.

Eine Frage vorweg: auf Windows 10 up-gegraded oder war das schon immer auf dem Rechner?
Das ist ein Upgrade von W8.1

BTW, falls jemand den Kleinen nachdrucken will: http://www.thingiverse.com/thing:1284431

Dein Tipp war mal wieder gold richtig. Ich musste den W10 Treiber "replacen" dann hat es mit dem flashen geklappt:

Code:
D:\Drohnen\Autoquad\qgroundcontrol_aq-Win32-1.6.3.1\aq\bin\dfu-util.exe -a 0 -d 0483:df11 -s 0x08000000:leave -R -D D:\Drohnen\Autoquad\aqv7.1.1852-hwv8.6\aqv7.1.1852-hwv8.6.bin
dfu-util 0.7

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Filter on vendor = 0x0483 product = 0xdf11
Opening DFU capable USB device... ID 0483:df11
Run-time device DFU version 011a
Found DFU: [0483:df11] devnum=0, cfg=1, intf=0, alt=0, name="@Internal Flash  /0x08000000/04*016Kg,01*064Kg,07*128Kg"
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 2048
DfuSe interface name: "Internal Flash  "
Downloading to address = 0x08000000, size = 228460
................................................................................................................
File downloaded successfully
Transitioning to dfuMANIFEST state
Resetting USB to switch back to runtime mode
No valid DFU suffix signature
Warning: File has no DFU suffix
Error during download get_status
can't detach

[QUOTE][/QUOTE]
 
#17
Allerdingst musste ich die FW für QUATOS flashen , sonst liefen die Motoren wieder nicht an. Liegt das dann an den Parametern ? Ich werde sicherlich später die AQ M4 in einem grösseren Kopter einbauen und müsste dann mit PID's fliegen und nicht QUATOS.
 
#18
Allerdingst musste ich die FW für QUATOS flashen , sonst liefen die Motoren wieder nicht an. Liegt das dann an den Parametern ? Ich werde sicherlich später die AQ M4 in einem grösseren Kopter einbauen und müsste dann mit PID's fliegen und nicht QUATOS.
Ich habe es hinbekommen. Parameter und FW müssen immer zusammenpassen , jetzt klappt es auch mit PID's
 
RCLogger

FPV1

Banggood

Oben