OpenTX Downgraden / ältere Firmware downloaden

#1
Hallo Leute,

ich hab mir vor kurzem die neueste Firmware OpenTX 2.3.5 heruntergeladen und installiert. Leider hatte ich vergessen die vorige Firmware 2.3.4 zu sichern, jetzt hab ich das Problem das in der Version 2.3.5 Problem mit dem Lua Script aufkommen und ich wieder die Firmware 2.3.4 installieren will.
Jetzt finde ich aber keine Option ältere Firmware bei OpenTX runterzuladen, weil es nur immer die neueste zum Download anbietet ?
Könnt ihr mir hierbei helfen :???:

Sender: Taranis X9D + SE
 
#2
Du musst Companion 2.3.4 installieren, erst dann kannst die entsprechende Firmware generieren.
Es besteht also immer die Verbindung, Companion mit der jeweiligen Firmware. Du kannst das "alte" Companion parallel dazu Installieren, mußt aber dem Kind ein anderes Verzeichnis zuordnen. vergiss nicht auf den SD-Karten Inhalt eine Blick zu werfen, weiß jetzt aus dem Stehgreif nicht ob die Zusammen passen.
 

wolepo

Erfahrener Benutzer
#3
Hallo,
hier kannst Du Dir jede OTX-Version runterladen. Ob dan aber die passende Firmware kommt, weis ich nicht.
 

FJH

Erfahrener Benutzer
#4
Im Downloadfenster von Companion wird ein Button angeboten "Softwarestände". Über den lassen sich dann alte OTx-Versionen runterladen. Hier bei OTx 2.3.x ist diese Funktion aber insofern deaktiviert, als in dem dann erscheinenden Fenster keine Versionen vor 2.3.5 angeboten werden, da alle Vorversionen einen Programmierfehler enthalten. Wenn du zurück möchtest, dann kannst du natürlich auch zu 2.2.4 zurück. Dürfte für deine X9D keinen relevanten Unterschied machen.

Und "alte" Companionversionen brauchst du auch nicht zu probieren, es wird dir nur und ausschliesslich die OTx 2.3.5 zum Download angeboten, keine Vorgängerversionen.
 
#5
Danke für die Tipp´s =)
Also ich hab es schon versucht mit dem alten Companion 2.3.4 zu installieren, aber ich muß etwas falsch gemacht haben. Weil wenn ich auf Download im Companion geh, will es immer die Firmware 2.3.5 (neueste) runterladen. Ich versuch es nachher nochmal =)
 
#6
Im Downloadfenster von Companion wird ein Button angeboten "Softwarestände". Über den lassen sich dann alte OTx-Versionen runterladen. Hier bei OTx 2.3.x ist diese Funktion aber insofern deaktiviert, als in dem dann erscheinenden Fenster keine Versionen vor 2.3.5 angeboten werden, da alle Vorversionen einen Programmierfehler enthalten. Wenn du zurück möchtest, dann kannst du natürlich auch zu 2.2.4 zurück. Dürfte für deine X9D keinen relevanten Unterschied machen.

Und "alte" Companionversionen brauchst du auch nicht zu probieren, es wird dir nur und ausschliesslich die OTx 2.3.5 zum Download angeboten, keine Vorgängerversionen.
Ok Danke für die Info! Dann ist hier die mühe vergeblich und ich muss warten bis ein neue OpenTX Version raus kommt, weil den Fehler mit dem Lua Script hab ich auf github bereits gemeldet und wir auch im 2.3.6 behoben...
 

r41065

Erfahrener Benutzer
#8
man kann Companion in den Verschiedenen Versionen auch parallel auf dem PC installieren.

Da OpenTx aber erst beim Download mit den entsprechenden Optionen Compiliert wird kann man damit immer nur die letzte Firmware-Version herunterladen:
also
- für OpenTx 2.0.x die 2.0.20
- für OpenTx 2.1.x die 2.1.9
- für OpenTx 2.2.x die 2.2.4
und für OpenTX 2.3.x aktuell die 2.3.5

Der Aufwand für alle Versionen Serverseitig alle Optionen bereitzustellen ist zu hoch ...

Wenn du vor Erscheinen der 2.3.6 testen willst ob der Fehler wirklich behoben ist musst du auf die aktuellen Nightly Builds ausweichen....
 
Zuletzt bearbeitet:

r41065

Erfahrener Benutzer
#10
Ich glaube da kennt jemand nicht den Unterschied zwischen PC Software ( Companion ) und Senderfirmware ...
 
Zuletzt bearbeitet:

r41065

Erfahrener Benutzer
#12
@FJH : Mein Beitrag #8 war nur eine Antwort auf #5:
Der Threadersteller hat ja Companion 2.3.4 auf seinem Rechner, kann damit aber keine FW2.3.4 herunterladen, es wird automatisch die höchste FW passend zur EEPROM Version geladen. Diese 2.3.5 ist im Bereich Lua aber fehlerhaft für die X9D (+) deshalb die Frage nach Downloadmöglichkeiten für eine ältere FW.
Um auf 2.2.4 zurückzugehen braucht man m.M. ein EEProm Backup einer 2.2er Version, ob man das 2.3er EEProm Zurückkonvertieren kann habe ich noch nicht probiert, bezweifle ich aber...

ps. probiere es aus mit Companion 2.2.2 kommt die FW2.2.4 , nicht die 2.3.5;
Kritisch waren die Versionen 2.3.0-2.3.4 nur für Horus und T16, nicht für Taranis Modelle...
aber es hilft nicht das horstimac verschiedene Downloadlinks für die Companion Software Version 2.3.4 auflistet. Wie du selber geschrieben hast kann man damit aktuell nur Firmware 2.3.5 laden....

pps. wenn ich die entsprechenden Beiträge dazu im Github querlese hat der Ersteller eine X9D+Se2019, d.h. keine Möglichkeit die 2.2.4 zu verwenden...
Ralf
 
Zuletzt bearbeitet:

Jimmy1952

Neuer Benutzer
#13
Moin
Zurück konvertieren geht.Auch das E'eprom Man braucht aber die bin Datei. Ich lasse meine immer so lange auf der Karte, bis ich halbwegs sicher bin das die Version mit meinen Optionen funktioniert Zudem sicher ich den Karteninhalt.
Mfg Hermann
 
#14
Vielen dank für die ganzen Antworten =)
Also ich werde das auch in Zukunft so handhaben, das ich immer vor den Firmware Update´s eine Sicherung mache, bevor ich was neues drauf lade !
 

FJH

Erfahrener Benutzer
#20
Dazu gehst du in Companion auf Einstellungen/Anwendungs-Einstellungen und dort kannst du bei Release channel auswählen "Releases (stable)" oder "Release candidates (testing)".
 
RCLogger

FPV1

Banggood

Banggood

Oben