Verbindungsproblem Taranis QX7 mit R-XSR/XM

#1
Hallo liebe Community,
über eine kleine Spielzeugdrone kam ich auf das Thema FPV-Quads.
Nach einiger Recherche habe ich mich dazu entschieden, zunächst klein anzufangen und zwar mit Kingkong Tiny 7 für zu Hause und einem HGLRC145 für draußen.
Da die Funke schon einige Zeit vorher eingetroffen ist, bin ich bisher nur im Liftoff Simulator geflogen.
Seit Anfang der Woche sind nun die Quads da und ich bin kurz davor, das Hobby aufzugeben, bevor es gestartet hat L
Ich kämpfe gleich mit 2 Themen….
Verbinden Funke-Empfänger:

Ich bekomme die Verbindung nicht hin, egal was ich ausprobiere.

Funke: Taranis QX7 (Banggood)
Empfänger: XM (Kingkong/Banggood), R-XSR (HGLRC/Hobbyking)
Der XM hat laut Aufkleber die Firmware für die Verbindung D16 international
Der R-XSR ist auf LBT-EU geflasht. Ich habe erfolgreich die Version international Version aufgespielt.
Die Taranis habe ich mit OpenTX auf non-Eu geflasht.
Das Alles nach der Anleitung von Phillip Seidel (blog)
XM: Stelle ich eine Spannungsversorgung bei gehaltenem Bind-Button her, fängt der Empfänger an grün zu blinken. Das soll er auch. Der Bind-Vorgang klappt aber nicht.
An der Taranis habe ich D16 Kanal 1-8 no Telemetrie eingestellt (auch hier alle anderen Optionen versucht)
R-XSR: Stelle ich eine Spannungsversorgung bei gehaltenem Bind-Button her, leuchten am Empfänger durchgehend alle 3 LEDs (rot grün blau).
Ich bin mir sicher, dass das alles auf eine Inkompatibilität zwischen Empfängerfirmware, Senderfirmware und XJT-Modul zusammenhängt, nur bringt mich das auch nicht weiter. Ich mache irgendwo einen Fehler…..
Mir wäre eventuell schon damit geholfen, wenn jemand auflisten könnte, welche Kombination von FW Versionen der Geräte bei ihm funktioniert.

Betaflight – Flightcontroller Verbindung:

Beim HGLRC konnte ich in der Vergangenheit bereits eine Verbindung herstellen.
Nun da der R-XSR und der Tiny7 gekommen sind, habe ich eine Verbindung zu Betaflight herstellen wollten. Bei beiden Controllern kommt die Meldung Verbindung fehlgeschlagen (serial port). Ich habe schon verdammt viel Zeit damit verbracht nach einer Lösung zu suchen.
Verschiedene USB Kabel, Zadig, Impulse RC Driver fix, Neuinstallation USB Treiber. Ich bin ratlos.

Das alles ist ganz schön unmotivierend und ich hoffe, dass mir jemand weiter helfen kann.
P.s.: Ich kenne es aus der Vergangenheit, dass Foren lediglich als „Dienstleistung“ zur Problemlösung angesehen werden. Das liegt nicht im meinem Interesse, auch wenn ich damit starte.

Im Voraus vielen Dank.
LG Micha
 

chrisfpv

Active member
#3
Ich habe die QX7. Bei der musst auch das interne Modul flashen! Das geht genauso wie mit den Empfängern nur Ebene nicht extern sondern intern auswählen.
Das Modul sollte allerdings schon die non EU FW haben wenn du die Tara von Banggood hast.
Wegen deinem Betaflight Problem wären einige Infos wichtig. Welche Version? Kannst du oben Rechts evtl. USB Verbindung zum FC manuell auswählen?
 
Zuletzt bearbeitet:
#4
Erstmal danke für die Antworten. Ich habe alle 3 Komponenten geflasht. Ich schreibe später wenn ich am Rechner bin mal die Versionen rein. Vielleicht aber noch einmal eine allgemeine Frage hierzu: senderfirmware wird über opentx erzeugt, xjt Modul hat eigene Firmware und Sender hat eigene firmware. - - > 3 Komponenten 3 verschiedene firmwares korrekt?
 

chrisfpv

Active member
#5
3 Komponenten bei der QX7?
OpenTX 2.2.2 und die des iXJT v170317 macht 2.
Oder hast du den Empfänger mitgezählt?
 
Zuletzt bearbeitet:
#7
Oh Mann ich trau mich kaum zu schreiben, aber bevor sich hier noch jemand die Mühe macht......
Beide Probleme gelöst.
Thema Sender/Empfänger: Wenn ich das nur wüsste. Habe zum xten Mal zwischen EU und deutsch gewechselt. Auf einmal klappt es.

Thema FC/Betaflight. Das 6. Kabel funktionierte (was mich wundert, da ich 2 der Kabel regelmäßig zum Datentransfer nutze)

Danke trotzdem Leute. Morgen gehts fliegen (Selbst der kleine ist krass laut mit schlafenden kids nebenan)
 
RCLogger

FPV1

Banggood

Banggood

Oben