AQ6 Firmware Upgrade

Snoopy

Neuer Benutzer
#1
Hallo zusammen,

ich habe ein Problem beim Firmware Upgrade auf die Version 'aqv7.1.1852-hwv6.1-dimu1.1': Das Upgrade selbst läuft fehlerfrei durch, aber nach Drücken des RESET-Tasters leuchtet nur die rote LED und es ist keine Verbindung mit der Ground Control Station möglich.

Ist das Problem grundsätzlich schon mal bei jemandem aufgetreten oder liegt es an der FW-Version?

Viele Grüße,
Stefan
 

r0sewhite

Erfahrener Benutzer
#2
Das hatte ich einmal: STM32 defekt. Das muss aber nicht heißen, dass das grundsätzlich der Fall ist. Vielleicht kann Peter ja noch was dazu sagen.
 

Snoopy

Neuer Benutzer
#3
Vielen Dank für den Hinweis.

Kann ich das irgendwie prüfen? Und wenn der STM32 defekt ist, kann ich dann den AQ6 wegwerfen?

Das Board ist noch nie geflogen, liegt aber schon einige Zeit herum, also keine Gewährleistung mehr.

Viele Grüße,
Stefan
 

keilie

Erfahrener Benutzer
#8
da bin ich überfragt, ich habe immer nur .bin Dateien zum flashen verwendet, habe aber auch nur AQ M4 im Einsatz. ich denke aber die FW sollte auf alle AQ passen
 

r0sewhite

Erfahrener Benutzer
#9
Auch wenn die Firmware funktional identisch ist, hat der M4 eine andere Firmware, als der AQ6. Passt also nicht.

Den STM32 kann man austauschen, wenn man entweder über eine Hotair Lötstation oder aber über viel Geschick im Umgang mit einem Lötkolben verfügt.
 

Snoopy

Neuer Benutzer
#10
Nachdem der STM32 wohl doch nicht defekt ist, habe ich noch mal verschiedene FW getestet und festgestellt, daß die Versionen 7.X mit DIMU-Unterstützung nicht laufen, während die älteren Versionen 6.X einwandfrei funktionieren.

Hat jemand dafür eine Erklärung?

Beste Grüße,
Stefan
 

r0sewhite

Erfahrener Benutzer
#11
Dann ist wohl entweder Deine DIMU nicht in Ordnung oder sie hat keinen guten Kontakt. Kann bei den Sockeln gerne passieren, wenn beim Löten etwas Flussmittel vom Lot reingezogen ist.
 

Snoopy

Neuer Benutzer
#12
Einen Fehler im Bereich der DIMU hatte ich aufgrund der beobachteten Symptome auch schon vermutet. Danke für Deinen Hinweis auf die Kontakte. Ich habe die Stifte der beiden Platinensteckverbinder mit einem Glasfaserradierer gereinigt und anschließend die DIMU-Platine mehrmals vorsichtig eingesteckt, um auch eventuelle Verschmutzungen aus den Buchsenkontakten zu entfernen. Leider ist das Problem damit nicht beseitigt. Ich werde wohl mal probeweise eine neue DIMU bestellen müssen. Wundert mich aber schon ein bißchen, daß so ein Defekt bei der Qualitätskontrolle unbemerkt bleiben konnte...
 

r0sewhite

Erfahrener Benutzer
#13
Also ich hatte noch keine defekte DIMU und ich hab bestimmt weit über 50 Stück verbaut. Allerdings oftmals Flussmittel in den Sockeln und da hilft ein- und ausstecken nicht wirklich. Die Sockel müssen mit Isopropanol eingeweicht werden, damit sich das Flussmittel löst. Noch besser ist ein Ultraschallbad in Isopropanol.

Eine neue DIMU wirst Du wohl nirgendwo bestellen können. AQ6 und DIMU gibt es schon lange nicht mehr.
 

Snoopy

Neuer Benutzer
#14
Habe ich mir eigentlich schon gedacht, daß ich das Flußmittel auf rein mechanischem Weg nicht heraus bekomme. Leider habe ich hier nicht die Möglichkeit einer Ultraschallreinigung.

Wie bekommst Du das gelöste Flußmittel nach dem Einweichen aus den Buchsenkontakten heraus ? Kann man das Kunststoffgehäuse abziehen um an die Kontakte zu kommen ?

Beste Grüße,
Stefan
 

Snoopy

Neuer Benutzer
#16
Danke für die Info. Ich hatte ja keine Ahnung, wie preiswert diese Ultraschallreiniger mittlerweile sind.

Könnt Ihr mir noch ein paar Tips zur Vorgehensweise, Einwirkzeit, usw. geben? Gibt es Bauteile, die vor dem Isopropanol geschützt werden müssen, z.B. Drucksensor, Reset-Taster oder Backup-Batterie? Ich habe das noch nie gemacht und der AQ6 ist ja auch nicht gerade billig gewesen. Bin für jeden Hinweis dankbar.

Beste Grüße,
Stefan
 
#17
Also, ich habe das Ding jetzt für zwei Stunden in Isopropanol (70% Vol.) gebadet und anschließend drei Minuten in den Ultraschallreiniger gelegt. Keine Besserung. Nach dem Reboot nur rote LED.

Macht Ihr noch was anders oder muß ich den Reinigungsprozeß mehrfach wiederholen?

Beste Grüße,
Stefan
 
RCLogger

FPV1

Banggood

Banggood

Oben