Link Quality Sensor von Tadango

#41
Hallo Alfons,

danke für den tollen Baubericht und die Super-Fotos! Leider hat der Sketch von Tadango einen kleinen Nachteil: wenn der Inverter nicht funktioniert, dann zeigt der Sensor immer 100% Linkqualität an. Man kann also erst dann sicher sagen, dass der Sensor funktioniert, wenn man mal einen Reichweitentest im Haus gemacht hat und sieht, wie die Linkqualität nach unten geht. Du hast das sicher gemacht, aber ich schreibe es immer wieder dazu, weil ich mich auch selbst schon reingelegt habe :)

Ein Arduino nano ist nur minimal größer und man spart sich den FTDI für's Aufspielen des Sketch. Die Checker nehmen aber natürlich den pro mini ;) Es gibt keine Ausreden, den Sensor nicht nachzubauen!
Eines hat mich verwundert:
Der Link Quality Sensor funktionierte auf Anhieb ohne Murren und Knurren.
Das ist der Standard, wenn du meine Vorschläge nachbaust ;)
Meistens jedenfalls :)
 

FPV-AH

Neuer Benutzer
#42
Hallo Alfons,

danke für den tollen Baubericht und die Super-Fotos! Leider hat der Sketch von Tadango einen kleinen Nachteil: wenn der Inverter nicht funktioniert, dann zeigt der Sensor immer 100% Linkqualität an. Man kann also erst dann sicher sagen, dass der Sensor funktioniert, wenn man mal einen Reichweitentest im Haus gemacht hat und sieht, wie die Linkqualität nach unten geht. Du hast das sicher gemacht, aber ich schreibe es immer wieder dazu, weil ich mich auch selbst schon reingelegt habe :)
*******
*******
Meistens jedenfalls :)
Danke für den Hinweis.
Den Reichweitentest im Haus habe ich gemacht. Da sieht man nicht nur die schwankende Linkqualität, auch Störungen durch WLAN und Smartphone machen sich bemerkbar.

Zwischenzeitlich habe ich noch einen zweiten Link Quality Sensor zum Spielen/Testen/Experimentieren gebaut, aber nicht eingeschrumpt, damit die Kontakte frei bleiben.
Auch der zweite Sensor funktionierte auch auf Anhieb.
Auch an meinem Multimodul wird die Link Quality einwandfrei übertragen.

Nochmals der Hinweis:
Der 2N7000 ist sehr empfindlich gegen elektrostatische Entladung.
Daher vor und beim Einbau darauf achten, daß man das Teil nicht zerstört.
 
#43
Ich würde noch einen Widerstand vom Gate nach Masse vorsehen (47k), da im nicht angeschlossenen Zustand das Gate offen liegt und der MOSFET durch statische Elektrizität zerstört werden kann.
 

FPV-AH

Neuer Benutzer
#44
Hallo Reinhard,

guter Hinweis, der zusätzliche Widerstand vom Gate nach Masse gibt zusätzliche Sicherheit.
Den werde ich beim nächsten mal einbauen.
Die größte Gefahr für eine Zerstörung durch statische Elektrizität sehe ich jedoch, wenn man den MOSFET 2N7000 in den Händen hält, biegt und verlötet.
Ist er eingebaut, verlötet und die Platine mit Schrumpfschlauch gesichert ist die Gefahr sicherlich geringer, aber nicht null.

Vorhin habe ich mal bei meiner X9D+ und einem X8R die HF Firmware auf 2.01 upgedatet.
Das Update und das anschließende Binden hat einwandfrei funktioniert.

Auch der Lost Frame Sensor konnte nach Sensorsuche problemlos eingebunden werden.
Wie erwartet (u.a. wegen neuer FrSky Lost Frame Definition im SBus Signal) zeigte der Lost Frame Sensor beim Test innerhalb des Hauses deutlich bessere Werte (meistens 100%) an.
In der Nähe des WLAN Routers oder wenn ich mit dem Smartphone ins Internet gegangen bin, rutschen die Werte unter 100%.

Noch eine Auffälligkeit:
Ich lasse mir auf dem Display die aktuellen Werte des Lost Frame Sensors als LQ anzeigen und parallel dazu den LQ- Wert, also den niedrigsten per Telemetrie übertragenen LQ Sensorwert.
Das hat bei der alten HF Firmware einwandfrei funktioniert.
Bei der neuen Mitte Januar 2020 HF Firmware auf 2.01 funktioniert es für eine begrenzte Zeit.
Dann erscheint (und bleibt im Display stehen) jedoch bei LQ- eine extrem hohe Zahl (z.B. aktuell: -268414364) statt einer Zahl zwischen 0 und 100%.
Das liegt wohl noch an dem bekannten Bug in der FrSky 2.01 Telemetrie, der ja behoben werden soll, wenn die FrSky Mitarbeiter hoffentlich gesund in der kommenden Woche die Arbeit wieder aufnehmen.

Gruß

Alfons
 
#45
Hallo Alfons, die LED verrät immer noch die Wahrheit über die Lost Frames. Das ist keine "neue Definition" das ist Besch!ss ;) Wenn FrSky das durchzieht, sind sie für ernsthafte Anwendungen zukünftig außen vor.
 

helle

Erfahrener Benutzer
#46
Dann frag halt einfach die LED ab, wen dich das so bewegt....

Tip:
Da reicht es einen Fototransistor über der LED zu fixieren, eventl sogar mit integrierem Gatter
da musste nicht mal den RX öffnen.
und schon kannst damit auf einen Zähler gehen
 
#47
So eine Lumperei unterstütze ich nicht ;) Die sollen einfach das Lost Frame Bit wieder wahrheitsgemäß setzen.
 
#48
So, ich habe auch mal einen LF-Sensor gebaut. Ich habe einen 3,3V Arduino Pro Mini benutzt. Das funktioniert auch. Man kann dann den Sensor über den RAW-Pin versorgen. Der 10k Widerstand des Inverters liegt an Vcc (3,3V). Der SPort läuft dann auch auf 3,3V. Zwischen Gate und Source des FET habe ich einen 47k SMD Widerstand gelötet.
20200205_000221.jpg

Hier ein Test im Range Modus mit X9D+ und X6R
Log1.jpg

Als nächstes will ich mal versuchen noch das Verfahren von Bionicbone zu implementieren
 
#49
Als nächstes will ich mal versuchen noch das Verfahren von Bionicbone zu implementieren
Interessantes Verfahren, ich hatte auch schon überlegt, ob ich nachfrage. Es würde ja reichen, nur einen Sägezahn auf einem Kanal zum Modell zu schicken, um mit V2 die wahren LF, in dem Fall als Hold zu sehen.
Andererseits glaube ich nicht, dass FrSky die Schummelei mit dem Lost Frame Bit durchziehen kann. Es haben nur noch nicht viele kapiert, was das bedeutet.

Wenn der erste Youtuber dahinter kommt, wachen ein paar Leute mehr auf.
 

quax2011

Erfahrener Benutzer
#50
Hallo ! Möchte hier nochmal den Hinweis auf die BS 170 geben. Die funktionieren auch und scheinen nicht so empfindlich auf Elektrostatik zu sein. Zumindest haben die bei mir alle überlebt obwohl ich die ziemlich gequält hab beim Löten.😬
 
#51
Also wenn der FET bei @quax2011 überlebt (ich habe seine erste Bauausführung gesehen), dann überlebt er auch die elektromagnetische Schockwelle einer Atombombe.

Aber im Ernst, der Widerstand hilft, aber wenn man nicht gerade im Fleece Jumpsuit über den Teppichboden gerobbt ist, sollte nichts passieren. Bei sehr trockener Luft gibt es ein Risiko, wenn das Gate noch nicht mit dem SBus verbunden ist, aber es ist überschaubar.
 
#52
Beim Löten stirbt das Teilchen meistens am Hitzetod. Wichtig ist, um dem ESD Gau zu entgehen, beide Flossen auf den Tisch, bevor ich was anfasse.
 
#54
@bionicbone wird seine Lösung mit Überwachung des Sägezahns auf einem Kanal bei GitHub einstellen. Dann gibt es auch mit der trojanischen Pferde-Firmware eine Möglichkeit, die echten LostFrames zu sehen.

So macht das Spaß ;)
 
#57
Aber im Ernst, der Widerstand hilft, aber wenn man nicht gerade im Fleece Jumpsuit über den Teppichboden gerobbt ist, sollte nichts passieren. Bei sehr trockener Luft gibt es ein Risiko, wenn das Gate noch nicht mit dem SBus verbunden ist, aber es ist überschaubar.
Der Widerstand vom Gate gegen Masse sollte auch beim Programmieren des Arduino (mit eingebautem Inverter) hilfreich sein, da der FET dann definiert abgeschaltet ist und den RX-Pin nicht stört.
 
#58
Der Widerstand vom Gate gegen Masse sollte auch beim Programmieren des Arduino (mit eingebautem Inverter) hilfreich sein, da der FET dann definiert abgeschaltet ist und den RX-Pin nicht stört.
Dann ist der Widerstand ab jetzt mein bester Freund! Muss ich mal probieren (y)
 
RCLogger

FPV1

Banggood

Banggood

Oben