OpenXsensor - Erste Schritte und Problem

Versorgung ist bei mir ebenfalls direkt über das Regler BEC vorgesehen. Beim RAW Eingang sollte man über 5,2V haben laut Datenblatt. Spannung des Arduino ist aber max. 5V. Mein BEC liefert 5,1V ist ein Anschluss des Arduino direkt über VCC möglich?
Klar, das ist die beste Variante. Diese Spannung mit dem Multimeter genau messen und als Referenzspannung eintragen.
 
Wenn die Messung bei Servobewegung jetzt schwankt, tut sie es dann auch ;-)
Es gibt ja aber noch die interne Referenz...
Korrekt, prinzipiell ist die interne Referenz sinnvoll, wenn die Betriebsspannung zu niedrig für den internen Arduino Regler (Anschluss über RAW/VIN) ist und die Betriebsspannung schwankt.

Aber wenn beim Betätigen der Servos die BEC Spannung einbricht, liegt das Problem woanders. BEC, Servos, Anlenkung, Verdrahtung, Verbindungen ......

Die Umstellung auf interne Referenz ist nicht ohne, Das bedeutet, alle Spannungsteiler müssen geändert werden und auch der ACS758 muß über Spannungsteiler angeschlossen werden. Die interne Referenz sollte auch noch "geeicht" werden. Mit der Umstellung macht man schon ein (kleines) Faß auf, ohne dass das eigentliche Problem gelöst ist.
 

Stoschek

Erfahrener Benutzer
Ja. Ein BEC, welches Servos versorgt, ist halt auch einfach keine gute Referenz für diese analoge Messungen. Es ist zum Beispiel aber möglich, habe ich so, ein linearen Spannungsregler bei dem Stromsensor unterzubringen. Den dann nur für ACS und Arduino verwenden. Mit Stromsensor ist ja schon für Fortgeschrittene, da kann man sowas vorschlagen, oder ;-)
 
Vielen Dank für eure Antworten.
Dann bleibe ich bei meiner gewählten Referenz und baue von RAW auf VCC um.
Das mit der Schwankung der Spannungswerte betrifft die zweite Nachkommastelle. Werde aber auch hier mal ein anderes BEC testen und ansonsten die Anlwnkungen überprüfen.

Grüße
Christopher
 

strgaltdel

Erfahrener Benutzer
@ Sakerfalke

Wenn du schon den oXs "Fullhouse" ausstattest, könntest du auch einen Empfängerkanal einspeisen um z.B. Vario Empfindlichkeit einzustellen bzw zwischen kompensierten / unkompensierten Vario umzuschalten.
Über bidirektionalem SPORT ist wohl auch einiges möglich, aber dazu bedarf es dann skripting..

RPM habe ich auch mal vor.
Falls du E- Antriebe messen möchtest:
Prinzipiell gibt es ja noch die Alternative über die Motorphase Drehzahl zu ermitteln.
Erspart Einbau des Hall Sensors am Spant / des Magnets am Mitnehmer.
Daran mal gedacht ?

Habe mal alte links rausgesucht, muss aber zugeben, dass ich mich noch nicht weiter damit befasst habe.


http://openrcforums.com/forum/downl...id=16b6f476653069c4c1795fec4513b13e&mode=view
http://openrcforums.com/forum/viewtopic.php?t=4334

https://www.mikrocontroller.net/attachment/142015/Schaltung_Drehzahlmessung_Motorphase.JPG
https://www.mikrocontroller.net/topic/253539

https://www.rcgroups.com/forums/showthread.php?t=1006124



Gruss
 
@ Sakerfalke

Wenn du schon den oXs "Fullhouse" ausstattest, könntest du auch einen Empfängerkanal einspeisen um z.B. Vario Empfindlichkeit einzustellen bzw zwischen kompensierten / unkompensierten Vario umzuschalten.
Über bidirektionalem SPORT ist wohl auch einiges möglich, aber dazu bedarf es dann skripting..
Moin Udo,

wir sind im Einsteiger Thread. Da finde ich den Airspeed Sensor schon grenzwertig :cool:. Sollten wir es nicht hier dabei belassen und für die Erweiterungen neue Threads aufmachen? Der Plan reicht für den Einsteiger, wenn man noch mehr reinpackt, stöhnen wieder alle.

Übrigens: für die oXs Steuerung über SPort ist schon alles, inkl. Script, im aktuellen Master enthalten. Von daher passt der Plan. Ab jetzt sollte man den oXs über SPort steuern, spart einen Draht und einen physikalischen Kanal. Das script wertet einen logischen OpenTX Kanal aus und sendet diesen über SPort.
 
Zuletzt bearbeitet:

strgaltdel

Erfahrener Benutzer
Moin Bernd,

hast' ja recht;)

Wenn schon müsste man eigentlich noch einen threat ala "OpenXsensor für Fortgeschrittene" aufmachen.

.. und dann noch einen mit den wesentlichen Inhalten pinnen
..... und dann noch ein Unterforum aufmachen :eek:

Grüsse
 
Ja. Ein BEC, welches Servos versorgt, ist halt auch einfach keine gute Referenz für diese analoge Messungen. Es ist zum Beispiel aber möglich, habe ich so, ein linearen Spannungsregler bei dem Stromsensor unterzubringen. Den dann nur für ACS und Arduino verwenden. Mit Stromsensor ist ja schon für Fortgeschrittene, da kann man sowas vorschlagen, oder ;-)
Vielleicht können wir uns darauf einigen, dass es für den Einsteiger, der ein vernünftiges BEC im Flieger hat, erstmal so ausreichend ist. Fortgeschrittene können noch optimieren, nach deiner Methode oder mit interner Referenzspannung oder mit einem ADS1115 mit 16 bit Auflösung :)

..... und dann noch ein Unterforum aufmachen :eek:
Sehr gute Idee. Organisierst du das? Lass dich gleich als Moderator freischalten. Ohne Moderator wird es nämlich gleich wieder konfus.
 

Stoschek

Erfahrener Benutzer
Ein Unterforum wäre eine schöne Sache :) + Moderation
Weitere Bauvorschläge als Einzelthemen fände ich auch gut, es wird immer so schnell unübersichtlich.

Vielleicht können wir uns darauf einigen, dass es für den Einsteiger, der ein vernünftiges BEC im Flieger hat, erstmal so ausreichend ist. Fortgeschrittene können noch optimieren
Natürlich, man sollte halt nur klar darauf hinweisen, finde ich. Kleine Ungenauigkeiten sind ja meist auch gar nicht tragisch, hast schon recht...
 

Sakerfalke

BA: Polarenvermessung
Ach ja, hier noch ein Hinweis von mstrens zum nano + GPS, das kannst du vielleicht bei deinem Bau überprüfen:

"I would recommend to use an arduino pro mini instead of a nano because with the nano it could be that there would be some conflict on the Tx/Rx pins (not sure about this)."

Die Frage ist noch offen.
Hallo Bernd,

ich habe heute das neu eingetroffene GPS Neo 6M mal angeschlossen (über Breadboard noch nicht verlötet)
Es hat sich erst überhaupt nichts getan, ich dachte schon vlt reicht die Spannung nicht...
Doch dann nach 3-5min fing plötzlich eine LED am GPS an zu blinken, ein Signal an der Taranis bekomme ich aber immer noch nicht. Fand ich sehr seltsam.

"Discover new sensors" läuft bereits seit mehreren Minuten an der Taranis
Aber vlt liegts auch daran, dass er keine Satelliten findet, weil ich zwar direkt vor dem Fenster stehe, aber halt noch drinnen bin.

Aber was seltsam ist, mein Smartphone findet hier drin schon ein GPS Signal. Sollte also eig funktionieren, oder?

Also haben du und Michel Strens evtl. Recht und Ardunio Nano + GPS funktioniert nicht?
Aber vlt mache ich auch irgendwas komplett falsch?
 
Zuletzt bearbeitet:

strgaltdel

Erfahrener Benutzer
...
Der Nano unterstützt Gps auf jeden Fall
Habe mehrer kombis so im Einsatz
evtl meinte michel dass die rx ltg beim flashen getrennt werden muss um eine zerstörung des gps vorzubeugen

Tx vom gps muss an rx vom nano
wenn das beachtet wurde kanns fast nur an der config liegen, oder doch kein empfang
.... bei erstinbetriebnahme muss ggf der almanach abgeglichen werden
lass ihn mal länger draussen liegen
 
Zuletzt bearbeitet:

bendh

Erfahrener Benutzer
Es wäre der Übersichtlichkeit sicher dienlich, wenn jeder Sensor in einem eigenen Beitrag behandelt würde und nicht so ein Durcheinander wäre.
Es kommen immer wieder neue Dinge dazu, null Übersicht.
 

Sakerfalke

BA: Polarenvermessung
Hallo strgaldel, danke für die Info, dass es auch mit dem Nano funktionieren muss.

Der GPS ist wie gesagt wie folgt verbunden, das hast du doch auch so, oder?
...
Der Nano unterstützt Gps auf jeden Fall
Habe mehrer kombis so im Einsatz
evtl meinte michel dass die rx ltg beim flashen getrennt werden muss um eine zerstörung des gps vorzubeugen

Tx vom gps muss an rx vom nano
wenn das beachtet wurde kanns fast nur an der config liegen, oder doch kein empfang
.... bei erstinbetriebnahme muss ggf der almanach abgeglichen werden
lass ihn mal länger draussen liegen
Ich werd ihn, wenns aufhört zu regnen, mal etwas rauslegen. Kann es evtl. auch sein, dass das neue GPS iwie konfiguriert werden muss oder defekt ist, obwohl die LED blinkt?
Übrigens die LED fängt immer genau nach ca 3min an zu leuchten, ist das normal, dass das so ewig dauert?
 
Also haben du und Michel Strens evtl. Recht und Ardunio Nano + GPS funktioniert nicht?
Das war nur eine schwache Vermutung, bei Udo geht es mehrfach, also kann man einen Haken dranmachen.

4 Hinweise, der erste aus einer Mail von mstrens:

-"I noticed that the data where not yet available on the Tx when the GPS led start blinking. I still had to wait about 45 sec before I got data on TX.
I would have to check but I presume that there are 2 levels of fix and I start probaby sending with the second level."
- Das M6N und das M7N waren bei mir bei Teilabdeckung des Himmels nie besonders empfängnisfreudig ;) Das M8N geht wesenlich besser, sogar im Haus
- Ich hatte mal vergessen, den ADS1115 in der config zu deaktivieren, die i2c Suche hat das GPS ebenfalls ausgeknockt, es kam nur alle Minute mal ein Datensatz durch, könnte natürlich auch passieren, wenn ein anderer i2c Teilnehmer fehlt (MS5611, 4525)
- Es gab gerade eine heftige Sonneneruption und einen Protonensturm, klingt witzig, aber das kann auch den Empfang beeinträchtigen
 

Eagle71

Neuer Benutzer
danke für deine Blitzantwort, Bernd

Gerade mal überprüft und ja, du hast Recht, am 5V Eingang kommen dann nur noch 4,17V heraus und sogar auch jetzt schon, wo ich noch nichts angeschlossen habe.

Du schreibst, "Einspeisung nach dem Arduino Regler am 5V Anschluss.
Habe ich dich richtig verstanden, dass ich dann sowohl am 5V Eingang "ein-", als auch "ausspeisen" soll, WEIL der Receiver ja sowieso 5V liefert und ich deshalb den Spannungsregler nicht brauche, wo ja nur Spannung abfällt?

edit: Bild oben angepasst
Bitte Vorsicht, wenn man direkt an den 5V ran geht. Mein ProMini macht bei RAW5,4V (vom SBEC) an Vcc4.99V.
Wenn jedoch mal was über 5,5V an Vcc kommt, beginnen die Atmegas schon mal an den Magic Smoke entweichen zu lassen.

Habe da ein Beispiel mit Happy End.
Empfänger XSR zum FW updaten per SPort an die Taranis, update alles OK.
Beim zweiten hatte ich einen QCopter über SBus noch dran, uptate external Device --> ENTER und damit Power on im Schacht.
Die 4 Motoren haben schön gebeept, Copter schön erleuchtet, flash lief schön durch!!!
Die Taranis hat den ganzen Copter versorgt mit ihren 9V. Glücklicherweise FC auch an RAW angeschlossen, da die 5V vom Power Distrpution Board (normalerweise) kommt.
Also immer das unmögliche mit zu bedenken.
 

blauerklaus

Erfahrener Benutzer
Hallo zusammen,
möchte hier von meinem weiteren Erfolg berichten, habe mein GPS M8M(wie der weiter oben abgebildet) ans Laufen bekommen, zwar etwas holprig aber dank Bernd nun doch mit Erfolg.
Hatte wohl zuerst den falschen Sketch geladen, mit dem ganz neuen geht's. Habe in Zeile 110 in der Confic basic h GPS auf Yes, ging aber trotzdem nicht, habe keinen Sensor in der Taranis gefunden, erst als ich in der Zeile 70 no baro eingestellt, dann hat er den GPS sofort gefunden(alles im Freiem). Ich habe an meinen pro mini zurzeit nur das GPS angeschlossen. Weiterhin ist mir bis jetzt aufgefallen das der GPS nach dem Anschalten nicht mehr gefunden wird, erst wenn man alle Sensoren löscht und wieder sucht, komisch? Werde weiter testen:D
Eine Frage habe ich noch, bei den Sensoren erscheint, ist wohl die Heading, nur was sagt die aus? Habe gedacht es wäre wie ein Kompass, aber wenn ich den GPS drehe, tut sich nix nur wenn ich ein paar Meter gehe ändert sich die Gradzahl, gehe zum Ausgangspunkt ist die Gradzahl eine andere wie beim Start?
Danke und Grüße
Eddy
 
Zuletzt bearbeitet:
Weiterhin ist mir bis jetzt aufgefallen das der GPS nach dem Anschalten nicht mehr gefunden wird, erst wenn man alle Sensoren löscht und wieder sucht, komisch? Werde weiter testen:D
Das ist nicht normal, entweder ein Fehler im aktuellen Master (glaube ich aber eher nicht), oder du wartest nicht lange genug auf den Fix. Wobei der beim M8N normalerweise superschnell ist. Mal sehen, was du dazu noch feststellst.

Eine Frage habe ich noch, bei den Sensoren erscheint, ist wohl die Heading, nur was sagt die aus? Habe gedacht es wäre wie ein Kompass, aber wenn ich den GPS drehe, tut sich nix nur wenn ich ein paar Meter gehe ändert sich die Gradzahl, gehe zum Ausgangspunkt ist die Gradzahl eine andere wie beim Start
Heading ist die Richtung in der sich das GPS bewegt, es wird aus dem Verlauf der Koordinaten berechnet. Im Stand ist es eine Zufallszahl, aber in Bewegung zeigt es sehr genau die Himmelsrichtung der Bewwegung an (0°=Nord). Beim Hin- und Zurückgehen sind es 180° Unterschied zwischen den beiden Headings. Wenn man das GPS im Laufen dreht, verändert sich Heading übrigens nicht, anders als beim Kompass.
 
RCLogger

FPV1

Banggood

Oben