openXsensor-Konfiguration YouTube

#21
Als HDOP wird 190 angezeigt. Was bedeutet das? Theoretisch sind wohl Werte von 0-50 möglich, je kleiner desto besser.
1,9 ist fast perfekt. Das Temp-Feld hat nach Definition keine Nachkommastellen, ein Komma wird in der Telemetrie grundsätzlich nicht übertragen. Entweder DOP im ACC Feld übertragen, das hat laut Definition zwei Nachkommastellen, oder, wie Stoschek vorschlägt, einfach im Telemetrietab auf 2 Nachkommastellen ändern. Dort kann man auch gleich den/die Sensornamen ändern. Für Sat passt das Temp-Feld.
 
#22
Hallo Bernd (Carbonator),

dank deiner Hilfe und deinen Videos bin ich jetzt voll angefixt von dem Openxsensor Thema.
Vielen Dank nochmal und ich kann allen nur empfehlen das mal auszuprobieren.

Mach weiter so.

Gruß Michael
 

fa223

Erfahrener Benutzer
#23
Hallo Bernd,

vielen Dank für die Videos!
Schade dass ich schon über die ersten Grundlagen hinaus bin, die Videos hätten sicher einiges vereinfacht.
Es wäre ganz toll, wenn du auch für Fortgeschrittene weitere Videos machen würdest.

Ich bin zwar kein Buchhalter, aber dennoch würde mich die Einzelzellenüberwachung interessieren. Muss man sich da auf die Zellenzahl (softwaretechnisch) festlegen oder geht das so wie bei anderen Lipo-Sensoren auch, dass das automatisch erkannt wird?

Grüße,
Klaus
 

quax2011

Erfahrener Benutzer
#24
Hi Klaus, ich bin zwar nicht der Bernd, versuche aber trotzdem mal deine Frage nach bestem Wissen zu beantworten. Ich habe schon einige Sensoren mit Strommessung und Einzelzellenmessung gebaut. Du musst - dazu je nachdem wieviele Zellen du messen willst - erst mal Spannungsteiler aufbauen damit an den Arduino-Eingängen nicht mehr als Max. 5V ankommen. Bei der ersten Lipozelle ist das einfach, da braucht man nix, da kommen eh nur 4,2 V an. Bei der zweiten Zelle muss es ein 1:1 Teiler sein zB. 10KOhm : 10KOhm, dann 1:2 usf. Ich gab gelernt dass mehr als 4EZ keinen Sinn machen weil die Genauigkeit mit der Zeilenanzahl abnimmt. Warum, das sollen/müssen die Spezialisten erklären, dazu bin ich nicht firm genug (hängt mit den Bit?? zusammen, frag mich nicht). Die Spannungsteiler und die max. Zellenzahl musst Du in der Konfig_h eintragen. Die Widerstände sind nur Beispiele, nur der Teiler muss stimmen und die Sollten nicht zu klein gewählt werden um die Messung nicht zu verfälschen. Ich hab mir 10, 20 und 30,1 KO SMD-Widerstände besorgt und die Teiler direkt auf einem kleinen Stück Lochrasterplatine aufgebaut mit dem Stecker für den Balancer dran. Hoffe das hilft dir weiter. Falls ich was falsch beschrieben gab. Bitte Korrektur von den Spezialisten.

Gruß Jürgen
 

fa223

Erfahrener Benutzer
#25
Hallo Jürgen,

danke für deine Antwort.
Die Sache mit den Spannungsteilern ist soweit (theoretisch) klar.
Den Aufbau hatte ich mir so in etwa vorgestellt, wie du geschrieben hast. Mal schauen, ob es bei mir auch funktioniert.
Die Frage, die mich aber immer wieder beschäftigt ist, wenn ich mir Anschlussmöglichkeiten für z. B. 4 Zellen schaffe, aber auch mal einen 3-Zeller anschließe, funktioniert dann die Auswertung noch?
Z. B. beim FrSky LiPo-Sensor kann man bis zu einem 6-Zeller anschließen. Egal, ob nun ein Einzeller dran ist oder eben ein 6-Zeller, die Auswertung (Zellen-Spannung, Gesamtspannung, Zellen-Max, Zellen-Min) funktioniert immer.
Ich könnte mir vorstellen, dass die Auswertung der Einzelzellenspannung auch beim oXs noch funktioniert, auch wenn eine Zelle weniger dran ist?? Aber wie sieht es mit mit Zellen-Min-Spannung aus?

Grüße,
Klaus
 

quax2011

Erfahrener Benutzer
#26
Hi Klaus, das sollte m.M nach eigentlich funktionieren. Du musst ja im Telemetrimenu der Horus die EZ- Anzeige als "neuen Sensor" per Berechnung selbst erzeugen. Aber ehrlicherweise muss ich sagen, habs noch nicht versucht und bin nicht sicher ob das an der gemessen Gesamtspannung des Akku die ja als Basis der Berechnung dient ( stimmt das so ????) scheitert ?

Gru Jürgen
 

fa223

Erfahrener Benutzer
#27
Hallo Jürgen,

da bin ich mir auch nicht sicher, weil bei einer Einzelzellenüberwachung eigentlich die Gesamtspannung nicht gemessen wird. Es wird nur jeweils auf beiden Seiten der Einzelzellen abgegriffen.
Zwar ist ja dann die letzte Zelle auf dem Spannungsniveau der Gesamtspannung, aber über die Spannungsteiler eben wieder auf ein Maß < 5 V reduziert.
Dein Einwand mit der Berechnung im Sender ist berechtigt. Es werden - glaube ich - nur die aktuellen Spannungswerte übertragen, den Rest macht der Sender (in meinem Fall X9D+, aber das Prinzip ist identisch).
Es bleibt halt die Grundfrage, ob ich in der oXs-Firmware z. B. eine Einstellung für 4 Zellen machen kann, auch wenn ich im Modell nur 3 Zellen anschließe.

Grüße,
Klaus
 
#28
Es bleibt halt die Grundfrage, ob ich in der oXs-Firmware z. B. eine Einstellung für 4 Zellen machen kann, auch wenn ich im Modell nur 3 Zellen anschließe.
Der 4. Eingang ist dann über den Spannungsteiler auf 0V und meldet dann auch Zelle 4 mit 0V. Die eigentliche Frage ist: kann ich OpenTX so konfigurieren, dass ich 3s nutzen kann, ohne Fehlermeldungen zu bekommen.
 

fa223

Erfahrener Benutzer
#29
Der 4. Eingang ist dann über den Spannungsteiler auf 0V und meldet dann auch Zelle 4 mit 0V. Die eigentliche Frage ist: kann ich OpenTX so konfigurieren, dass ich 3s nutzen kann, ohne Fehlermeldungen zu bekommen.
Ui, da gehts schon wieder los - ich verstehe deine Fragestellung nicht. :eek:
Wenn oXs einfach 0V meldet und keine andersgearteten Fehler ausgibt, dann könnte man den Sensor (vermutlich?) problemlos nutzen, wenn man im TX nur 3 Zellen definiert hat.
Hat man 4 definiert, müssten ja (nach meinem Verständnis) auch die 4 Werte angezeigt werden; nur Zellen-Min liefert dann 0V?
Oder habe ich da ein grundsätzliches Verständnisproblem?

Grüße,
Klaus
 

quax2011

Erfahrener Benutzer
#31
Will sagen: Wenn ich die Sensorsuche starte werden ja erstmal keine EZ angezeigt. Die muss ich ja im Telemetrimenu erst "erzeugen" .Ob das dann mit 3 Zellen korrekt angezeigt wird wenn im Arduino 4 eingestellt sind... Kein Ahnung.
 
#32
Das muss man einfach mal ausprobieren. Die letzte Zelle nicht anschließen und schauen, ob OpenTX damit umgehen kann. Da ich keine EZ-Messung mache, habe ich es noch nie getestet ....
 

quax2011

Erfahrener Benutzer
#35
Ich hab möglicherweise noch einen Sensor für 3S. Werd den mal testen mit 2S und dann berichten. Aber nicht hier sondern unter OpenxSensor Erste Schritte...
Hier passt das nicht weil ich den schönen Videothreat von Bernd nicht weiter missbrauchen will. ;-)

Jürgen
 
RCLogger

FPV1

Banggood

Oben