Aq6 +dimu + CAN

Hi,

lt. Norbert gibt es 2 Lötpads (grün umrandet) auf dem DIMU. Hab das rechte Blockschaltbild im engl. Forum gefunden. Hält man das DIMU daneben, dann könnten die oberen Pads der Anschluß für CAN_L(-) und die Unteren für CAN_H(+) sein.

Nachdem auf der DIMU bereits 120Ohm sein sollen, wird der hier eingezeichnete Abschlußwiderstand wohl derjenige auf dem letzten ESC32 sein

CAN-Verbdg_DIMU--ESC.jpg

Gruß Egb.
 

solution

Erfahrener Benutzer
Hallo zusammen
Nach dem Umbau des AQ6 auf DIMU und Tests auf einem Test-Quadro, die recht gut verlaufen sind, habe ich nun den AQ6 auf einen Hexa montiert, hott_dimu_R397 geladen und heute etwa 10 Akkuladungen geflogen.
Die Hott-Geschichte funktioniert sehr gut, anderweitig gab es aber Probleme:

Problem 1:
Etwa 2-3 mal konnte ich den Kopter nicht armen/Motoren starten, obwohl die Hott-Telemtrie "armed" angezeigt hat.
Das Problem läßt sich nur mit einem Akku-Reset beheben.
(Das gleiche Problem hat wohl jemand bereits im engl. Forum beschrieben, allerdings mit einer AIMU)

Problem 2:
Beim langsamen Bewegen in PH/AH über die Sender-Sticks (Nick/Roll) ist alles in Ordnung.(kleine Knüppelausschläge, leichte Neigung des Kopters)
Jedoch mit größerem Knüppelausschlag, entsprechend stärkerer Neigung des Kopters, pendelt dieser völlig über, wenn man den Knüppelausschlag zurück nimmt und der Kopter von (glaube heisst hier DVU-Mode) wieder in PH/AH geht.
Dieses ist derart kritisch, dass man man glaubt der Kopter schwingt sich völlig über die entsprechende Achse auf und stürzt ab.

Peter (sandmen) hatte mir an anderer Stelle im Forum den Tip gegeben, Nav_Speed_Rate P von 10,5 auf 7, Nav_Speed_Rate I um die Hälfte zu reduzieren.
Das alles hat nicht wirklich was gebracht. (Testweise P bis 5 runter, I zwischen 0.001-0.01)
Das Problem tritt ebenfalls auf, wenn man über WP-Flug oder RtH über einen längere (mehr als 2-5m) Strecke navigiert, dann neigt sich der Kopter stärker und das heftige Überschwingen tritt auch dort auf.

Wer weiß Rat?
Gruß
Joachim
 

sandmen

Erfahrener Benutzer
Hallo zusammen
Nach dem Umbau des AQ6 auf DIMU und Tests auf einem Test-Quadro, die recht gut verlaufen sind, habe ich nun den AQ6 auf einen Hexa montiert, hott_dimu_R397 geladen und heute etwa 10 Akkuladungen geflogen.
Die Hott-Geschichte funktioniert sehr gut, anderweitig gab es aber Probleme:

Problem 1:
Etwa 2-3 mal konnte ich den Kopter nicht armen/Motoren starten, obwohl die Hott-Telemtrie "armed" angezeigt hat.
Das Problem läßt sich nur mit einem Akku-Reset beheben.
(Das gleiche Problem hat wohl jemand bereits im engl. Forum beschrieben, allerdings mit einer AIMU)

Problem 2:
Beim langsamen Bewegen in PH/AH über die Sender-Sticks (Nick/Roll) ist alles in Ordnung.(kleine Knüppelausschläge, leichte Neigung des Kopters)
Jedoch mit größerem Knüppelausschlag, entsprechend stärkerer Neigung des Kopters, pendelt dieser völlig über, wenn man den Knüppelausschlag zurück nimmt und der Kopter von (glaube heisst hier DVU-Mode) wieder in PH/AH geht.
Dieses ist derart kritisch, dass man man glaubt der Kopter schwingt sich völlig über die entsprechende Achse auf und stürzt ab.

Peter (sandmen) hatte mir an anderer Stelle im Forum den Tip gegeben, Nav_Speed_Rate P von 10,5 auf 7, Nav_Speed_Rate I um die Hälfte zu reduzieren.
Das alles hat nicht wirklich was gebracht. (Testweise P bis 5 runter, I zwischen 0.001-0.01)
Das Problem tritt ebenfalls auf, wenn man über WP-Flug oder RtH über einen längere (mehr als 2-5m) Strecke navigiert, dann neigt sich der Kopter stärker und das heftige Überschwingen tritt auch dort auf.

Wer weiß Rat?
Gruß
Joachim
Zu Problem 1,
wenn er sich nicht armen lässt, hat das Board dann gebootet?
Wenn ja, Schalterstellung?
Bei nein, deutet das auf Initialisierungsfehler der Sensorik hin.

Zu Problem 2,
NAV_MAX_SPEED mal auf 3m/sec runter drehen.
Zudem wäre dann mit beiden Einstellungen ein Log nicht schlecht.
 

solution

Erfahrener Benutzer
Zu Problem 2,
NAV_MAX_SPEED mal auf 3m/sec runter drehen.
Zudem wäre dann mit beiden Einstellungen ein Log nicht schlecht.
Habe mal den Test mit NAV_MAX_SPEED auf 3m/s gemacht.
Damit gibt es (neben NAV_Speed_Rate_P auf 7 und NAV_Speed_Rate_I auf 0.006) keine Aufschaukelprobleme mehr, allerdings ist das auch ein bissl Schneckentempo!
Kommt er so gegen den Wind an????????????

Warum ist das aufschaukeln bei Pitch stärker als bei Roll????
 

sandmen

Erfahrener Benutzer
Habe mal den Test mit NAV_MAX_SPEED auf 3m/s gemacht.
Damit gibt es (neben NAV_Speed_Rate_P auf 7 und NAV_Speed_Rate_I auf 0.006) keine Aufschaukelprobleme mehr, allerdings ist das auch ein bissl Schneckentempo!
Kommt er so gegen den Wind an????????????

Warum ist das aufschaukeln bei Pitch stärker als bei Roll????
NAV_MAX_SPEED = maximale Geschwindigkeit, bei Navigation oder DVH. Diese wird natürlich immer Versucht zu erreichen.
Wenn mächtig Gegenwind da ist, wird dieses natürlich auch Versucht.
Dafür ist ja der "NAV-Regler" da. Sicherlich, wenn das System (Copter) die Leistung nicht hergibt, wird er das nicht erreichen.

Warum Pitch und Roll unterschiedlich ist, kann verschiedene Faktoren haben. Auch die Massenverteilung am Copter kann hier mit einspielen.
Grundsätzlich ist das nicht anders behandelt.

Ach, kontrolliere doch mal deine "?-Taste" :)
 

Snoopy

Neuer Benutzer
Hallo Tilman,

welcher Kanal wird denn zum Dimmen der LED verwendet? Im AQ-Forum habe ich gelesen, daß Kanal 8 vorgesehen ist. Bei meiner Futaba-Funke tut sich da aber nichts.

Grüße,
Stefan
 
RCLogger

FPV1

Banggood

Banggood

Oben