CRIUS AIOP 2.0 und MPNG for the beginner

#61
Wenn man eins ohne Log hat, ist man etwas Dümmlich drann. Dann hilft nur Servomonitor an der Fernsteuerung beobachten, bei welchem Wert er Schwebt, und solange den Wert verändern im MissionPlanner verschieben bis man bei Knüppelmitte angekommen ist. Genau muss der Parameter nicht unbedingt sein, aber wenigstens in etwa.
 
#63
Es bringt einem das was ich in der Einleitung der Anleitung geschrieben hab.;)

Es ist doch wie immer, wenn etwas TOP Funktioniert sollte man die Finger davon lassen, wenn der Wurm drinn ist hilft nicht immer ein Apfel weiter, dann evtl. diese Zusatzanleitung.
 

hulk

PrinceCharming
#65
Wenn failsafe auf rtl steht und das gps ist weg, sieht es schlecht aus.
Ich hatte mit dem gps stecker schwerste Probleme. Ich habe dann den Stecker ausgelotet und die 4 Kabel vom GPS direkt aufgelötet. Seit dem ist Ruhe. Ich denke, es liegt an schlechten Crimpungen.mfg
 

DF9CY

Tiefstflieger
#66
Diese Picoblade Kontakte taugen nichts. Sollte icheigentlich wissen, denn in der Elektronikentwicklung waren sie mir untersagt, sie einzusetzen. Wird jetzt auf jeden Fall angelötet.
 
#67
Seit dem mir am Anfang meiner Modellflugbahn ein Heli runter gekommen ist wegen Stecker ab. Mache ich immer ein Klecks Heißkleber auf die Stecker. Somit kann er wenigstens nicht raus.

Und an meinem Nitro Heli sowieso, wenn der auf die Ohren bekommt und im 3D rumzappelt kann ich keine abfallenden Stecker gebrauchen.
 

DF9CY

Tiefstflieger
#68
Hab versucht, die Logs zu laden. Bis auf irgendwelche "Hyroglyphen" nichts drin. Scheint ja wohl ein Glitch im Prozessor oder so gewesen zu sein.

In meiner APM_Config.h steht:

// uncomment the lines below to save on flash space if compiling for the APM using Arduino IDE. Top items save the most flash space
//#define CLI_ENABLED DISABLED // disable the CLI (command-line-interface) to save 21K of flash space
#define LOGGING_ENABLED ENABLED // disable dataflash logging to save 11K of flash space
#define GPS_PROTOCOL GPS_PROTOCOL_UBLOX // hard code GPS to Ublox to save 8k of flash
//#define GPS_PROTOCOL GPS_PROTOCOL_MTK19 // hard cdoe GPS to Mediatek to save 10k of flash
#define MOUNT DISABLED // disable the camera gimbal to save 8K of flash space
//#define AUTOTUNE DISABLED // disable the auto tune functionality to save 7k of flash
#define OPTFLOW DISABLED // disable optical flow sensor to save 5K of flash space
//#define AC_FENCE DISABLED // disable fence to save 2k of flash
#define CAMERA DISABLED // disable camera trigger to save 1k of flash
#define COPTER_LEDS DISABLED // disable external navigation leds to save 1k of flash
#define CONFIG_SONAR DISABLED // disable sonar to save 1k of flash

#define CONFIG_BARO AP_BARO_MS5611_I2C


Steuerung, GPS und RX liegen jetzt hier auf dem Tisch. Solange ich nicht in etwa weiß, was da passiert sein könnte, kommt das Board nicht wieder hinein.



---

Dem Video nach hat der freie Fall gestern 10,2 sec gedauert. War wohl ganz schön hoch :-(
 
Zuletzt bearbeitet:

DF9CY

Tiefstflieger
#70
Hab mich noch mal mit den Einstellungen beschäftigt.

Hier noch ein paar Daten zur Performance:

So wie die Steuerung auf dem Tisch liegt sehe ich für (CPU) Load folgendes:

#AKTION: Log-Ein Log-Aus

Disarmed: 63% 63%
Armed: 66% 77% (Stick unten = Throttle down)
Stabilize: 79% 77% (bei Throttle 50%)
RTL: 88% 84%
Loiter: 88% 85%
AltHold: 84% 82%
WayPoint: 84% 80%


(Bei den Einstellungen weiter oben angegeben)

Bei Throttle down: Auto_Disarm nach 15 sec (was mir wahrscheinlich den Copter gerettet hat, denn das hat Vorrang vor allem aus Sicherheitsgünden)

Trim_Throttle (in der Parameter List = CTUN??) = 383

Würde mich interessieren, was Ihr für Werte habt und ob das im Rahmen ist. Fast 90% finde ich schon "derbe" hoch ...
 
Zuletzt bearbeitet:
#71
Deshalb ist ist die 3.1b ja auch Beta. Ich hab um die 60% CPU Last, aber auch wirklich alles unnötige abgeschaltet was die ConfigH. so hergegeben hat. z.B. Autotune gemacht, werte gespeichert, abgeschaltet.

Die Hohe CPU Last war mit ein Grund warum ich bei meinem FullDresser Hexa auf die Ardupilot gegangen bin. Durch den Co. Prozessor hats die wesentlich einfacher. Die APM liegt mit OSD,Telemetrie bei Mission Alleinflug bei 70%. Mit der Crius ist mein Hexa irgendwo hin, aber nicht da wo er soll. War ne Halle im Weg. Deswegen musst ich einen neuen Kaufen, zum Glück war "nur" der Rahmen hinüber.

Haste mal ein Test gemacht wenn der Empfänger per Einzelverkabelung angeschlossen ist ? Wenn er das Summensignal nicht dekodieren muss könnt ich mir vorstellen das die CPU Last noch weiter runtergeht.

Das CTun haste doch selber da eingetragen.
 

FraLa

Neuer Benutzer
#72
Hi,

durch das Abschalten von z.B. Autotune wird die CPU doch nicht entlastet, es wird nur weniger Code mitgeschleppt, der aber sowieso nur bei Aktivierung durchlaufen wird.
Aktivierte Log Aufzeichnungen wird wohl mehr CPU Last verursachen, es wäre ständig was zu tun.
Ob die Einzelverkabelung weniger CPU Last verbraucht ist aber nicht klar. Das SUMO Signal ist komplexer aber nur einmal vorhanden, bei der Einzelverkabelung müssen mindestens 5 Kanäle überwacht und entschlüsselt werden.
Ein großer Unterschied machen wohl die Steuerung der ESC: 4 oder 6 Motoren ? Hier sind die Berechnungen bei 6 ESC wohl aufwändiger.

Gruß
FraLa
 
Zuletzt bearbeitet:

DF9CY

Tiefstflieger
#73
In Post #70 die Last Werte ohne Log-Schreiben dazugefügt. Es sind durchschnittlich 1 .. 3% weniger. Die Logs sind aber korrupt. Irgendwo in einem englischen Forum las ich gestern auch, dass es ein Problem noch damit gibt.

Kann nicht mal jemand diese Werte an seiner CRIUS und evtl auch an einer APM verifizieren?

Nein, TRIM_THROTTLE Wert hatte ich noch nicht eingetragen; das ist der automatisch erflogene Wert. Diesen Wert muss ich dann wohl bei THR_MID eintragen, nehme ich an. (Ich fliege mit zwei unterschiedlichen Akkus [3s2400 und 3s3800] die sind 95gr unterschiedlich im Gewicht. Also beide Werte erfliegen und irgendwo dazwischen stellen.)

Jetzt habe ich das Verhalten nachvollziehen können, wenn man mitten im Betrieb das GPS Modul abzieht. Die Last steigt für wenige Sekunden auf über 97% und im Logfile gibt es dann eine Fehlermeldung nach der nächsten. Da ich das GPS hardcoded geschaltet habe, kann das System mit Sicherheit nicht reagieren. Möglicherweise blockiert es dann irgendwann die Steuerung. Sieht jedenfalls so aus. Bleibt nur noch das Disarmen, denn das scheint so implementiert zu sein, dass es Vorrang hat. Das heißt dann auch, das Teil fällt runter wie ein Stein --> Aber er fliegt nicht weg. Andere Failsafe Prozeduren würden niemals greifen. Also kein RTL und so. Die Idee, den Stecker anzukleben oder die Kabel gleich anzulöten, ist gar nicht so verkehrt.
 
Zuletzt bearbeitet:

DF9CY

Tiefstflieger
#74
Zuletzt bearbeitet:

DF9CY

Tiefstflieger
#75
Gestern und heute war ich draußen, weil es auch mal nicht so ganz windig war und auch schien die Sonne mal ... Insgesamt 12 Akkus leergeflogen und etliches an Einstellungen ausprobiert.

* Throttle_Mid habe ich jetzt nach den CTUNE/ThrOut Wert auf 560 gestellt (550 mit 3s2400 Lipo (Ges.Gewicht 1020gr) und 570 mit 3s3800 Lipo (Ges.Gew 1105gr)). Hat also noch Reserve. Schwerer wird er auch nicht mehr.

* Das ständige Regeln macht er nur im AltHold und im Loiter so stark (sie im Bild). Ich weiß nicht, wo ich noch dran drehen soll. Wenn es noch mal windstill ist, mache ich noch mal Autotune. Ich habe mal die ausgewuchteten Graupner e-Props probiert, aber die Regelei hat sich nicht geändert.

CRIUS_CTUNE_ThrOut.jpg
Im Loiter Mode siegt man gut das Gezappel zwischen Werten von 500 .. 600.

Im Stabilize Mode zappelt es auch etwas, aber man muss schon genau hinsehen

Vorhin konnte ich nicht mehr "armen". Erst nach erneutem Flashen der Firmware und der MPNG 3.1 ging es wieder.

CRIUS_cpe_Einstellungen.jpg
Das sind meine Einstellungen - also nahezu Original.

mmmh, wo kann ich denn noch dran "drehen"??

Gruß Christoph
 
#76
So ich hab jetzt auch gemessen.

Disarmed Load 59
Armed Load 76 Stabilized
Althold 85
Drift 80

Alles was mit GPS zu tun hat kann ich hier im Keller nicht Testen


Irgendwo stand Throttle Rate P runterdrehen bei zu Nervösen Auftouren, habs aber selber noch nicht getestet.
 
Zuletzt bearbeitet:

DF9CY

Tiefstflieger
#77
Heute war ich wieder mal draußen. Zu windig zum Autotune, aber zum Herumfliegen OK.
Dabei bin ich ziemlich herumgeheizt und wenn man sich das Video ansieht, wird einem schwindelig.
Nach 12 Minuten plötzlich - der Quad war in dem Moment nur knapp 10m entfernt und nur drei Meter hoch - ging er plötzlich nach unten und landete leicht unsanft im "Modder". Die Motoren liefen weiter und konnten nur durch "Disarmen" zum Anhalten gebracht werden. Sender ausgestellt und die Motoren gingen wieder an, und das, obwohl in diesem Falle die Motoren ausgehen sollten.

Einstellungen:

FS_GCS_ENABLE 0 = Disable
FS_GPS_ENABLE 3 = Always Land, even from stabilize (werde ich auf 1 = Land stellen)
FS_THR_ENABLE 0 = Disable

Jetzt habe ich mir das Logfile angesehen und sehe jede Menge GPS ERROR (0 und 2, einmal 1). Was haben diese Fehler zu bedeuten?

Ich denke mal, ich muss den GPS Empfänger doch ein ganzes Stück von der Elektronik abrücken. Beim ersten Flug war die Mobius Cam ausgeschaltet, beim zweiten Flug war sie an. Der erste Flug hat auch eine Menge GPS Fehler, aber der zweite Flug wesentlich mehr.

Noch mal zu fliegen, habe ich mich dann doch eher nicht getraut.

Was habt Ihr für Failsafe - Einstellungen; was kann ich besser machen?
 
#78
Nach Disarm, wirklich die Motoren wieder angegangen ???

Ich hab Throttle_Failsave bei pwm 950 RTL und zusätzlich Kanal8 auf dem RTL ist, so gesettet das der bei Failsave auf RTL Stellung geht. Ziel ist, komm heim egal wie. Sollte Throttle nicht greifen warum auch immer, wird er per Kanal 8 umgeschaltet.

Funktioniert beides nicht, ist nach 10 min. der Spuk ehh vorbei weil Akku leer. Nur wo er dann ist ? Hoffentlich geht dann das FPV so weit das man sieht wo er runterkommt.
 

hulk

PrinceCharming
#79
Was ist fs_gcs und fs_gps und das andere?
Unabhängig davon ist bekann, dass die mobius das gps praktisch zum erliegen bringt.
Das mit dem motoranlauf nehm ich dir nicht ganz ab;)
Wieso loggen eure crius ? Ich kriegs zum verrecken nicht hin.meins ist von rctimer.
 

DF9CY

Tiefstflieger
#80
Ja, richtig, keine Reaktion auf nichts mehr. Sender aus - Motoren kurz aus und sprangen sofort wieder an. Hab mich tierisch erschrocken. Sender wieder an und sofort nach Binden auf Disarm. Dann blieben sie aus. Laut Einstellungen sollen aber die Motoren ausgehen, wenn Sender aus.

Hab jetzt die ganze Zeit herumprobiert mit dem GPS. Es ist alles OK und ohne Fehler, solange die MobiusCam aus ist. Auch wenn sie weit weg ist, gibt es Probleme. Also erst einmal ohne Cam fliegen.
 
RCLogger

FPV1

Banggood

Banggood

Oben