Jetboot fährt Schlangenlinien mit APM

Larz

Erfahrener Benutzer
#1
Moin!

Ich denke, es ist nur eine kleine Einstellungssache, aber wollte vorher doch mal hier fragen:

Ich verbinde mein Jetboot über 3DR (433MHz) mit meinem Smartphone und lege eine Route fest, die ich dann zum Boot sende. Im AUTOmode fährt das Boot auch zu den Wegpunkten, macht einen HOLD und fährt dann zum nächsten WP usw.

Nur leider fährt es in lustigen Schlangenlinien, auch wenn das Ziel geradeaus vor dem Bug liegt. Entfernung zwischen den WP´s waren so 20 - 30m.

Kann mir bidde jemand verraten, wo ich im MissionPlanner die Einstellungen anpassen muss? Ich denke mal, der Lenkausschlag ist einfach zu heftig, oder?..
 

-ghost-

Erfahrener Benutzer
#2
Hallo,

nein, ist vermutlich viel trivialer ...

Hast du in der Funke den Steuer-Kanal vielleicht invertiert, damit die Richtung stimmt?
Falls ja, dort wieder auf normal stellen und den Kanal im APM invertieren; das geht auf der Seite, wo die Sticks eingelernt werden.


-ghost-
 

Larz

Erfahrener Benutzer
#4
Ähm Ghost, das Ruder war tatsächlich im Reverse mode. Aber nach dem Umstellen in der Funke und dem kalibrieren im MP (Häkchen bei Umkehren gesetzt), lenkt es trotzdem so wie der Befehl der Funke kommt. Also nix mit reverse, wenn ich über die Funke steuere...
 

DerCamperHB

Erfahrener Benutzer
#5
Das ist auch in Ordnung so
Es geht darum, das die Ruderwirkung zu der Beabsichtigten Ruderwirkung der APM passen muss, sprich wenn die nach Links abdrehen will, muss auch das Bott nach Links drehen, und nicht nach Rechts

Hatten wir im Futterboot auch, da war nur etwas mehr zu schrauben und Löten nötig gewesen, um alle Fehler auszumerzen
 

Larz

Erfahrener Benutzer
#7
War gerade nochmal testen. JEtzt macht das Boot den "Irren Ivan"! Fährt jetz immernoch in Schlangenlinien aber nicht mal mehr in Richtung WP. Gibt es noch Vorschläge?

Werde jetzt den Compass nochmal calibirieren und diverse Funktionen entsprechend auf manuell stellen (es gab hier irgendwo n Thread, wo bestimmte Einstellungen empfohlen werden).
 

helmi53

Erfahrener Benutzer
#8
Die gleichen Probleme hatte ich bei einem RC-Auto, habs nach langen wochen dann entnervt aufgegeben.
 

Larz

Erfahrener Benutzer
#10
DSC_0045.jpg Nachdem ich mich nochmal etwas mit den Parametern befasst habe, fährt das Boot nun wie es soll. Schnurstracks geradeaus zum gesetzten Wegpunkt - wunderbar!

Die Problemlösung ist wie folgt:

1. Schaut, welchen Kurvenradius das Boot im harten Anschlag des Steuerknüppels macht. Man kann es naturgemäß´auf dem Wasser nicht penibel genau feststellen, aber ein grober Schätzwert hat bei mir schon gereicht.

Dann stellt ihr in der advanced parameter list den Wert STEER2SRV_P entsprechend ein (Angaben in meter, z.B. 3,5)

2. Nehmt euch den Wert CRUISE_THROTTLE vor. Hier gebt ihr die Autopilotgeschwindigkeit in Prozent des max. Schubs an. Bei mir habe ich den Wert auf 80 gestellt. Dieser Wert ist meiner Meinung nach aber nicht so kritisch.

3. Nehmt euch nun den Wert NAVL1_PERIOD vor. Dieser Wert befiehlt dem APM wie aggressiv es Kurskorrekturen vornehmen soll. Dieser Wert ist sehr entscheidend!. Der Standardwert steht glaube ich bei 6, was wahrscheinlich bei Landfahrzeugen auch ok ist. Jedoch reagiert ein Boot nun mal träger. Setzt den Wert allmählich höher, navigiert zwischendurch immer zu einem gestzten Wegpunkt zur Kontrolle. Bei mir gab es schließlich beim Wert 20 keine Schlangenlinien mehr.

4. Der Wert CRUISE_SPEED ist sozusagen die anvisierte Zielgeschwindigkeit im AUTO Modus. Er wird in m/s angegeben. 1 m/s entspricht dabei 3,6 km/h. Schaut im Flight Plan, wie schnell euer Boot tatsächlich ist und passt dann den Wert im Feld CRUISE_SPEED an.


Wenn ihr noch ein paar Infos zu den Einstellungen braucht, schaut auf rover.ardupilot.com vorbei.

Wie gesagt. Bei mir war schließlich der Wert NAVL1_PERIOD ausschlaggebend, das gibt dem APM scheinbar etwas mehr Zeit um zwischen den Lenkeinstellungen und der in der Folge veränderten Position des Bootes zu vergleichen. Viel Erfolg beim Einstellen!
 
Zuletzt bearbeitet:

Larz

Erfahrener Benutzer
#11
Anhang anzeigen 114894

Nachdem ich mich nochmal etwas mit den Parametern befasst habe, fährt das Boot nun wie es soll. Schnurstracks geradeaus zum gesetzten Wegpunkt - wunderbar!

Die Problemlösung ist wie folgt:

1. Schaut, welchen Kurvenradius das Boot im harten Anschlag des Steuerknüppels macht. Man kann es naturgemäß´auf dem Wasser nicht penibel genau feststellen, aber ein grober Schätzwert hat bei mir schon gereicht.

Dann stellt ihr in der advanced parameter list den Wert STEER2SRV_P entsprechend ein (Angaben in meter, z.B. 3,5)

2. Nehmt euch den Wert CRUISE_THROTTLE vor. Hier gebt ihr die Autopilotgeschwindigkeit in Prozent des max. Schubs an. Bei mir habe ich den Wert auf 80 gestellt. Dieser Wert ist meiner Meinung nach aber nicht so kritisch.

3. Nehmt euch nun den Wert NAVL1_PERIOD vor. Dieser Wert befiehlt dem APM wie aggressiv es Kurskorrekturen vornehmen soll. Dieser Wert ist sehr entscheidend! Der Standardwert steht glaube ich bei 6, was wahrscheinlich bei Landfahrzeugen auch ok ist. Jedoch reagiert ein Boot nun mal träger. Setzt den Wert allmählich höher, navigiert zwischendurch immer zu einem gesetzten Wegpunkt zur Kontrolle. Bei mir gab es schließlich beim Wert 20 keine Schlangenlinien mehr.

4. Der Wert CRUISE_SPEED ist sozusagen die anvisierte Zielgeschwindigkeit im AUTO Modus. Er wird in m/s angegeben. 1 m/s entspricht dabei 3,6 km/h. Schaut im Flight Plan, wie schnell euer Boot tatsächlich ist und passt dann den Wert im Feld CRUISE_SPEED an.


Wenn ihr noch ein paar Infos zu den Einstellungen braucht, schaut auf rover.ardupilot.com vorbei.

Wie gesagt. Bei mir war schließlich der Wert NAVL1_PERIOD ausschlaggebend, das gibt dem APM scheinbar etwas mehr Zeit um zwischen den Lenkeinstellungen und der in der Folge veränderten Position des Bootes zu vergleichen. Viel Erfolg beim Einstellen!
 
Erhaltene "Gefällt mir": helmi53

Janis

Neuer Benutzer
#16
Aus was hast du das Boot denn gebaut? MDF? Glasfaser?
Sieht ja ziemlich fancy aus... dafür, dass es "nur" Karpfen füttern soll ;)
 

Larz

Erfahrener Benutzer
#19
Hier nochmal ein paar Pics vom Vorgänger (war sozusagen das Versuchsboot zu dem jetzigen). Es ist etwas kleiner und ohne APM:

DSC_0053.jpg

DSC_0055.jpg

DSC_0056.jpg

DSC_0057.JPG
 
RCLogger

FPV1

Banggood

Banggood

Oben