Jumper T16 mit X9lite RF Modul

#21
Es gibt ja nur die gebrückten 5V Pins und Vmain für das externe Modul. Ich habe aber nochmal gemessen. Das interne Modul wird stromlos, wenn ich auf Off schalte.

Ich hab mal im OpenTX Chat nachgefragt, bist du dort angemeldet? Die Devs sind sich noch nicht so richtig einig. Es scheint "flash internal module" gestartet zu werden, wenn ein frk-File ausgewählt wird. Und das Flashen erfolgt nicht über den SPort. Vielleicht kommt noch etwas. Zur Not baue ich das Modul zum Flashen aus. Zur Zeit gibt es eh noch keine neue Firmware. Und wenn es mit FrSky so weiter geht, ist man vielleicht froh, ein MPM in Reserve zu haben :D
 
#23
Aber du hast die auswahl flash internal modul wenn du auf das file klickst oder? Nicht das ich was falsch kompiliert habe.
Ja klar, das passt alles. Kilrah hat gerade nochmal betont, dass alle Pins angeschlossen sein müssen und dass es eigentlich gehen sollte. Da bin ich wieder bei meinem Pin 3, der noch nicht angeschlossen ist. Aber ich könnte das ISRM einbauen und mit dem Scope mal Pin3 anschauen, ob sich dort beim Flashen etwas tut.

Aber das muss ich ein paar Tage schieben, es droht mal wieder Arbeit ;)
 
#25
Hier siehst du ihn auf dem ISRM. Auf dem Kabel vom Mainboard ist es der 5.Kontakt, zwischen TX (PXX2) und
SPort.
ISRM_3.jpg
Und hier, über dem rechter Pfeil, die ähnlich aussehende Gruppe auf dem X9lite Modul, die aktuell nicht angeschlossen ist.
X9lite_pcb.jpg
 
Zuletzt bearbeitet:

loetefix

Neuer Benutzer
#26
Ich sollte mir auch so ein Modul kaufen. Dann kann ich besser testen. Gibts das in Deutschland? Hattest du telemetrie als der Empfänger gebunden war?
 

loetefix

Neuer Benutzer
#28
Hab nochmal in die software geschaut. Bei der x9lite müsste die anschlussvariante so funtionieren. Mhhhh..... Evtl. Gibts da noch was das anders gemacht werden muss. Ich schicke dir morgen nochmal ein kompilat. Welches file wolltest du flashen? Gibt es das auf der frsky seite?
 

loetefix

Neuer Benutzer
#30
Heute morgen mal schnell oszi dran gehalten. Also beim Update selbst findet nur auf tx und rx Kommunikation statt. Allerdings konnte ich nicht feststellen ob beim starten über einen anderen pin getriggert wird. Das werde ich die Tage mal testen. Muss aber erstmal hilfskabel anlöten, da ich sonst zu wenig Hände habe.
 
#31
Zu mir würde ich an der Stelle sagen: Uffbasse, mach nix kaputt bei der Aktion. Bei dir habe ich da keine Sorgen ;)
 
#33
FWIW Ich hab mal die Belegung des iXJT/ISRM Motherboards ins Reine geschrieben.

pinout.jpg

Edit: Bootcmd ergänzt
 
Zuletzt bearbeitet:

loetefix

Neuer Benutzer
#35
Also.Der Pin wird angesteuert von Port I nummer 9.Dieser ist laut OTX target definitions in der hal.h der INTMODULE_BOOTCMD_GPIO_PIN.Denke mal er lässt das Modul in den Bootloader gehen? Ich denke mal der gehört an den mittleren des 6 pin wie beim x10 modul
 

Anhänge

#36
Awesome, die Indizien sind erdrückend, ich werde versuchen, den finalen Beweis anzutreten ;) :)
 
#38
Ich hätte nicht gedacht, dass es Menschen gibt, die noch schräger unterwegs sind wie ich. Das wäre der Ober-Ober-hammer --> Authigate ausgetrickst :eek::cool:

Bloß - warum hab ich mir dann die ganze Arbeit gemacht :D
 

mastersurferde

Erfahrener Benutzer
#39
Wenn Du mal viel Lust hast, dann kannst vielleicht doch mal checken, welche Pins vom TI2510 auf dem Sendemodul für was verwendet werden. Ich hab immer noch den Gedanken einen R-XSR als ACCESS Sendemodul zu verwenden.
 
RCLogger

FPV1

Banggood

Banggood

Oben