openXsensor mit HOTT Protokoll, erste Tests

@Carbonator
Du hast, wie ich gesehen habe, diese Pullupsache im "openrcforums" gepostet. Kannst du das dort erklären/ergänzen? Der GR12L dürfte recht verbreitet sein, wäre also eine relevante Information.
Mir fehlen da etwas die Sprachkenntnisse ;-)
Moin, eigentlich hatte ich deine Universallösung empfohlen. Die hast du jetzt aber gar nicht probiert, oder verstehe ich das falsch?

Der GR12L benötigt also keinen Pullup. Es wäre aber noch gut zu wissen, ob die Universallösung auch beim GR12L funktioniert. Ich habe nix zum Testen, deswegen frage ich lieber nochmal nach.
 
Ich habe doch erfolglos einen älteren oXs getestet, der hatte diese Schaltung. Schau mal bei Strom2Hott, da steht glaube ich auch was dazu, das es nicht geht, zumindest habe ich es irgendwo gelesen. Ziege-One verwendet eine Z-Diode am 5V Arduino, ich verwende gerade die 3,3V Variante... Vielleicht mal noch bei Ziege fragen, wie das entstanden ist? Oder auch mal selbst mit Z-Diode nachbauen, ob das immer funktioniert. Wenn ich Zeit habe, schaue ich mal nach Z-Dioden, sollten da sein. Könnte aber dauern, ich bin unterwegs und komme erstmal nicht dazu.
 
Moin, eigentlich hatte ich deine Universallösung empfohlen. Die hast du jetzt aber gar nicht probiert, oder verstehe ich das falsch?

Der GR12L benötigt also keinen Pullup. Es wäre aber noch gut zu wissen, ob die Universallösung auch beim GR12L funktioniert. Ich habe nix zum Testen, deswegen frage ich lieber nochmal nach.
Ok, vergesse bitte was ich geschrieben habe. Ich hatte da etwas äh... falsch. Reden wir besser nicht drüber :rolleyes:
Die alten oXs funktionieren doch, also die mit meiner Pullupschaltung, auch am GR12L. Mit dem richtigen Widerstand hätte es bestimmt auch mit dem neuen 3,3V oXs funktioniert, das mir das nicht aufgefallen ist... :rolleyes:
Was nicht immer geht, ist die Beschaltung von Ziege-One mit der ZDiode, die funktioniert mit dem GR12 nicht, zumindest nicht mit meinen GR12 von vor 2016 gekauft.
 
Moin Moin zusammen. Ich habe mich die Tage auch am oXs versucht. Ich verwende ein GY86 Board und möchte erstmal nur das Vario zum Laufen bekommen. Ich habe alles geflasht bekommen, jedoch bekomme in der Funke keine Sensoren angezeigt. Getestet habe ich es mit einem Gr12 und einem GR12L (Sensor an pin 5 aktiviert). Ich benutze ein Arduino pro mini 5V und habe einen Spannungsteiler wie von Poettie beschrieben verbaut. Ich hoffe Ihr könnt mir sagen wo bei mir der Fehler liegt.
Wenn du deinen Arduino mit 5V betreibst, dann sind die Ausgänge - auch der zum Telemetrieport - ebenfalls mit max 5V betrieben. Wenn die Annahme mit 3,3V max für den Telemetrieport korrekt ist, dann wäre ein Spannungsteiler denke mal die sichere Wahl. Da nimmst du einfach 1,8kOhm am Pin des Arduino in Reihe mit einem 3,3kOhm und greifst dein Signal für die Telemetrie zwischen den Widerständen ab:

Arduino ----|1,8kOhm|---°----|3,3kOhm|---GND
....................................|
..........................Telemetriesignal

Aber keine Ahnung obs notwendig ist ...
 
Der High-Pegel kommt nicht vom OXS, somit benötigst du die Widerstände nicht. Messe mal am Telemetriepin des Empfängers, da müssen 3,3V heraus kommen, damit es funktioniert.
 
ok geht ohne Widerstände. Danke für die schnelle Hilfe! Jedoch gibt er das Variopiepen nur von sich wenn ich Kopfhörer drinnen habe, hast du eine Idee woran das liegt?
 
Zuletzt bearbeitet:
Aber mit dem originalen Vario piept er ja auch ohne Lautsprecher? Das müsste doch mit dem oXs auch gehen?
 

Gravity

Erfahrener Benutzer
Hat schon jemand Erfahrung gemacht OpenXSensors als Temperatur Sensor für Hott zu betreiben?
Ich suche eine (kleine leichte) Lösung zum überwachen meiner Motortemperatur.
Mein aktuelles Projekt hat DLE35 im Rumpf und ich mache mir sorgen ob die Kühlung reicht.
In der oXs_config_description.h steht 6.4 steht was dazu, aber ein schlau werde ich daraus auch nicht.
 
Hat schon jemand Erfahrung gemacht OpenXSensors als Temperatur Sensor für Hott zu betreiben?
Wenn sich keiner meldet, wirst du die selbst machen müsssen. Das kriegst du aber hin. Hast du den NTC schon? Mit einem NTC 100k 3950 passen die Parameter. Mit dem Script kann ich helfen, oder frag direkt mstrens im openrcforum.

Hier gibt es auch eine Vorlage
, die mit Jeti funktioniert hat, da musst du nur von Jeti auf HOTT umstricken.
 

Gravity

Erfahrener Benutzer
Nein noch nicht, aber das scheinen mir die Standard Sensoren für 3D Drucker zu sein.
Im Hott Protokoll sind 2 Sensoren erwähen, wenn 2 Stk nutzbar wären könnte ich auch den Dämpfer im Augen behalten. Es wird eng im Rumpf.

Auf den Angebot komme ich gerne zurück.

DSC_0006.jpg
Fernwelle Für Druckpropeller
DSC_0013.jpg
Mittelmotor
DSC_0018.jpg
Vorne sitzt such noch ein Motor

Und er Kenner sollte jetzt wissen was das für ein Vogel wird 😉
 

Gravity

Erfahrener Benutzer
Also ich habe die beiden Files aus dem Forum mit den Sources von git verwurstet und das Protokoll auf HOTT umgestellt. Das kompilieren war hat funktioniert und das Nano ist jetzt ein General Air Modul.
Soweit ist alles klar. Aber was muss mich mit dem NTC machen im Forum war von A0 die Rede an VCC?
Und das andere Kabel? An 5V ich habe es al probiert aber der Funke zeit mit mir eine Spannung an Zelle 1 (V 4.1V) und keine Temperatur.
 

Gravity

Erfahrener Benutzer
So ich hab‘s doch noch hinbekommen, allerdings geht nur ein Temperatur Sensor.
T1 = 20° Jo kann sein.

Hat jemand eine Idee wie ich den zweiten Sensor ans Laufen bekomme?
Änderungen in der conf Basic.
#define TEMPERATURE_1_SOURCE VOLT_1
#define TEMPERATURE_2_SOURCE VOLT_2

Änderungen in der adv cof:
#define FIRST_NTC_ON_VOLT_NR_1
#define LAST_NTC_ON_VOLT_NR_2
Da hatte der Jeti Mensch die Unterstriche vergessen.
 

Gravity

Erfahrener Benutzer
Servus.
Kennst sich jemand mit Eagel aus?
Ich habe mich gestern zum ersten Mal damit beschäftigt.
Nach rund 2 Stunden inkl. Youtube Studium habe ich grundsätzlich mein Ziel erreicht.
Es gibt nur ein kosmetisches Problem:
Meine Platine ist so kompakt das die Beschriftung der Bauteile auf die Kontaktflächen ragt.
Die Schrift lässt sich auch nicht löschen, oder verkleinern. Smash macht nix.
Holzhammer: kann ich den Layer nicht einfach weglassen?
Jetzt nee ganz doofe Frage, weil ich mach das zum ersten Mal.
Wenn ich mir die CAM Files mit nem Gerber Viewer ansehe sind da keine Löcher. Ist das normal?
Wenn alles passt wollte ich es dort machen lassen.
https://www.elecrow.com/pcb-manufacturing.html


Anhang anzeigen Test.zip
 

Gravity

Erfahrener Benutzer
Hat sich erledigt.
Ich hätte vor den bearbeitungsversuchen der Beschriftungen F6 drücken müssen, oder das .brd komplett neu laden. Bug oder Feature?
Die Polygon Funktion für Masseflächen habe ich auch entdeckt.
Für die Seite gibt’s ein CAM Profile was dann auch gleich die benötigten Dateien erzeugt.
10 Stk. mit SchneckenPost Porto kosten dort unter 10€! Ich dachte ich guck nicht richtig.
Gut billigste Ausführung, aber für den Preis denkt man nicht mehr an selber machen.
Ob die Löcher jetzt drin sind oder nicht wird sich zeigen zur Not mach ich sie selber rein…
 
RCLogger

FPV1

Banggood

Banggood

Oben