AutoQuad M4V2r1 Anschlüsse

TheBone

Erfahrener Benutzer
Sorry, ich war die letzten Tage mit anderen Dingen beschäftigt und bin nicht dazu gekommen. Werde mich wohl morgen wieder ran setzen und die ESCs und die Werte überprüfen. Sobald es was neues gibt, werde ich hier umgehend wieder posten.
Bis dann. :)

Bye
 

TheBone

Erfahrener Benutzer
[video]https://youtu.be/Em3UqyrvBqM[/video]

:wow:

So. Ich glaube, ich kann bald einen Thread aufmachen, mit einer Auflistung aller Fehler, die man machen kann. Ich habe es nämlich gemacht. xD

Okay. Sieht schon mal etwas besser aus. Jetzt bekommt der nur noch kein GPS. Mit der AQ6 Platine hat der noch GPS bekommen. Mit dem M4 hatte ich es bisher noch nicht probiert. ... Öhm... ja, soviel dazu. Man sollte die GPS-Antenne natürlich auch an dem GPS anschließen und nicht am Port für die Radio Antenna. -.-
Okay. Werde das nachher nochmal testen, gehe aber davon aus, dass das der Grund dafür sein wird.

Die Nummer mit den Logs werde ich mir dann wohl auch nochmal anschauen müssen, denn irgendwie hat der die nicht geschrieben oder zumindest nur Kauderwelsch.
 
Zuletzt bearbeitet:
[video]https://youtu.be/Em3UqyrvBqM[/video]
Okay. Sieht schon mal etwas besser aus. Jetzt bekommt der nur noch kein GPS. Mit der AQ6 Platine hat der noch GPS bekommen. Mit dem M4 hatte ich es bisher noch nicht probiert. ... Öhm... ja, soviel dazu. Man sollte die GPS-Antenne natürlich auch an dem GPS anschließen und nicht am Port für die Radio Antenna. -.-
Okay. Werde das nachher nochmal testen, gehe aber davon aus, dass das der Grund dafür sein wird.
Sieht doch schon mal vielversprechend aus.

Die Nummer mit den Logs werde ich mir dann wohl auch nochmal anschauen müssen, denn irgendwie hat der die nicht geschrieben oder zumindest nur Kauderwelsch.
Wenn du dir die Datei mit einem Editor ansiehst wird das nix! Dann ist das nur Kauderwelsch. Du musst sie dir mit QGC ansehen (Log File Analysis).

Reduziere mal die Rates noch etwas um zu sehen wie sich 'das Schaukeln' verändert. Ist natürlich gut möglich dass du damit auch weiter hoch musst - war bei meinem Nylon-Spider so; rates runter hat das Aufschaukeln nur noch verstärkt. Hatte dann so lange in 200 Increments was drauf gepackt. Wurde dann besser und irgendwann wieder schlechter. Bingo! Wieder etwas runter damit und fertig.

EDIT: Denk beim Tunen auch daran dass du da später Ballast drunter hast!
 

TheBone

Erfahrener Benutzer
Hatte die Daten selbstverständlich versucht mit der QGC zu lesen, jedoch waren die Dateien auch in hoher Zahl mit kryptischen Zeichen betitelt und 4GB groß. Ich habe die Karte jetzt nochmal platt gemacht und damit kurz getestet. Jetzt sind das wieder ordentliche Logfiles. Werde nachher nochmal einen Flugtest machen, da kann ich dann die Log von posten.

Zum Verständnis, da ich ja jetzt schon an fast allen Parametern dran war. Welche empfiehlst du genau, welche ich ändern soll und in welchem Verhältnis?
 
Hatte die Daten selbstverständlich versucht mit der QGC zu lesen, jedoch waren die Dateien auch in hoher Zahl mit kryptischen Zeichen betitelt und 4GB groß. Ich habe die Karte jetzt nochmal platt gemacht und damit kurz getestet. Jetzt sind das wieder ordentliche Logfiles. Werde nachher nochmal einen Flugtest machen, da kann ich dann die Log von posten.

Zum Verständnis, da ich ja jetzt schon an fast allen Parametern dran war. Welche empfiehlst du genau, welche ich ändern soll und in welchem Verhältnis?
Ich gehe der Einfachheit halber mal von dem Parametersatz aus den ich ein paar Seiten vorher gepostet habe.

Code:
CTRL_TLT_RTE_D	                    12550
Der Knabe ist es in vielen Fällen. Erst mal runtersetzen (100 bis 250 Increments pro Schritt; der Schaukelt ja nicht viel weshalb du es langsamer angehen kannst) und sehen wie der Copter darauf reagiert.

Code:
CTRL_TLT_ANG_D	                     4100
Der ist schon niedrig --> erst mal nicht zu viel dran schrauben.

Log im Flug (der muss aus dem Bodeneffekt raus) ist interessant. Anhand der Daten (z.B. Vibrationslevel) kann man dann ableiten woran geschraubt werden sollte/muss.
 

TheBone

Erfahrener Benutzer
Hey Leute,

ich habe jetzt mal wieder ordentlich herumprobiert. Leider mit wenig Erfolg. Ich bin mit den D Werten bis auf 9.000 runter gegangen. Manchmal hatte ich das Gefühl, dass es etwas besser wurde mit dem aufschaukeln. Bei nachfolgenden Tests war es dann wieder schlecht wie eh und je. Ich nehme an, dass er sich die paar mal nicht so sehr aufgeschaukelt hat, war eher Zufall. Dann dreht er sich die ganze Zeit im Uhrzeigersinn um die eigene Achse. Mich wundert dann auch noch, dass die P und I Werte (Tilt-Rate) auf 0 stehen. Ist das richtig so?
Auf einigen Seiten habe ich betreffend PID-Settings auch noch massig Informationen gefunden, welche mich eher verwirrten, als das sie mir Aufschluss gaben. Jetzt bspw. oben die I und P Werte. Wenn die auf 0 stehen, bedeutet das doch, dass der Regler für diese Werte keine Aktionen durch führt, egal welche Werte durch den Flug gerade erzeugt werden. Dann ist es doch nicht verwunderlich, dass der Kopter sich immer aufschaukelt. Oder wie ist das zu verstehen? Arbeiten eigentlich vom Prinzip her alle Regler gleich oder bedeuten die Werte je mach FC immer etwas anderes?

Hier steht z.B.:
"Einstellen der PID-Regler
Als erstes setzen Sie alle Reglerparameter auf null, was einem Ausschalten der Regler gleichkommt. Nacheinander stellen Sie die P, D und I Parameter ein."
http://www.technik-consulting.eu/index.php?cat=Optimierung&page=Quadrocopter_PID-Regelung

Wenn dem so ist, wieso fange ich dann bei 12500 an?

Woran könnte es liegen, dass er sich weiterhin so aufschaukelt?

Danke schon mal für eure Antworten. :)

VG.
TheBone
 
...
Hier steht z.B.:
"Einstellen der PID-Regler
Als erstes setzen Sie alle Reglerparameter auf null, was einem Ausschalten der Regler gleichkommt. Nacheinander stellen Sie die P, D und I Parameter ein."
http://www.technik-consulting.eu/index.php?cat=Optimierung&page=Quadrocopter_PID-Regelung

Wenn dem so ist, wieso fange ich dann bei 12500 an?

Woran könnte es liegen, dass er sich weiterhin so aufschaukelt?
Wer hat dir denn gesagt dass du dass bei der Autoquad so machen kannst? Die verwendet verschachtelte PID Regler!
Was hast du denn jetzt für Parameter? Ich hab schon mehrmals nachgefragt aber noch nie welche gesehen.

Kommen die 12550 aus meinem Parameterfile für den Spider-Quad?

Wieso dreht der sich im Kreis? Z.B. weil der Mixer (immer noch oder schon wieder) falsch ist, oder weil einer/mehrerer Motoren nicht gerade sitzen (mit digitaler Pitchlehre kann man die wunderbar kontrollieren).

Mal ganz dumm gefragt: wenn du einen Parameter änderst machst du schon ein TRANSMIT und dann WRITE TO ROM?
 

TheBone

Erfahrener Benutzer
Wer hat dir denn gesagt dass du dass bei der Autoquad so machen kannst? Die verwendet verschachtelte PID Regler!
Was hast du denn jetzt für Parameter? Ich hab schon mehrmals nachgefragt aber noch nie welche gesehen.
Na ja den Log hatte ich ja bereits hier verlinkt:
Link
Oder was meintest du jetzt genau? Die Parameter der AQ m4 sind ja weitestgehend std. abgesehen von dem geänderten 12500 Wert.

Kommen die 12550 aus meinem Parameterfile für den Spider-Quad?
War der nicht Standard? Ich kann mich nicht erinnern diesen gesetzt zu haben.

Wieso dreht der sich im Kreis? Z.B. weil der Mixer (immer noch oder schon wieder) falsch ist, oder weil einer/mehrerer Motoren nicht gerade sitzen (mit digitaler Pitchlehre kann man die wunderbar kontrollieren).
Ich nehme mal an, dass die Motoren des Kopters schlicht nicht genau gerade sitzen und es wird halt immer schlimmer, je öfter man testet und je weiter sich die Motoren jeweils verdrehen (durch die unsanften Landungen). Ich müsste dann jeweils die Motoren wieder richten, aber ich hoffe einfach mal, dass dieses Problem sich via Software in den Griff bekommen lässt und wenn der neue Rahmen da ist, dann verdrehen sich die Motoren auch nicht mehr.

Mal ganz dumm gefragt: wenn du einen Parameter änderst machst du schon ein TRANSMIT und dann WRITE TO ROM?
Ja, das mache ich natürlich.
 
Hi,
also die Motoren solltest du schon gerade richten...da wird die Software die Phsyik nicht besiegen können.

Generell gilt: die Standard PIDs des M4 sind für einen Ladybird Copter gedacht. Somit sind die viel zu hoch für einen normalen Copter mit brushless ESCs und erst recht um Welten zu hoch für deinen.

Neben dem Log-File interessieren mich ALLE deine Parameter! D.h. im QGC auf den Button SAVE FILE clicken, abspeichern und dann diese Text-Datei hier posten.

EDIT: hab gerade in das LOG File geschaut: also die Vibrationen auf meinem Spider mit alten Motoren und weichen Nylon Armen waren deutlich übler --> Aufschaukeln kann man schön sehen --> der muss aus dem Bodeneffekt raus. Näheres dann wenn ich die Parameter dazu habe
 
Zuletzt bearbeitet:
Seit dem ich den Kopter an die Decke gehängt habe, ist es echt eine Überwindung ihn von dort wieder herunter zu holen. xD
Ich habe es jetzt jedenfalls geschafft. Anbei daher die aktuelle PARAMS.txt. :)

Anhang anzeigen 136947

Viele Grüße
Chris
Code:
CTRL_TLT_RTE_D	                    11250
Der ist viel zu hoch für deinen Copter! Ich würde mit einem Wert von 6000 anfangen und dann versuchen höher zu gehen.

Mixer ist korrekt --> wenn der trotzdem dreht sind die Motoren nicht richtig ausgerichtet.

Schalte mal das Braking der ESC32V3 ab. Kann gut sein dass dein aktueller Rahmen das nicht mag. Reduziert auch die Chance dass das Bremsmoment der riesen Props den Motor schief zieht (da müssen u.U. vier Klemmen statt bloß 2 ran).
 

TheBone

Erfahrener Benutzer
So, habe jetzt nochmal alle Motoren gerade ausgerichtet. Jetzt dreht er sich auch nicht mehr (merklich) um seine eigene Achse. Dass er jetzt in eine Richtung abdriftet kann am Aufschaukeln oder dem Wind liegen. Eigentlich dachte ich, dass er im position hold ist, aber kp.

Testergebnisse mit:
CTRL_TLT_RTE_D 6000
[video]https://youtu.be/tKxprxvclEw[/video]

CTRL_TLT_RTE_D 6300
[video]https://youtu.be/etF9VWNn6u8[/video]

Ja, ich freue mich schon über Spott und Hohn. :p

Werde jetzt erst mal die Beine kürzen. Das eine Karbonrohr hat es bei 6300 nämlich entschärft. Den Propellern ist - auch wenn es auf den ersten Blick anders aussieht - nichts passiert.
Die Gehäuse der Elektronik unter den Motoren werde ich erst mal entfernen und dafür dann besser haltende Schellen anbringen. Ich hoffe, dass dadurch die Motoren sich auch weniger oft verdrehen.

To be continued...
 
Wieso hast du CRTD höher gemacht? Wird das Schaukeln bei <6000 schlimmer?

Die Beine würde ich soweit wie möglich nach innen setzen. Durch die zusätzliche Masse am Armende wird das nicht besser. Die zu kürzen ist sicherlich keine schlechte Idee.
Du hast noch immer die 18mm Rohre, oder? Schon mal drüber nachgedacht zusätzliche Versteifungen zwischen die Arme zu packen?
 

ThinMan

Erfahrener Benutzer
Der Rahmen ist einfach nicht steif genug, das kann man ja in dem Video sogar sehen. Und bei solch einem kleinen "Absturz" darf kein Landebein kaputt gehen.

Schließe mich dem Vorredner an, zusätzliche Versteifungen könnten das Problem erheblich besser machen.

ThinMan
 

TheBone

Erfahrener Benutzer
Wieso hast du CRTD höher gemacht? Wird das Schaukeln bei <6000 schlimmer?
Ich würde mich jetzt mal darauf berufen:
Ich würde mit einem Wert von 6000 anfangen und dann versuchen höher zu gehen.
Ich werde dann bei den nächsten Versuchen den Wert nach unten anpassen. Mal gucken, was dabei heraus kommt.

Die Beine würde ich soweit wie möglich nach innen setzen. Durch die zusätzliche Masse am Armende wird das nicht besser. Die zu kürzen ist sicherlich keine schlechte Idee.
Ich habe die Beine jetzt erst mal rund 15cm gekürzt und etwa auf die Mitte zwischen Lastenhaltesystem und Motoren gesetzt.
Du hast noch immer die 18mm Rohre, oder? Schon mal drüber nachgedacht zusätzliche Versteifungen zwischen die Arme zu packen?[/QUOTE]

Die Arme werden auf absehbare Zeit durch 25mm Rohre ersetzt und unter Umständen auch noch etwas gekürzt. Bis dahin werde ich die 18'er nutzen und erstmal von zusätzlichen Versteifungen absehen.
 

gervais

Ich brauche mehr Details
Das hattest Du ja bereits im Juni geschrieben. Das Problem besteht darin, dass der Copter als Wackeldackel nie ordentlich fliegen wird. Ich habe zwar keine Ahnung von AQ, aber mit Arducopter wäre dieses Design unfliegbar, mithin gerade beim Gewöhnen an eine neue Technik (dieser Thread ist voller Baustellen), eher eine zusätzliche Hürde. Vielleicht solltest Du erst einmal Gehversuche mit einem Industrierahmen machen (Tarot o.ä.) oder klein anfangen F450 o.ä., um die Technik kennnenzulernen.
 
RCLogger

FPV1

Banggood

Banggood

Oben