Crius AIO V2 und Megapirates

Borbosch

Neuer Benutzer
Hi Zusammen,

heute konnte ich mal wieder einen Test wagen. Übrigens ist der Schaum recht weich und sollte eigentlich ganz gut geeignet sein.
Nun steht der Copter im Stabelize ganz gut in der Luft. Aber sobald ich althold einschalte springt er wie ein Wahnsinniger. Eingeschaltet hab ich den Modus bei gut 2 Metern Höhe.

Als ich nun nach dem Fliegen wieder daheim war, hab ich mir mal die Logfiles gezogen und mal "BarAlt" und "WPAlt" auf dem Diagramm angeschaut. Dabei kann man erkennen, dass der die gemessene Höhe doch ziemlich schwankt und "WPAlt" fast durchgehend bei 0 bleibt (oder bleibt der bei 0 wenn Althold eh aus ist?). Wenn ich das richtig verstehe, ist WPAlt die Zielhöhe die vom FC ermittelt wird. Was passiert da? Bin ich einfach zu niedrig und darf bei 2 Metern höhe nicht mehr erwarten? Spielt mir das GPS in irgendeiner Form dazwischen?

althold.png
 

hulk

PrinceCharming
Gps ist beim althold nicht schuld.
Baro nicht gut abgedeckt und oder vibrationen.
Aktivier mal imu logging
Und schwebegas einstellen.
 

Borbosch

Neuer Benutzer
Hey!

Danke für den Tipp mit dem IMU logging, das hat mich mal wieder auf die ardupilot Anleitung gebracht. Eigentlich hätte ich darauf auch selbst kommen können, aber ich wollte einfach nicht glauben, dass es ein Vibrationsproblem ist. Wie man aber im Screenshot sehen kann, scheint es genau das zu sein. Die Werte sehen für mich übel aus, wenn man das mit Graphen vergleicht, die im Rahmen sein sollen.
Da muss ich wohl mal ans Dämpfen...

vibration.png
 

Borbosch

Neuer Benutzer
Hi Zusammen!

Es geht weiter! Ich habe mich mal ans Dämpfen gemacht und mich für die "O-ring Suspension Mount" aus dem ardupilot-Wiki entschieden: http://copter.ardupilot.com/wiki/vibration-damping/.

Meine Variante sieht so aus:
IMG_20140914_152739.jpg

So sahen meine Vibrationswerte vorher aus:
vibrations1.png

Und so sehen Sie nach der Anpassung aus:
vibrations2.png

Ich glaube so kann es erstmal bleiben! Und nach meinem ersten Testflug im Garten ist auch alle viel stabiler! Der große Test muss leider noch warten, aber bisher bin ich schon ganz zufrieden. Ich bin mal gespannt ob die drei Lagen Antistatikschaum helfen werden.

Vielen Dank schonmal für eure Hilfe! Ich halte euch auf dem Laufenden ob es dann beim AltHold und Loiter auch wirklich geholfen hat.
 
Was sind für Props drauf das der so derbe Vibriert ? Die Bunten Plastik Teile ?

Graupner oderAPC MR wären eine gute Wahl. Diese noch ordentlich Gewuchtet und es langt ein normales Schaumstoff Tape als Entkopplung .

Mit der Plexiglasscheibe oben drüber und den rel. langen Gewindestangen, haste Dir einen Turm gebaut der Vibrationen noch Verstärkt.

Zumal dieser bei Roll und Nickbewegungen nach bzw. mitschaukelt. Wird dann auch ein Problem werden da ein richtig Stabiles Flugverhalten hin zu bekommen .
 
Zuletzt bearbeitet:
Hallo zusammen,

ich habe da auch mal wieder eine Frage. Und zwar versuche ich einen Strom und Spannungssensor anzuschließen. Aber ich bekomme einfach keine vernünftigen Werte angezeigt. Ich will diesen Sensor hier verwenden. Es lag keinerlei Anleitung dabei. Es sind sechs Drähte am Molex Stecker, ich denke 2x VCC 5,3V 2x GND, 1x I und 1x V.

Ich habe also mein vorhandenes BEC abgeklemmt und VCC + GND ans Board angeschlossen. Das Board läuft so auch.
I und V habe ich an A0 bzw A1 angeklemmt.

Nun meine Frage: Was muss ich im MissionPlanner einstellen und wo kann ich prüfen ob A0 / A1 überhaupt dafür vorgesehen sind.
In älteren MP Versionen kann man bei BatteryMonitor den VoltagePIN festlegen, in meinem Mission Planner finde ich das gar nicht.

Achso ich glaube ich fliege MPNG 3.0.1 R2 (kann man die Version irgentwo auslesen). Welche Version ist den derzeit die neueste stabilste ?
 
Ich kann das Wort "Drohne" nicht leiden. Ich empfinde das unter Modellbauern als Schimpfwort. Und gelaber von Presse Fuzzis die keine Ahnung haben.

Meine Meinung.
 

kismet

Erfahrener Benutzer
Hallo zusamen,

bin gerade am einrichten meines Crius AIOP v2 mit MegapirateNg. Nur scheitert es da schon beim compilieren des codes. Dabei bekomme ich folegende Fehlemeldung:

Building for MegaPirateNG
Excluding arduino core from include paths
avr-gcc: error: unrecognized command line option '-assembler-with-cpp'


Habe mir arduino und den sourcecode von der megapriateng runtergeladen, das jar kopiert und ersetzt ... jop beim überprüfen kommt die meldung

Könnt ihr mir einen Tipp geben was ich machen muss.

Vg kismet
 

hulk

PrinceCharming
Du solltest besser lesen.
Einfach nur jar kopieren geht nicht. Auf der seite ist das komplette tutorial oder du nimmst das flashtool
Mfg
 

kismet

Erfahrener Benutzer
hey danke für deine Antwort die mir leider nichr wirklich weiter hilft. falls dir der fehler bekannt ist, könntest du mir auch einen tipp geben was ich übersehen habe.

natürlich habe ich die anleitungt komplett gelesen nur habe ich jeden Schritt nicht hier aufgeführt.

bin für hilfreiche Antworten dankbar

vg
 

hulk

PrinceCharming
Du brauchst den richtigen arduino. Du musst den sketchordner angeben. Du hast nur das jar kopiert. Eventuell falsches board im arduino und oder sketch ausgewählt.
Da ich kein hellseher bin und nicht weiss was du machst, laut fehlercode aber was vermisst wird, ist die Hilfe extrem schwer.
Probier es bitte deshalb hiermit:
https://github.com/MegaPirateNG/FlashTool
 
Zuletzt bearbeitet:

kismet

Erfahrener Benutzer
Moin Hulk,

verstehe dass du kein Hellseher bist, schade ;).

Mit dem Flashtool funktioniert es auch, wollte das nur selber compilieren um den externen Kompass zu benutzen.

Folgendermaßen bin ich vorgegangen.

1. ArudPilot Arduino von Megapriratng.com runtergeladen und entpackt in C:/quadcopter (wie in der Anleitung beschrieben)
2. Megapriatng copter runter geladen und ebenfalls entpackt. (ebenfalls C:/quadcopter)
3. aus dem MegapriatNG die pde.jar genommen und in C:/quadcopter/ArdupilotArduino/lib kopiert und vorhandene Datei ersetzt.
4. Arduino gestartet (C:/quadcopter/ArdupilotArduino/arduino.exe) und unter ArduPilot->HAL Board->MegaPiratNG ausgewählt.
5. Unter Datei->Einstellungen bei SkatchBoard Speicherot C:/quadcopter/ardupilot-mpng-mpng-3.0.1-r4 eingetragen und alle häckchen entfernt.
6. Crius AIOP angeschlossen und Serial Port eingestellt.
7. Arduino geschlossen und wieder gestartet
8. Skatchook->ArduCopter ausgewählt und in der APM_Config.h Datei eigene Werte eingetragen.
9. STRG+R gedrückt und oben genannter Fehler (Building for MegaPirateNG
Excluding arduino core from include paths
avr-gcc: error: unrecognized command line option '-assembler-with-cpp') tritt auf.

Hoffe dies hilft weiter um die Fehlerquelle zu finden.

Vielen Dank und Gruß
 

hulk

PrinceCharming
Ich habe das megapirateng nicht mehr am laufen. Zuviele abstürze, zuviele betas, absolutes leistungslimit.
Ein amp board mit ext compass und gps kostet ja mittlerweile genau soviel.
P.s. brauchte man nicht ein richtiges arduino und nicht ardupilot?
 

kismet

Erfahrener Benutzer
Also habe das Arduino runter geladen welches auf der webseite verlinkt war bzw. ist. Hatte auch versucht arduino von der webseite runter zu laden jedoch ist das zip irgendwie kaputt.

Kenne mich bei den aktuellen Preisen für die Boards nichts aus, aber möchte nun kein neues Board mir anschaffen. Würdest du anstatt Megapiratng eher multiwii verwenden auf der Crius AIOP?
 

kismet

Erfahrener Benutzer
ok im bezug auf Funktionsumfang nicht aber im bezug auf Stabilität, vor allem wegen deiner Aussage "..habe das megapirateng nicht mehr am laufen. Zuviele abstürze, zuviele betas, absolutes leistungslimit."
 
RCLogger

FPV1

Banggood

Banggood

Oben