LUA Scripts zum testen

hobby1946

Erfahrener Benutzer
Allerdings versteht ich nicht "origineles GPS" Welches GPS hast den am Kopter wenn die Daten falsch erscheinen? Nimm doch das NAZA GPS wenns damit klappt.
Ich habe eine Naza Lite mit Zoggometry auf meinem Quadrocopter..
Das hat vor 2 Jahren einwandfrei mit der X9D+ und OTX V2.1.9 funktioniert.

Nun habe ich eine X10 mit OTX V2.2.1.
Hier funktioniert das Zaggometry auch, bis auf die GPS-Position.
Hier wird nur der Wert für OST angezeigt. Für NNORD steht immer 0.
Die Position wird auch nichtgeloggt.

Schließe ich ein orginal Frsky GPS an, funktioniert die Anzeige.
Bei beiden ist die GPS- ID gleich (0200/4).
 

hobby1946

Erfahrener Benutzer
Ich hatte V1.3 und habe auf V1.3.1 upgedated.
Alles das gleiche ...

Lt. Zaggo wird folgendes gesendet (Terminprogramm)

Zaggo LOG.JPG

Alles OK, bis auf den LAT-Wert.

Bei OTX V2.1.8 war die GPS-Anzeige auch nicht OK, was mit V2.1.9 ausgebessert wurde.

Wer ist jetzt dafür "zuständig" ???
 

grisu-hsk

Neuer Benutzer
Hallo zusammen,
weiß jemand wo man die Zaggo noch bekommen kann?

Scheint nicht mehr hergestellt zu werden. Oder welche Alternativen man hat die Daten aus der NAZA zu kitzeln.

Grüße
Sven
 

hobby1946

Erfahrener Benutzer
Wird nicht mehr hergestellt.
Auch die Firmware wird nicht mehr gepflegt.
Mit dem Sender X9D+ funktioniert das Zaggo noch, aber dann nicht mehr (X9E,X12,X10)
Und ohne GPS Position kann man nicht viel damit anfangen ...

Da gibt es sonst nix fertiges.
 
Hallo Alex!

Ich möchte meine Horus ebenfalls mit Pixhawk und Teensy Modul betreiben!

Habe mal einige Fragen dazu, wie du es umgesetzt hast.
1. Benutzt du das Teensy board als mavlink to Frsky SPort konverter, richtig?
2. Kannst du evtl deine Dateien von Scottfly für das teensy board dranhängen?
3. Musstest du bei den Sensoren etwas anpassen? Oder hast du einfach neue Sensoren suchen lassen und fertig?
4.Wie sieht deine Ordnerstruktur aus für Bilder, Script und das Model?
Hatte oft Probleme beim Ausführen dieses Scripts. Mal hat es funktioniert. Irgendwo ist da der Wurm drin :???:
5. Hast du den Namen des Scripts geändert?

Würde mich über deine Antwort sehr freuen!
Vielen Dank im Voraus!

Gruß!
Eugen
 

Lexi1970

Erfahrener Benutzer
Hallo das FLVSS Widget funktioniert bei mir nicht in companion.
wenn ich es aufrufen, erscheint nur die meldung requiers flvss sensor. obwohl ich diesen im sensor simulator aktiviert hab. flvss.jpg
 

r41065

Erfahrener Benutzer
Stell mal unter Cels auch die 2 ein:
Das ist die Sensor ID Mit der der Simulator intern Kommuniziert, nicht die Anzahl der Zellen.
eventuell auch im Simulator dann erst eine Sensorsuche...

Ralf
 

Lexi1970

Erfahrener Benutzer
hatte ich zuerst versucht mit 2.

hat auch nicht funktioniert

edit. jetzt hats geklappt. hab vegessen in den widget einstellung cels auszuwählen.
doof.
 
Zuletzt bearbeitet:

devil

Erfahrener Benutzer
Du hast in den letzten drei Zellen feldern die Werte angegeben, das funktioniert glaube ich nicht, da mittendrin.

gib mal in den ersten drei feldern 4v ein oder eben alle felder
 

Lexi1970

Erfahrener Benutzer
hat von euch jemand das Lua Script Pid Einstellungen auf der Horus X10 zum laufen bekommen? Ich krieg das nicht hin. Ich kann nur in den Sendergrundeinstellungen unter sd karte das script aufführen und da sieht man dann auch die pid werte, aber man kann keine änderung abspeichern. Normal sollte das doch auch mit auswahl telemetrie bildschrim und widgets zu machen sein. aber das klappt überhaupt nicht.
 

Lexi1970

Erfahrener Benutzer
Wenn du mode 2 hastsolltest du für autos den rechten knüppel vor zurück das gas nehmen. Da du eine mittelstellung hast.

Ih fahrre mit dee x9d mittlerweile nur die autos. Rechter knüppel vor zurück gas bremse und rechter knüppel links rechts die lenkung. Ist dann wie beim heli fliegen. Rechter knüppel vor zurück und links rechts.
 
Zuletzt bearbeitet:

wolepo

Erfahrener Benutzer
Wenn du mode 2 hastsolltest du für autos den rechten knüppel vor zurück das gas nehmen. Da du eine mittelstellung hast.

Ih fahrre mit dee x9d mittlerweile nur die autos. Rechter knüppel vor zurück gas bremse und rechter knüppel links rechts die lenkung. Ist dann wie beim heli fliegen. Rechter knüppel vor zurück und links rechts.
Hallo,
hier mal ein Beispiel meines Sohnes Jumbo. Angesteuert werden Licht- und Soundmodul von Servonaut. Vielleich hilft es weiter.
Gas ist links, Lenkung rechts. Nahezu alle Schalter wurden gegen 3-Stufentaster getauscht.
Sender ist ein X9D+.
Anhang anzeigen 11.2. Back up.otx.txt
Zum Umbenennen .txt entfernen
 
RCLogger

FPV1

Banggood

Banggood

Oben