MultiWii Release 2.2 ist da!

shackfu

Well-known member
kann man da nicht deadband in der config.h für nehmen?

Code:
    /* introduce a deadband around the stick center
       Must be greater than zero, comment if you dont want a deadband on roll, pitch and yaw */
    #define DEADBAND 6
Edit: Nach dem reinpasten habe ich es auch gelesen : nur roll,pitch,yaw ... sorry - passt für dich dann nicht
 

olex

Der Testpilot
Das gibt's aber auch, ist eine Extraoption, und zwar direkt unterm Deadband:

Code:
/* defines the neutral zone of throttle stick during altitude hold, default setting is
       +/-40 uncommend and change the value below if you want to change it. */
    #define ALT_HOLD_THROTTLE_NEUTRAL_ZONE 60
 
Ok, danke!
Ist diese Option standartmässig mit
#define ALT_HOLD_THROTTLE_NEUTRAL_ZONE 60
schon aktiv? Oder hast du "Olex" den Wert so gesetzt?

Muss die Zahl grösser sein um die Neutralzone zu vergrössern?
 

olex

Der Testpilot
Gute Frage. Ich glaube, ich hatte die Option schon hochgesetzt - standardmäßig sind's weniger. Ja, je größer die Zahl desto größer die zulässige Abweichung (Mitte ist ja bei 1500, unten/oben bei 1000 und 2000 - um den Wert von 1500 herum, also bei 60 von 1440 bis 1560 wird er dann Bewegung ohne Reaktion zulassen).
 
SUPER!!! Ich danke! :)
 

ChristophB

Erfahrener Benutzer
Der Nachteil ist, daß wenn man die Höhe manuell korrigieren will und diesen Deadband verlässt ist der Gassprung umso größer. Ich habe den Wert auch erhöht und dieses Phänomen festgestellt.
 
Es geht mir eigentlich um ganz wenig mehr spielraum. Ist default 40 wenn nichts ausgeklammert ist? Ich denke 60 ist schon wieder zu viel. Wenn 40 default ist werde ich es mit 50 mal versuchen.
 

lolsen

Erfahrener Benutzer
Ich habe jetzt auch ein Problem mit der 2.2er und einem ublox Gps ( rctimer cn-06 ).
Ich hatte es erst mit den Standartwerten des Gps versucht ( 9600 baud ) und dort auch Daten usw. in der GUI bekommen aber im Flug tat sich nicht, danach habe ich weiter rumprobiert und es auf 115200 Baud gestellt und "10.00 Hz Measurement Frequency" und auch dort bekomme ich die Koordinaten usw. in der GUI aber im Flug passiert immer noch rein gar nichts.
Hat da jemand ggf. eine Idee wie man das lösen könnte?!

lg Matze
 

weisseruebe

Erfahrener Benutzer
Ich habe jetzt auch ein Problem mit der 2.2er und einem ublox Gps ( rctimer cn-06 ).
Ich hatte es erst mit den Standartwerten des Gps versucht ( 9600 baud ) und dort auch Daten usw. in der GUI bekommen aber im Flug tat sich nicht, danach habe ich weiter rumprobiert und es auf 115200 Baud gestellt und "10.00 Hz Measurement Frequency" und auch dort bekomme ich die Koordinaten usw. in der GUI aber im Flug passiert immer noch rein gar nichts.
Hat da jemand ggf. eine Idee wie man das lösen könnte?!

lg Matze
Aktivierst Du zusätzlich auf Angle/Horizon und Mag? RTH oder PH alleine reicht nicht.
 

lolsen

Erfahrener Benutzer
ne, nur rht. okay, dann wird das mein fehler sein, hoffen wir mal das es funktioniert :p.
( gibt es eig irgend wo eine gescheite wiki über das p i d einstellen z.b. für Level usw., ich finde da nur mist )
 
So, meine MultiWii 2.2 Version läuft perfekt. Alles geht und fühle mich beim FPV Fliegen gut gesichert mit RTH / Headfree / PosH usw.... ;)
Mit dem Filter auf 98Hz war dann auch das wenige zucken weg (Mot und Prop sind gewuchtet) Habe nur den P-Wert um 0.2 angehoben. Ist nun auf 3.9 mit dem DJI F450 Frame, DJI Regler, den SunnySky Motoren und E-Prop 10x5 (Crius V2) :)

Nur die RTH Geschwindigkeit ist etwas lahm, das OSD zeigt mit 9-11 km/h an. Ich vermute aber, dass bei Gegenwind gar nichts geht. Irgendwo habe ich die Frage auch schon gelesen wo man die Gesch. anpassen kann, finde es aber gerade nicht.
Weiss jemand welche Einstellung es ist? So 20km/h wären schon schön, aber vermutlich wird dann das Ziel extrem überschossen hmmm....
Wie siehts bei euch aus?
 

didike

Erfahrener Benutzer
Hallo Marcel

Ich habe unter GPS ab Zeile 131 diese Werte geändert.
Im Beispiel sind die original Werte.

#define NAV_SPEED_MIN 100 // cm/sec
#define NAV_SPEED_MAX 300 // cm/sec
#define NAV_SLOW_NAV true
#define NAV_BANK_MAX 3000 //30deg max banking when navigating (just for security and testing)

In meinem Fall musste ich die Geschwindigkeit reduzieren und den Winkel verkleinern weil mein Quadro abzustürzen drohte und extrem übers Ziel schoss.

Gruss Dieter
 
Hoi Dieter

Habe die Werte gerade angeschaut. Weisst du in welchen Schritten die Werte geändert werden müssen? Ich meine damit zb. 110 oder 120 damit was geht oder nur schon 102 gibt schon was her?

Ach so, du musstest die default Werte runterschrauben? ja, hast glaub mal was geschrieben dass du bei 2 Copter unterschiedliche Gesch. hattest.
Was meinst du, was muss ich erfassen damit er nur etwas schneller wird? ;)
Danke Dir!
 

olex

Der Testpilot
Naja, das ist ja direkt die Geschwindigkeit die in den Werten steht. 100cm/s = 1m/s = 3.6 km/h, 300cm/s = 10.8 km/h. Wenn das zu wenig ist, entsprechend höher drehen.
 
Du sagts es, wieso bin ich nicht gleich draufgekommen ;)
Danke!!
 

olex

Der Testpilot
Allerdings eine Anmerkung: du hast ja vorhin geschrieben, gegen den Wind kommt das nicht an. Die Geschwindigkeit ist aber kein Airspeed, sondern GPS-basierte Bodengeschwindigkeit - heißt bei Wind wird er sich schräger stellen, bis die gleichen 300cm/s in die gewünschte Richtung doch erreicht sind. Zumindest wenn alles optimal eingestellt ist, und er dafür nicht schräger als 30° stehen braucht.
 
Ach so, dachte es sei Airspeed. Ja demfall schraube ich da nichts oder nur ganz wenig. Wenn er bei Wind trotzdem vorwärts kommt ist ja gut, auch 11 km/h reichen da, hauptsache er kommt ;)
 

Floh

Erfahrener Benutzer
Habe heute auf mein flyduinomega auch die 2.2 aufgespielt aber mitdem Drotek10dof
Baja althold ist nicht so der bringer ohne baro klappt höherhalten richtig gut mit baro fängt er an sich aufzuschwingen.
Meint ihr das es am Bosch baro liegt oder sollte ich die pid Werte anpassen ?
Baro ist das 085 . Der Frame ist der flyduspider .
Gruß Florian
 
Hallo Leute
Hab das SRF08 an meinem Quad, weiss aber nicht ob es funktioniert.
Denn es blinkt nur 9-mal rot. Weiss jemand vielleicht wie man es testet oder schaut ob es funktioniert.:confused::!:

Mfgl. Michael
 
RCLogger

FPV1

Banggood

Banggood

Oben