Tagebuch Erfahrungen mit dem Autoquad 6 Beta

MarcoKalmar

Erfahrener Benutzer
Also ich glaub das es wirklich am COM Port liegen könnte. Ich habe versucht diesen zu ändern nun jedoch zeigt es mir an das mein Gerät gar nicht mehr richtig installiert ist. Auch ein neues Installieren des Treibers hat nichts gebracht. Selbst als ich den Port wieder auf 11 gelegt habe zeigt es mir an, dass das Gerät nicht richtig installiert wurde. Ich habe nun meine anderen Laptop verwendet. Bei diesem werden mehrer COMs angezeigt wenn ich im QGG bin. Nachdem ich den richtigen ausgewählt habe (COM10 diesemal und nicht wie bei dem anderen COM11) kam eine neue Fehlermeldung:

stm32flash - http://stm32flash.googlecode.com/
read_byte: No error
SERIAL_ERR_NODATA

Assertion failed: 0, file stm32.c, line 94

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

Using Parser : Intel HEX
Using Parser : Intel HEX
Serial Config: 115200 8E1

Oh mann...vll versuche ich es Morgen mal mit meinem MacBook...oder hat jemand einen Ahnung?
 
Zuletzt bearbeitet:

MarcoKalmar

Erfahrener Benutzer
JAAA ich hab die Lösung gefunden. Also so habe ich es hinbekommen:
Grünes Kabel beim Adapter wegmachen
Adapter und AQ6 verbinden.
J4 verbinden.
Akku an AQ6 anschließen.
Reset Bottom am AQ6 drücken.
GCC öffnen und flashen.

Danke an alle die mir geholfen haben.

PS: Immer noch keine Ahnung warum es an meinem eigentlichen Laptop nicht geht aber es klappt nun auf dem 2ten.

Wenn ich nun auf Connect klicke kommen bei mir keine Zahlen im Mavlink Fenster. "Active" ist gelb und 0%. Jemand eine Idee?
 
Zuletzt bearbeitet:

MarcoKalmar

Erfahrener Benutzer
Also wie im "Thema:Tagebuch Erfahrungen...."auch im Wiki wird gesagt, dass im Mavlinkfenster viele Zahlen bzw irgendein Text kommt der einen Datenaustausch darstellt. Dies ist bei mir nicht der Fall statt dessen die Meldung ,,Voltage warning 6.9 volts". Wenn ich eventuell eine falsche hex Datei verwendet habe, wo bekomme ich die richtige her? Ich habe die Aktuellste von der AQ6 Seite genommen.
LG
 

sandmen

Erfahrener Benutzer
Jo, wenn Du in der qgc sagst, Zahlen anzeigen, dann würden die auch kommen!
Wenn Du das widget "Communication" etwas breiter machst, bzw. als eigenständiges Fenster "heraus holst" oder aber die qgc,
so groß machst wie möglich, würdest Du diese Optionen auch sehen. :)
 

MarcoKalmar

Erfahrener Benutzer
zu aller erst vielen vielen Dank! Du hattest Recht was die .hex Datei angeht. Habe eine andere .hex genommen und keine Fehlermeldung mehr und die Zahlen sehe ich auch...alles genau so wie du es gesagt hast. Nochmals vielen Dank
 
Zuletzt bearbeitet:

jenne

Neuer Benutzer
Hallo,

nach zähem ringen habe ich mich nun doch entschlossen, den AQ zu testen und mir ein AQ6+DIMU besorgt. Leider habe ich damit auch gleich schon das erste größere Problem. Ich kann das Board anschliessen, bekomme aber immer eine SDIO WRITE error != SD_OK Fehlermeldung.

Ich habe bisher 3 SD-Karten probiert (und diese auch mehrfach neu formatiert):
- Samsung Pro 8GB
- Transcend Premium 300x 8GB
- Sandisk Extreme 16GB (ohne "Plus")

Firmware ist auf dem Board und Daten kommen an. Ich kann das Board bewegen und sehe das auf dem Rechner (Linux). Das funktioniert also schon mal. Aber es wird nichts geloggt und ich kann das Board damit auch nicht kalibrieren.

Sind die getesteten SD-Karten noch zu "schlecht"? Mache ich sonst noch etwas falsch oder habe etwas vergessen?

Danke für Eure Hilfe,
Jens
 

Lindbaergh

Erfahrener Benutzer
Moin, das hört sich nicht gut an, ich habe auch so ein Board hier liegen das die Fehlermeldung SDIO WRITE error != SD_OK bringt. Bei meinem wurde der Fehler durch einen (leichten) crash verursacht. Auch mein Board läuft ansonsten top, und Tests mit anderen SD Karten die in einem anderen AQ laufen brachten nichts.
 

jenne

Neuer Benutzer
Hallo,
danke für die Antwort, auch wenn das nicht gut klingt. Ich habe das Board im Autoquad-Forum gekauft. Das Board hatte der Vorbesitzer vor einigen Tagen zur Kontrolle eingeschickt und als i.o. zurückbekommen. Da muss ich da mal näher nachforschen.

Jens
 

Lindbaergh

Erfahrener Benutzer
Solltest du herausfinden was das Problem ist bzw. wie man es beheben kann, würde es mich freuen wenn du hier etwas dazu schreibst. Vielleicht kann ich meinen 400€ (Das Board ist noch aus der Zeit vor der Preissenkung) Briefbeschwerer ja doch noch irgendwie retten.
 

jenne

Neuer Benutzer
Sorry, die letzten Wochen hatte ich leider überhaupt keine Zeit, mich um meinen AQ zu kümmern.
Ja, das Problem mit der SD-Karte ist jetzt behoben. Kaputt war nichts, es lag an einer ungewollten Lötbrücke. An dieser Stelle danke an Jussi für die Hilfe.

Jetzt wollte ich mal ein Stück weiterkommen, habe das MultiWii Borad gegen AQ getauscht - und habe leider wieder ein neues Problem. Ich kann meinen Copter nicht armen. Genauer gesagt, werden die ESCs (Kiss 18A) nicht scharf/aktiv geschaltet (es kommt der erste kurze Beep+LEDs gehen an, dann gehen die Lampen wieder aus, d.h. sie werden nicht aktiviert).
An den PWM Parametern (Mot_Start, Aktivieren_PWM) habe ich schon gedreht - ohne Erfolg. Dem Empfänger (Frsky X8r) habe über über S-Bus (mit Inverter) angeschlossen und sehe auch die Steuerausschläge in der qgroundcontrol. Throttle geht auf 0, wenn ich den Hebel nach hinten bewege, Yaw geht bis auf über 800 bei Bewegung nach rechts. Die Schalter für die Flugmodi sind korrekt eingestellt (manual mode, normal mode). Kalibriert habe ich den Copter noch nicht (weder statisch - muss ich das überhaupt, wenn ich eine DIMU habe, noch dynamisch). Ich hoffe, das ist nicht die Ursache. Aber ich wollte erstmal versuchen, den Copter überhaupt zu armen.

Was könnte die Ursache sein, dass die ESCs nicht aktiviert werden?
 
Zuletzt bearbeitet:

El-dentiste

1.21 Gigawatt
Moderator
HI
die kiss esc bekomen kein gültiges signal, sodas sie freischalten.
Stimmen in der AQ gui die werte der kanäle(balken) bei gas halt 0-100% zb
DANACH die kiss nochmal einlernen und dann wirds was :)

(gearmt isser aber oder?? also grüne led dauerhaft an ;) )
 
RCLogger

FPV1

Banggood

Banggood

Oben