Wifibroadcast-Projekte - Einzel- und Anfängerfragen

Deepflights

Erfahrener Benutzer
#61
Also mit dem richtigen Treiber, für die USB-Sticks, und den richtigen Sticks, sollte die Latenz zwischen 60 und 120ms sein.
Easycap ist nun da, hättest Du ein paar Zeilen für mich was Du installiert hast? ich habe da versch. MPEG2 Encoder gefunden, Deine Version scheint ja super zu laufen.

Verwenden würde ich am liebsten ich einen Zero, sollte der nicht reichen, habe ich noch einen PI3 zur Verfügung, was meinst Du?
 
#62
Easycap ist nun da, hättest Du ein paar Zeilen für mich was Du installiert hast? ich habe da versch. MPEG2 Encoder gefunden, Deine Version scheint ja super zu laufen.

Verwenden würde ich am liebsten ich einen Zero, sollte der nicht reichen, habe ich noch einen PI3 zur Verfügung, was meinst Du?
Das ist zwar der falsche Treath für Fragen zum Easycap (wird wohl bald wieder der ein oder andere rumnöhlen), aber ...

Code:
[install 'mplayer' audio/movie player]
sudo apt install mplayer2

If you want to start live video capturing - using mplayer - from a shell script you need to
create a script file
[name].sh
For my example it is 
start_capture.sh
The contents of the file are the commands to run. In case of capturing live video:
mplayer tv:// -tv device=/dev/video0 -hardframedrop

Don't forget to make this script exectuable
sudo chmod +x /[path to script]/start_capture.sh

If you want to start this from the desktop simply make a new .desktop file:
shark.desktop
[Desktop Entry]
 Name=LiveFeed
 Comment=Start image capturing
 Icon=/home/pi/QGC_V1_7Beta/shark_logo.png
 Exec=/home/pi/QGC_V1_7Beta/start_capture.sh
 Type=Application
 Terminal=false
 Categories=None;
Das Logo welches ich verwendet habe stammt von hier (hab es jedoch transparent gemacht) http://www.mhm-modellbau.de/firmen/fatshark_logo.jpg

Ergebnis sieht dann so aus
2016-04-05-112024_169x357_scrot.png
 
Zuletzt bearbeitet:

Deepflights

Erfahrener Benutzer
#63
Danke :)

Dann lag ich ja mit dem Mplayer gar nicht mal so falsch, mit dem habe ich gestern schon ein Bild bekommen, aber beim bewegen habe ich jetzt den Kamm-Effekt.. ich muss also etwas finden wo ich "interlaced" machen kann.

Irgendwie ist das Bild auch sehr soft, wenn es so ist wie ich es befürchte dann ist wohl das AV Signal mehr als scheisse.
Ich spiel mal noch ein wenig, wenn alles nicht klappt dann muss doch eine PI Cam mit auf dem Gimbal.
 

Deepflights

Erfahrener Benutzer
#64
Projekt gestorben, das Videobild ist noch schlimmer als analog übertragen, warum die Chinesen der Kamera keinen HDMI out verpasst haben würde mich wirklich interessieren.
Ich habe soeben eine PI Cam bestellt, die kommt dann eben an die Yi 4k drauf.

Schade.
 

Haucki

Erfahrener Benutzer
#65
Hallo Zusammen,

ich muss auch noch mal eine Frage wiederholt stellen, weil es noch keine zufriedenstellende Antwort gab, vielleicht gibt es auch keine.

Ist eine 5" Monitor aufgetaucht, den man in eine Quanum stecken könnte? Ich hab keine Lust, mir noch eine sperrige FPV Brille zuzulegen ;)

Viele Grüße
Haucki
 

spongebob

Neuer Benutzer
#69
Hallo

ich bin neu in diesem Forum. Entschuldige mich also mal gleich im Voraus, wenn ich hier mit dummen Fragen komme.

Also ich habe hier EZ-Wifibroadcast-1.6RC3 auf zwei Rapspi 3 mit CSL 300 am Laufen. Videoübertragung excellent, keine Frage. Problem ist aber, dass sich Wifibroadcast offenbar wie ein Frequenzbesen aufführt: Sowie ich den Tx starte, gehen alle meine anderen WLAN Verbindungen offline. Mehr noch, Sniffer finden die Netze nicht mal mehr.

Ich muss dazu sagen, dass ich keine der Einstellungen verändert habe.

Habe ich was vergessen?

EDIT: Die Sniffer sehen die Netze, aber es ist mir unmöglich, auch nur eins zu joinen

Mfg
 
Zuletzt bearbeitet:

spongebob

Neuer Benutzer
#70
OK, dann antworte ich mir mal selbst: Wifibroadcast beansprucht 130 MHz Bandbreite, damit scheidet das 2.4 GHz Band für weitere Wifi Operationen (ausserhalb Wifibroadcast) aus. Ich habe TX und RX jetzt auf 5.8 GHz konfiguriert und das funktioniert auch. Mein 2.4 GHz Netz wird nicht mehr gestört.
 

Identic

Erfahrener Benutzer
#72
Ich schon wieder...
Bin da auf ein kleines Problem gestoßen.

Ich möchte einen Zero W als Sender nutzen, hab bei Auvidea das B102 HDMI-CSI Bridge bestellt, eine CSL300 als Antenne.
Bekomme so aber kein Bild am Empfänger (Pi3 mit 2 CSL300).

Wenn ich den Zero W durch einen Pi3 mit der normalen Pi-Cam ersetze habe ich Bild.

Übersehe ich etwas? Das B102 muss ja nicht extra aktiviert werden, oder?
 

Drohne

Erfahrener Benutzer
#75
Danke für die Antwort. Über das Netzwerk geht es. Wenn ich aber schon eine Tastatur und Monitor dran habe, möchte eben diese auch nutzen.
Local login (via a keyboard and monitor connected to the Pi)
Connect keyboard and monitor to the Pi
Press alt-F12 to switch to TTY12
Das funktioniert eben nicht (bei mir). Auch andere Tastenkombinationen nicht.
 

rodizio1

Erfahrener Benutzer
#76
Du hast geschrieben, Du hättest "strg-alt-f1" gedrückt, das wäre die richtige Tastenkombination wenn auf dem Pi ein X laufen würde und du auf tty1 willst.

Auf dem Pi läuft aber kein X und auf tty1 bist Du schon per default, deswegen passiert bei "nach tty1 schalten" natürlich nichts. tty12 (bzw. tty2 bis tty12) ist aber da. Geht die Tastatur vielleicht gar nicht?

Versuch mal strg-alt-del, das muss auf jedenfall zum reboot führen.
 

Drohne

Erfahrener Benutzer
#77
Die Tastatur funktioniert. Wenn ich ohne "Wifi Broadcast" von einer anderen SD Card hochfahre, klappen auch die Tastaturbefehle. Ich möchte irgendwie aus dem Videobild in eine Möglichkeit der Konsolenbefehle wechseln. Wenn das überhaupt möglich ist...
 

Drohne

Erfahrener Benutzer
#78
Hallo,
warum auch immer, jetzt kann ich zwischen den Konsolen mit Ctr. F<> wechseln! In F12 kann ich mich einloggen, wie ich es möchte...
Möglicherweise habe ich die Funktion meiner italienischen Tastatur unter deutschem Layout erst jetzt richtig verstanden.
Und das Videobild muß weg sein! (Sender aus).
 
Zuletzt bearbeitet:
RCLogger

FPV1

Banggood

Banggood

Oben