X12S Horus mit openTx V2.2x

Norbert

Erfahrener Benutzer
Hallo Leute - 1 Frage an die Spezialisten, bin im Moment ratlos:
Ich habe mit meiner Horus seit diesem Jahr das Problem kurzer Aussetzer in der Telemetrie, bzw eines negativen Ausschlag des Höhenruders. Diese Störungen dauern ~ 2sec.
Gestern flog ich in gut 100 mtr - hatte einen Ausschlag lt. Telemetrie von -1024 und nach 2 sec konnte ich meinen Segler in gut 40 mtr abfangen. Das ist mir dieses Jahr in ähnlicher Form schon 5 oder 6 x passiert, seither lasse ich ständig die Telemetrie mitlaufen, um Daten zu bekommen.
Während der Störung stand auch die Telemetrie für exakt 3sec, was sich schön am GPS ablesen läßt ( keine Änderung der Koordinaten ). Ich zeichne mit 0,2 sec auf. Hatte vorher schon stottern in der Telemetrie beim Vario. Das Problem trat an insgesamt 3 Orten auf, die räumlich je ~10 km getrennt sind.
Jetzt meine Fragen:
  • Woher nimmt die Telemetrie die Daten für die Aufzeichnung der Knüppel und Schalter? (Um den Fehler einzukreisen)
  • Kennt jemand das Problem?
  • kann es mit der Telemetrie zusammenhängen?
  • Es tritt nur bei HR auf - Kabelbruch liegt nicht vor und kommt nur alle paar Std.
  • Kein Reichweitenproblem, fliege zT mit diesem Modell annähernd 1000 mtr - gestern waren es 140 mtr Distanz
  • Log liegt vor
Wenn mir da jemand helfen könnte wäre ich sehr dankbar. Das ist im Moment mein letztes Problem, das geklärt werden muss :engel:
 

FJH

Erfahrener Benutzer
Hallo Norbert,

wenn du noch einen Kanal frei hast, dann verlege (Kopie Mischer) doch dein HR mal darauf. Ist jetzt zwar keine Erklärung für deinen unerwünschten Effekt, wäre aber interessant zu testen, ob sich dann beide Kanäle gleich verhalten.
 
  • Woher nimmt die Telemetrie die Daten für die Aufzeichnung der Knüppel und Schalter? (Um den Fehler einzukreisen)
  • Das hat mit Telemetrie/HF-Modul/SPort nichts zu tun, die Daten gehen direkt in den Log.

  • Den würde ich mir gerne ansehen. Hier kommen zwei Sachen zusammen, der Höhenruderausschlag, da würde ich eigentlich ganz simpel auf Kabel/Hall-Sensor tippen. Und die Telemetrie bzw. der Verbindungsabbruch. Beides zeitlich zusammen ist aber ein komplett neuer Effekt. Vielleicht findet man im Log noch weitere Anhaltspunkte.
 

Norbert

Erfahrener Benutzer
  • Das hat mit Telemetrie/HF-Modul/SPort nichts zu tun, die Daten gehen direkt in den Log.

  • Den würde ich mir gerne ansehen. Hier kommen zwei Sachen zusammen, der Höhenruderausschlag, da würde ich eigentlich ganz simpel auf Kabel/Hall-Sensor tippen. Und die Telemetrie bzw. der Verbindungsabbruch. Beides zeitlich zusammen ist aber ein komplett neuer Effekt. Vielleicht findet man im Log noch weitere Anhaltspunkte.
"Das hat mit Telemetrie/HF-Modul/SPort nichts zu tun, die Daten gehen direkt in den Log." Davon würde ich auch ausgehen

Das Kabel des Hallsensors ist es nicht - davon gehe ich mal fest aus - kann ich aber gerne erneuern. Das Problem hatte ich immer in Verbindung mit "Telemetrie verloren -Telemetrie wieder hergestellt " .

Bei den Files einfach das .txt weglöschen - aber wem sage ich das. Das Problem trat bei 11:48:14 auf. Deutlich am plötzlichen Höhenverlust zu erkennen.

Problem.csv ist der ausgeschnittene Problem Flug und das 09_Xplorer...... eine kurze Sequenz vor und nach dem Auftreten.

Ich bin gespannt wie ein Flitzebogen, zu welchem Schluss ihr kommt.

PS: Exakt das gleiche Problem hatte ich mit dem ersten Horus Sender, nur auf allen Rudern, der dann getauscht wurde. Auch da konnte ich mit dem Log nachweisen, daß da eine Fehlfunktion vorliegt. Mit dem neuen Sender war jetzt 2 Jahre Ruhe, jetzt das gleiche wieder.
 

Anhänge

Also rein nach dem Log würde ich sagen, du hattest einen Verbindungsausfall und das Höhenruder war von dir gesteuert. Es war deine Reaktion auf das was passiert ist. Das erinnert mich fatal an einen Pylonracer, der hatte denselben Effekt mit einer X10. Also erst kommt der Lockout, dann deine Höhenruderreaktion. Das sollte man nicht auf die leichte Schulter nehmen. Währed des Lockouts wurde kein Telemetriedatum aktualisiert.

Lockout.png
 

strgaltdel

Erfahrener Benutzer
kurzer Aussetzer in der Telemetrie, bzw eines negativen Ausschlag des Höhenruders

jetzt mal aus dem Gedaechtnis, ohne Ueberpruefung:
Die "Knueppel-Werte" werden "direkt" vom Geber abgefragt.
Wuerde bedeuten, dass ein negativer Wert = Hoehe ist, nicht Tiefenausschlag
Bin gerade im Ausland, ganz ohne Sender, kann's leider nicht gegenchecken

Wuerde Sinn ergeben
kurz vorher Tiefe gedrueckt,
ggf erfolgte dann FS mit Servo auf "hold"
also nose down attitude,
Pilot zieht dabei sukkzessive Hoehe
irgendwann reagiert dann wieder das Modell

unmittelbar vor dem Problem fiel der RSSI
welcher Empfaenger ?

imho kann man die ueblichen RSSI Grenzwerte nicht fuer die neueren G- / R- Empfaenger verwenden, die muessten imho hoehere RSSI Warnungen erhalten.
Reichweite ist zwar besser als z.B. bei X-Series
aber der FS wird bei hoeheren RSSIs ausgeloest.

War bis jetzt nur eine Beobachtung bei Bodentests
Ohne fundierte Vergleichsmessungen mache ich da aber "kein Fass auf"
 
Zuletzt bearbeitet:
Ich kenne mich mit den Logs nicht aus, hatte aber gerade den "blöden Gedanken" ob da der Failsafe falsch gegriffen hat?
Ok es ist ja erst (eine Sekunde) nach dem Verbindungsausfall passiert, dass Norberts Höhenruder auf Tiefe ging, aber könnte es sein dass die FS Funktion das Höhenruder stuert?
 
Im Log sieht man nicht, was Norberts Höhenruder gemacht hat, die lila Linie zeigt, was Norbert gesteuert hat. Das Modell muss aus irgendeinem Grund abgetaucht sein, gleichzeitig war die Verbindung unterbrochen, das sieht man an der eingefrorenen Telemetrie. Norbert hat versucht mit Höhenruder ziehen, das Modell abzufangen. Failsafe greift erst eine Sekunde nach Verbindungsverlust, aber Norbert hat schon früher gegengesteuert. Also muss etwas anderes passiert sein.

Verbindungsverlust + ungesteuerter Tiefenruderausschlag war vermutlich die Ursache. Nur warum? Ein Empfänger Reboot könnte so ähnlich aussehen.

Edit: Udo hat wahrscheinlich Recht mit der Vermutung, dass der Segler nach einem gesteuerten Tefenruderausschlag nach unten geneigt war, als der Verbindungsabbruch auftrat.
 
Zuletzt bearbeitet:
In meinem Ausschnitt ist es unklar, aber wenn man die Daten direkt anschaut, sieht man die 50m Höhenverlust.
gelb: Lockout
orange: Höhe
cyan: Höhenruder
Lockout_data.png
 

Norbert

Erfahrener Benutzer
Sorry dass ich mich erst jetzt melde - war gestern - nein heute :engel: lange unterwegs.

Vielen Dank für Eure Erklärungen - haben mir die Augen geöffnet. Zzur weiteren Erklärung:

Das war nicht das erste Mal, daß das Modell nicht reagierte oder ohne Zutun abtauchte. Immer in Verbindung mit Telemetrieverlust. Dieses Mal waren es Luftlinie Modell - Sender ~ 200mtr. Fliege das Modell aber ohne Probleme ~ 1km Luftlinie.

Ich habe die Telemetriedaten falsch gelesen, da ich über sah, dass das Höhenruder vom Log her anders herum läuft - pos. Werte= Tiefe neg Werte = Höhe

In diesem Fall, zu dem die Diagramme und Tabellen gehören - wollte ich Höhe vernichten und drückte das Modell mit halbem Knüppelausschlag. Ging mit dem Knüppel auf Neutral und wollte dann wieder ziehen. Keine Reaktion. Wie bereits richtig erkannt - ziehen - mehr ziehen - ich dachte nicht voll. Dann reagierte das Modell wieder - nach gefühlten 30 sec - nein - vielleicht einer Sekunde.

Durch meinen Gedankenfehler glaubte ich, dass die interne Aufzeichnung fehlerhaft ist - und vermutete den Fehler wo anders. Durch eure Korrektur :p vielen Dank :p spiegelt die Aufzeichnung auch die Ereignisse wieder.

Nur was war geschehen?

" Das erinnert mich fatal an einen Pylonracer, der hatte denselben Effekt mit einer X10. " spiegelt mein Problem wieder, das offenbar ein Failsave war - was auch ich jetzt vermute. Meine Ruder gehen im Failsave auf hold, was aber immer noch nicht erklärt, warum bereits mehrfach mein Segler schlagartig abtauchte. Also nicht langsam Fahrt aufnahm und nicht reagierte sondern hart Tiefe gab, dann kurz ~ 1-2 sec nicht reagierte und dann wieder alles normal in Verbindung mit Telemetrie lost.

Und Tadango schreibt:
"To me this sounds a bit like the bug in the iXJT in the early release of the X12s:
- Good RSSI values
- Sudden hold in a not expected location / distance
- Short failsafe, then a recovery and everything works normal
- No telemetry lost warning from the receiver
- Not reproducable in other flights"

Aha - das erklärt auch die Probleme mit meiner ersen Horus - exakt dieses Verhalten. Warum jetzt 2 Jahre Ruhe war und es wieder los geht????????????

Bei "Das erinnert mich fatal an einen Pylonracer, der hatte denselben Effekt mit einer X10. " wird auf einen weiteren Beitrag von Carbonara in RCG hingewiesen, in dem es ebenfalls um Failsave geht.

Den Bezug auf "Quim_Bodas" habe ich nicht gefunden, aber wenn ich es richtig verstehe, setzt man die Failsave eines Kanals auf eine extreme Position, lässt ein Servo auf diesem Kanal laufen, hängt an den Servohebel etwas hin ( Vermutung ) und schaut ob das runtergefallen ist ( Failsave ) oder löst damit eine Kamera aus oder was auch immer.

Etwas weiter oben von wir auf einen Testaufbau von Tadango verwiesen, bei dem mit Hilfe des
Link Quality Sensor und einer PC Routine ??? nach Failsave gesucht wird. Diesen Beitrag habe ich nicht gefunden. Ich schließe jetzt hier mal, sonst wird der Post zu lange und suche und denke nochmals.

Zusammenfassung:
Vielen Dank für die Unterstützung und Berichtigung. Hätte ich so wahrscheinlich nie gefunden.

Die vermutliche Ursache ist ein nicht richtig funktionierendes HF - Modul.
  1. Ich werde den Sender im Moment mal unverändert lassen und mit meiner 2ten Horus fliegen.
  2. Eine geeignete Prüfmethode finden, um die Probleme nachzuweisen
  3. Geeignete Maßnahmen finden das Problem zu beheben und die Behebung nachweisen, ohne dabei Modelle zu schrotten ( wäre auch eine Prüfmethode :devilish: )
Ich bitte mich weiter zu unterstützen und ich werde hier sicher berichten. Falls ich falsche Schlüsse gezogen habe, bitte darauf hin weisen :poop:
 
Meine Ruder gehen im Failsave auf hold, was aber immer noch nicht erklärt, warum bereits mehrfach mein Segler schlagartig abtauchte. Also nicht langsam Fahrt aufnahm und nicht reagierte sondern hart Tiefe gab, dann kurz ~ 1-2 sec nicht reagierte und dann wieder alles normal in Verbindung mit Telemetrie lost.
Beim Pylonracer in RCG war es ähnlich. Er flog mit gezogener Höhe um den Spitzpylon, als das Höhenruder neutralisierte (kann man auch als auf Tiefe gehen sehen) und er im Messerflug unterwegs war, bis er wieder Kontrolle hatte. Eine Erklärung dafür suche ich noch :unsure:

Bis jetzt ist der Fehler nur bei iXJT in Verbindung mit LBT aufgetaucht, will aber auch nix heißen.

Falls es hier im Forum einen Moderator gibt, könnte er ein neues Thema mit den letzten Posts aufmachen: "Kontroll- und Telemetrieverlust"
 

Norbert

Erfahrener Benutzer
"I put my Horus on servo cycling and I'm using an x8r receiver powered by an esc bec using a single servo. Failsafe set so that the servo horn hits a block and clips off. Got 6 events in 30 minutes."

Meintest du diesen Test in RCG?

Ich habe mir folgendes überlegt: Ich setze Failsave bim Höhenruder auf eine extreme Position (hoch ). Lasse Sender und Empfänger laufen. Schliesse meinen SM GPS Logger mit dem Servoeingang am Höhenruderkanal an und logge im 0.2sec Takt. Da der SM GPS Logger den Wert des Servokanals in usec aufzeichnet, kann ich hinterher wunderbar auswerten. Wäre das eine sinnvolle Möglichkeit?
 
Hallo Leute,
Ich hatte letztes Jahr ebenfalls Probleme mit Verbindungsabbrüchen bei meiner Horus von 02/2017.Der erste hat mich einen nagelneuen Tomcat beim Erstflug gekostet(ja,das tat weh!).Ich bin allerdings von einem gestorbenen G-RX8R ausgegangen,da die Logdatei ebenfalls fehlerhaft war und der Tomcat bis zum Einschlag nicht mehr steuerbar war.Danach hatte ich auch bei verschiedenen Modellen kurze Abbrüche mit Ansage "Telemetrie verloren",zuletzt mit meiner 2,30m Extra in max.50 Meter Entfernung bei einer Rolle über die Landebahn.Diese Aussetzer waren immer relativ kurz und das Modell sofort wieder steuerbar.
Ich habe über den Winter mal das IXJT Modul erneuert und hatte danach keine Probleme mehr,muss aber noch abwarten,da ich dieses Jahr noch nicht viel zum Fliegen gekommen bin.
Ich werde über meine weiteren Erfahrungen berichten.
 

Norbert

Erfahrener Benutzer
Das wäre hochinteressant - ich bin noch auf Fehlersuche. Meine erste Horus - die ausgetauscht wurde - kostete mich einen Carbonara aus ~ 300 mtr senkrecht ( 4mtr CFK F3b Modell ) und einen gebrochenen Rumpf eines Tracer ( 3mtr F3B im Landeanflug ), mit dem neuen Sender war 2 Jahre Ruhe - jetzt geht es wieder los.
Ich fliege jetzt meine Spare Horus - wll aber definitiv den Fehler nachweisen, da ein Crah mich 5x so viel kostet wie ein neuer Sender - liebe aber OTx und Horus.
 
Ich hatte zuerst OTX in Verdacht,da die Abbrüche erst mit dem Update auf 2.2.2 begannen.Vorher hatte ich nie irgendwelche Probleme,weder mir Reichweite noch mit Failsaves.Mittlerweile habe ich 2.2.3 installiert und somit wäre ein Nachweis nur mit einem downgrad auf 2.2.2 möglich.
Hauptsache die Verbindungsabbrüche sind weg,denn auch ich liebe meine Horus ,OTX und natürlich auch meine Modelle ;-)
 
Meintest du diesen Test in RCG?
Nicht genau diesen, aber ähnlich. Einfach eine extreme Servoposition als Failsafe speichern, die eine Aktion ausführt, z.B. eine Kugel irgendwohin kickt.

Ich habe mir folgendes überlegt: Ich setze Failsave bim Höhenruder auf eine extreme Position (hoch ). Lasse Sender und Empfänger laufen. Schliesse meinen SM GPS Logger mit dem Servoeingang am Höhenruderkanal an und logge im 0.2sec Takt. Da der SM GPS Logger den Wert des Servokanals in usec aufzeichnet, kann ich hinterher wunderbar auswerten. Wäre das eine sinnvolle Möglichkeit?
Mach doch beides parallel. Man müsste sich vielleicht noch etwas einfallen lassen, um einen Telemetrie Freeze zu bemerken. Hast du einen oXs mit PWM Auswertung? Dem könntest du ein Servotestsignal über PWM oder SPort (LUA-script) schicken und die zurückgemeldeten, sich laufend ändernden PWM Werte loggen. Ein passendes Script kann ich dir schicken.
 

quax2011

Erfahrener Benutzer
@all, von wann sind eure Sender. Meiner ist von Ende 2016. Hatte bisher keinerlei Problem damit. Ich hab aber damals die Hallgeberkabel von Engel auswechseln lassen. Ich frag mich jetzt schon ob ich mir da Gedanken machen muss. War das Sendemodul von Anfang an das gleiche?

Jürgen
 
RCLogger

FPV1

Banggood

Banggood

Oben