FPV Wifi Broadcasting HD Video - Thread zum Raspberry HD Videolink von Befi

#41
Idealerweise verwendet man natürlich ein UHF system, der wlan kanal 13 scheint aber recht störungsfrei auf 2.4 ghz funken zu sein.
grundsätzlich kann man natürlich beliebig viele wlanadapter anschliessen und die auf unterschiedlichen kanälen senden oder empfangen lassen. Dank multitasking auf dem pi alles kein problem.
 
Zuletzt bearbeitet:

aargau

Erfahrener Benutzer
#42
@digaus einfach einen anderen der 13 Kanäle wählen
@seeers funke und video auf der gleichen Frequenz ist nie eine gute Idee
13 Kanäle gibt es zwar, die überlappen sich aber, man kann nur 3 Kanäle nutzen die sich nicht überlappen... Ansonsten wird es wohl Pixelbrei geben.
Bei digitalem Funk giltet das eben nicht mehr unbedingt ;-) Wenn gehoppt wird stört sich das nicht, bzw. wenn dann wird nur das Wlan gestört. Dazu gibt es ja eben mehrere Kanäle. Die Funke sollte übrigens eh auf dem ISM Band und nicht im Wlan Band Funken, das ISM ist wenn ich es korrekt in Erinnerung habe über dem Wlan Band, also sollte eigentlich ein tiefer Kanal besser sein.

@seeers: Sicher das du FrSky verwendest? Ich kann mir echt nicht vorstellen, dass eine Billige GoPro mit den paar nW sendeleistung die Funke stören kann. Bei billigen die nicht Hoppen ist es ganz klar, da ist sicher schnell finito wenn die GoPro den kanal zuballert. Ich fliege oft mit Wlan am Copter und hatte noch nie ein Range Problem. Ev. auch nur ein Telemetrie Problem bei dir?
 

kinderkram

Erfahrener Benutzer
Moderator
#43
auf nachfrage von trailblazer:

so hab ich mit meinen spärlichen linuxkentnissen den autostart über die comand-line installiert:

hg clone https://bitbucket.org/befi/wifibroadcast_fpv_scripts/src/497917f2421c01a1a7c52332e7e09b344b7b2622?
cd 497917f2421c
cd init.d
sudo cp wbctxd /etc/init.d
sudo update-rc.d wbctxd start
cd
mkdir wifibroadcast_fpv_scripts
cd
cd 497917f2421c
sudo cp tx.sh /wifibroadcast_fpv_scripts

sudo reboot

fertig
für rx einfach rx.sh auf tx.sh und wbctxd auf wbcrxd ändern...
Danke für die Anleitung - aber meine Linuxkenntnisse sind noch spärlicher.
Hab RASPBIAN über NOOB auf dem A+ installiert und funzt soweit auch.
Mercurial installiert und dann scheitert es schon am hg clone Befehl: "bash: hg: Kommando nicht gefunden"

Was hab ich falsch gemacht oder übersehen? :confused:


Edit:
Hab Mercurial erneut installiert und fehlende Pakete runter geladen (hat beim ersten Mal wohl nich geklappt). Jetzt funzt der hg Befehl jedenfalls...


Edit, die 2.: Nu findet er das Verzeichnis 497917f2421c nich...
 
Zuletzt bearbeitet:
#44
Schau mal mit "ls" welcher ordner angelegt wurde, also welche Revision aus dem Repository gezogen wurde. Wenn sich das unterscheidet von dem 497917f2421c dann einfach "cd <Ordner Name>" eingeben. Es reicht aus wenn du die erste/ersten Zeichen eingibst und dann mit Tab das ganze vervollständigen lässt.
 

kinderkram

Erfahrener Benutzer
Moderator
#45
Schau mal mit "ls" welcher ordner angelegt wurde, also welche Revision aus dem Repository gezogen wurde. Wenn sich das unterscheidet von dem 497917f2421c dann einfach "cd <Ordner Name>" eingeben. Es reicht aus wenn du die erste/ersten Zeichen eingibst und dann mit Tab das ganze vervollständigen lässt.
Danke für den Tipp, aber ich fang nochmal von vorne an.
Ich muss wohl erstmal die Liste von befinitiv abarbeiten. :rolleyes:
Die Anleitung von f.bednarz bezieht sich wohl nur auf den Autostart Patch.

Bin halt totaler Linux Noob...
 
#46
Hat schon jemand einen 5 GHz stick gefunden der monitor mode unterstützt? Mein Googleausflug hat mich noch nicht auf ein ordentliches Ergebnis gebracht.
Laut mehrer Berichte aus den englischen Threads scheinen die CSL 300 Dongles auf 5GHz prinzipiell zu funktionieren, habe aber noch nichts über irgendwelche Reichweiten gesehen.
Habe selbst welche hier liegen und werde bei Gelegenheit testen...
 

moritzz06

Erfahrener Benutzer
#47
Kann denn nicht mal jemand ein image seiner SD Karte(n) in eine dropbox laden?
Dann könnte man das Projekt vllt doch "plug and play" bekommen..
Würde sicher vielen helfen..
 

kinderkram

Erfahrener Benutzer
Moderator
#50
Ja Anleitung bezieht sich nur auf autostart der scripte,
installieren und testen musst du nach der liste von befinitiv...
Ja, danke - habs gemacht und das Airmodul scheint auch zu funzen.
Jetzt gehts an das Groundmodul. Mal schauen, ob ich das heute noch hinbekomme...

Fertige Images wie von moritzz06 vorgeschlagen wären ne riesige Erleichterung für Einsteiger.
Wär schön, wenn sich einer der Cracks dessen mal annehmen würde.
 

kinderkram

Erfahrener Benutzer
Moderator
#52
Schau mal hier, vllt läuft das ja :)
http://fpv-community.de/showthread....ung-Telemetrie&p=820338&viewfull=1#post820338

Kommt nicht von mir und hab es nicht getestet..

Am Wochenende ist es bei mir so weit ;)
Danke für den Link - ich saugs mir grad.

Meine eigenen Bemühungen enden öfter im "Hängenbleiben" der Installation. K.A., warum.
Werd die Images mal auf frische Karten flashen und schauen, was passiert. Ich berichte dann...

Kann mir jemand sagen, wie ich die RunTx/Rx.sh Scripte einbinden kann?
 

Schalonsus

Erfahrener Benutzer
#54
Heute den ersten Bodentest gemacht mit 720p, 18dbi Yagi an WN722n und Dipol an WN722n. Empfänger 1m über dem Boden und Sender 1.5m... 800m Reichweite. Bin dann auf einen Hochsitz gestiegen da war das Signal dann wieder super.
 

moritzz06

Erfahrener Benutzer
#55
Sehr gut kinderkram :)
Hast Du einen RPi 2 oder 1 am Boden?

Jetzt fehlt nur noch ein günstiges 5" 720p Display für die diy Videobrille. Fliege nicht so gerne mit Monitor.
 

kinderkram

Erfahrener Benutzer
Moderator
#56
Ich hab 2 A+ wg. der Baugröße.
Vom Airmodul werd ich alle überflüssigen Teile ablöten, das Stickgehäuse entfernen und alles zusammen mit nem Stepdown Regler in ein möglichst kleines Gehäuse packen.

Für´s Groundmodul hab ich ein 8" Polin HD Display ins Auge gefasst, weil ich das Package eher für Aerial Videos brauche als für FPV. Noch ein paar CL Antennen druff und dann sollte das laufen...
 

aargau

Erfahrener Benutzer
#58
Heute den ersten Bodentest gemacht mit 720p, 18dbi Yagi an WN722n und Dipol an WN722n. Empfänger 1m über dem Boden und Sender 1.5m... 800m Reichweite. Bin dann auf einen Hochsitz gestiegen da war das Signal dann wieder super.
800m hört sich jetzt nicht so extrem viel an für eine 18dBi Antenne...
Das würde heissen mit den Dipol Antennen ist schon nach wenigen Metern Schluss wenn man tief fliegt :-(?

Edit: Mein RX läuft schon mal, zumindest RX war keine hexerei mal sehen wie es dann auf dem TX aussieht, das mach ich dann (hoffentlich) morgen.
 
Zuletzt bearbeitet:
#59
Hab grad festgestellt, das man die seriellen bluetooth module die ich noch zuhauf von multiwii Zeiten rumliegen hab prima per gpio einbinden kann und dann mit dem handy auf die commandline kommt...
Da ich mir für den tx nen a+ bestellt hab und alles was geht weglöten sowie wlan stick direkt anlöten will, is des ne gute Möglichkeit onfield noch paar einstellungen vorzunehmen...
 

Schalonsus

Erfahrener Benutzer
#60
Für 80mW und 720p find ich das ganz in Ordnung. Villt kann man auch an den Einstellungen noch was ändern aber damit habe ich mich noch nicht beschäftigt. Kann ja morgen nochmal mit den Dipolen testen
 
RCLogger

FPV1

Banggood

Banggood

Oben