FunFly Controller Naze 32

coolmax hat gesagt.:
Für mich der jetzt gerade einsteigt in die Copterszene dachte, ich habe mir mein Naze32 kaputt geflasht.
Wenn ich TimCop richtig verstande habe kannst du per USB den Bootloader garnicht überschreiben, somit kann nicht viel kaputt gehen beim flashen.
 

JUERGEN_

Generation 60++
der-Frickler hat gesagt.:
coolmax hat gesagt.:
Für mich der jetzt gerade einsteigt in die Copterszene dachte, ich habe mir mein Naze32 kaputt geflasht.
Wenn ich TimCop richtig verstande habe kannst du per USB den Bootloader garnicht überschreiben,
somit kann nicht viel kaputt gehen beim flashen.
so ist es,
Der Chip-Bootloader ist fest im ROM gespeichert, und wird hier durch die Brücke BOOT0 aktiviert.

und es gibt hier auch keine versteckten Bereiche , wie bei der FF (Seriennummer)

:rot:
 

coolmax

Erfahrener Benutzer
Das ist gut zu Wissen, naja im meinen Fall war ich aber erstmal überfordert von dem Flashtool und es leuchtete ja nur noch die Blaue LED.
Da steht man dann als Anfänger erstmal dumm da.

Die Bezeichnungen zum Flashen im Flash Loader Demo finde ich ein wenig unglücklich, ich gin davon aus das es upload sein müßte und nicht Download, kenn ich beim flashen nicht so.
Aber wie gesagt, ich bin ja anfänger und man lernt nie aus und bin auch bereit dazu.
 

ReX_1986

Erfahrener Benutzer
lazyzero hat gesagt.:
@rex die Einstellungen der pid kannst du mit der wiiconf GUI nachen ppm und copter Type wird per cli eingestellt.
Chridtian
Kannst Du vieleicht genau beschreiben was ich machen muss? Ich hab Putty, HyperTerminal und Hercules heruntergeladen. Ich weiß nicht wie ich die befähle senden soll :???::S:

Was hab will ich machen? Summensignal einschalten und Copter richtung. Standard ist Quad X also das bleibt aber später kommt noch hexa (hab zwei Naza32 Platinen).

EDIT:

Ich weiß nicht wie aber bin gerade in Einstellungen mit Putty gelandet :D . Paar mal probiert aber hat nicht funktioniert, jetzt aber geht das.
 

lazyzero

... zu viel geflashdingst
Du musst mit einem Terminalprogram dich mit der Platine verbinden. Baud sind 115200 kB/s und 8n1 muss für die serielle verbindung eingestellt sein, und eben der port der belegt ist.

Dann sendest Du ein R ohne Zeilenumbruch. Dann bootet das board und alle LEDs sollten an sein. Dann mit dem Flashtool von STM das neue hex-File einspielen.

Wenn das alles gemacht ist. Wie auf meiner Seite beschrieben die config anpassen.

Christian
 

ReX_1986

Erfahrener Benutzer
Es wäre super wenn Du noch auf Deiner Seite schreibst was was ist z.B:

PPM: Summensignal
usw.

Available features: PPM VBAT INFLIGHT_ACC_CAL DIGITAL_SERVO MOTOR_STOP SERVO_TILT CAMTRIG GYRO_SMOOTHING LED_RING

Danke ich komme "glaub ich" jetzt zu recht :)
 

lazyzero

... zu viel geflashdingst
Das könnte ich noch machen. Bin mir aber bei manchen sachen nich sicher.
Könnt mir ja auf die Sprünge helfen.

PPM Summensignal
VBAT Akkuspannungsüberwachung
INFLIGHT_ACC_CAL ? Ist das der ACC cal mit den Sticks wenn der Copter nicht gearmt ist?
DIGITAL_SERVO Digital Servo z.B. für Tricopter
MOTOR_STOP Motoren stoppen wenn der Gasknüppel auf null ist
SERVO_TILT Kamerastabilisierung
CAMTRIG ? Ein servo kann zum Auslösen einer KAmera genutz werden? Wo wird das angeschlossen?
GYRO_SMOOTHING ?
LED_RING Dieser I2C LED ring?

Gruß Christian
 
Zuletzt bearbeitet:

ReX_1986

Erfahrener Benutzer
Ich muss erst auf meine Hobbywing Programmierkarte warten, dann kann ich meine Regler einstellen. GoPro V2 ist heute angekommen :) Gimbal wird erst konstruiert und hergestellt. Videosender und Empfänger mit 5,8 GHz hab ich auch schon. bluetooth und Ultrasonic Module sind auch auf dem weg zu mir. GPS, hmmm erst einbisschen lesen dann kaufen ;) .
 
Zuletzt bearbeitet:
Hab am Sonntag mal die neuste baseflight 20120330 firmware geflasht, der GoFly Mini fliegt jetzt auch mit den default Werten prima. Nur der Baro zickt noch etwas rum, reagiert recht zickig, kann aber am kleinen Kopter und damit eigens produzierten Störungen liegen…

Mit den neueren Hobbywing/Plush Reglern habe ich das Problem teils auch das die Motoren schlechter starten, liegt aber nicht am Naze, hab ich beim KK auch. Einfach mal kurz an Nik/Roll rühren bis alle laufen, dann abheben.
 

Karsten J.

Erfahrener Benutzer
Könntet Ihr hier mal Eure PID-Werte posten ?
Brauche mal Anhaltspunkte (und ja, ich weiß, man kann die Werte nicht übernehmen :))
 

ReX_1986

Erfahrener Benutzer
ACC ist bei mir auch sehr schlecht. Wenn ich einschalte dann spinnt der Copter. Er macht was er will aber one ACC bleibt er richtig stabil, manschmal zugt er und fällt runter :(
 
So, hab meinem Naze gerade das 5€ GLB Bluetooth Modul verpasst, Einstellen und Graphen einstellen klappt prima mit dem neuen Android Tab ;-)
 
Schaltung wäre übertrieben, ist das Modul hier:

sku_65443_0.jpg
http://www.goodluckbuy.com/serial-bluetooth-rf-transceiver-module-rs232.html

Belegung steht ja quasi dran. Damit gehts dann am Naze an die folgenden Pins:



Natürlich Naze TX auf BT RX und andersrum. Der LEd Pin am BT modul kann noch mit einer LED + Widerstand gegen _Masse gelegt werden, dann blinkt das Ding im Betrieb auch schön.

Das BT Modul kann dann noch auf die Baudrate des Naze eingestellt werden, oder man setzt den seriellen Speed des Naze auf die 9600 des BT Modules runter. Christian hat das alles schön dokumentiert:
http://lazyzero.de/modellbau/multiwii/bluetooth?s[]=bluetooth
http://lazyzero.de/modellbau/multicoptersetup/naze32/start?s[]=naze
Ach ja, bei manchen BT Modulen muss um in den config mode zu kommen noch der PIO11 pin (der letzte oben gegenüber dem TX) auf 3,3V gelegt werden.

Ich kann die Tage mal ein Bild machen, aber von den Kabeln sieht man kaum was da der Frsky RX und das BT Modul beide auf dem kleinen Naze kleben und es fast komplett verdecken.
 
RCLogger

FPV1

Banggood

Banggood

Oben