Ghettostation Antennentracker

#83
Besten Dank für die Links.

Ich fülle so ebenen Einkaufskorb.
Bei den Widerständen bin ich mir nicht ganz sicher.
Benötigt wird:
- 5k60
- 33k2
- 17k8
Folgende habe ich an Lager:
- 5.6 k ohm
- 33 k ohm
- 15 k ohm
Kann ich den 33 und den 15 verwenden oder müssen diese passender sein?

@Peter Sollte das Herstellen der Platinen misslingen, so werde ich gerne auf Dein Angebot zurückkehren.
 
Zuletzt bearbeitet:
#84
@ Bongo_1st

Du solltest schon die Passenden nehmen sonst spielt das ding nicht richtig.
aber auch die kannst du haben von mir ich hab sie im 1000Pack gekauft ;-)....... Einfach PN
 

eve-msw

Neuer Benutzer
#85
hi, ich habe jetze die 3dr 433mhz module und würde die gerne einbauen
frage wie?
plane: gps >> 3dr ? oder gps >> Ghettoproxy >> 3dr

bodenstation << 3dr oder ???

hat wer evtl auch nochn schaltplan wo ich das rx/tx am dem 3dr mit usb abnehmen kann? ) 7pins ....
sg

ps 3dr überträgt raw daten direkt vom gps ...
 

IdefixRC

FPV, RC und mehr......
#86
3dr modems haben einen direkten TX/RX pin (7 pin am Modul, einfach mal nach pixhawk Telemetry suchen, ist das gleiche kabel das den pixhawk mit dem 3dr modem verbindet - denke es war pin 2 und 3 am Modul aber besser noch mal googeln).
Pixhawk - > 3dr modem ----------3rd modem - > ghettostation. Bei gps direkt einfach mal probieren anstelle von pixhawk das gps anzuschließen. Sollte gehen. Dann halt nur schauen das die baud raten stimmen und das das gps nema schickt und dies auch auf der ghettostation eingestellt ist
 
Zuletzt bearbeitet:

eve-msw

Neuer Benutzer
#88
sooo :) 3dr telemetrie geht leider muss ich da noch was einstellen, die gps daten kommen teilweise gestückelt an
welche einstellungen am 3dr sind da von nöten?
aktuell SiK 1.9 on HM-TRP

format: 25
Baud: 57
Airspeed: 64
NetID: 75
TX Power: 11 (in de glaub ich max 8)
ecc: Häckchen
mavlink: ist mavlink ausgewählt
Op Resend: häckchen

min max freq : 433050 bis 434790
#of channels: 10
Duty cycle: 10
lbt Rssi: 0
rts cts: kein hacken
max window (ms): 33
 

eve-msw

Neuer Benutzer
#89
so nach gefühlten 365stunden dauertestens läuft das ding nun aber mit fehlern bei der 3dr übertragung werde mich da aber noch weiter rantasten bis das genau funktioniert ^^
aktuell:
skyeye fpv:::> GPS --> minimosd , GPS --> 3dr 57600baud schwarz, rot, gelb, grün ist weggelassen wird nicht gebraucht) gps läuft mit 57600 baud und es werden ublox und nmea gleichzeitig übertragen (siehe minimosd setup für ublox6m gps)

ghettostation :::> 3dr (57600baud) >> mega2560,kompas,20x4lcd,3buttons,2billigservos,3slipo für mega, 4akkus für servos( servos extra spannungsversorgung sonst schmiert der mega bei schnellen bewegungen ab ^^ )

3dr alles auf standart bis netid, duty cycle 10, max window (ms) 37

so sieht das aus was im moment ankommt
q ` < ?2?b$ ?|? ????   UB? ??D ???b! ?|? ?#?
,6?-$PUBX,04,134454.60,090815,49494.60,1857,17,-145000,-4819.473,21*11
?b4 }?????A?d/gf?y
m ???????????? ? "g ???b }???Q??l?? ?? ? P ???b }?? ? P ? q ` < K?b$ }? ???? 
UB? ??D
?$PUBX,04,134454.70,090815,49494.70,1857,17,-145481,-4819.304,21*1B
?b4 x}?????A?c/gd?y
m ???????????? ? "g ?>?b x}???Q??l?? ?? ? M 4?b x}?? ? P ? q ` < fS?b$ x}? ???? 
UB? ??D yq$PUBX,04,134454.80,090815,49494.80,1857,17,-145963,-4819.252,21*18
?b4 ?}?????A?c/gd?w
m ???????????? ? "g ?b ?}???Q??l?? ?? ? J s?b ?}?? ? P ? q ` < ?[?b$ ?}? ???? 
UB? ??D ?!$PUBX,04,134454.90,090815,49494.90,1857,17,-146445,-4819.012,21*14
?b4 @~?????A?b/gc?w
m ???????????? ? "g U??b @~???Q??l?? ?? ? H ???b @~?? ? P ? q ` < /t?b$ @~? ????   UB? ??D MD$PUBX,04,134455.00,090815,49495.00,1857,17,-146927,-4818.773,21*1C
?b4 ?~?v???A?b/ga?v
m ???????????? ? "g ???b ?~???Q??lt? ?? ? F &?b ?~?? ? P ? q ` < ?|?b$ ?~? ????

UB? ??D ?H$PUBX,04,134455.10,090815,49495.10,1857,17,-147409,-4818.671,21*1F
?b4 ?X???A?`/g_?u
m ???????????? ? "g ???b ???Q??l`? y? ? C H??b ?? ? P ? q ` < ???b$ ?????????
 UB? ??D ?$PUBX,04,134455.20,090815,49495.20,1857,17,-147891,-4818.790,21*1C


diese zeile würde mir reichen

PUBX,04,134455.20,090815,49495.20,1857,17,-147891,-4818.790,21*1C

vielleicht braucht man ja doch noch einen flightcontroller , reicht da ein cc3d?

schönen sonntag :)
 

eve-msw

Neuer Benutzer
#90
hi, habe nun ein cc3d mit eingebaut telemetrie mit der openpilot software via 3dr funktioniert besstens nur an der gettostation habe ich zwar empfang aber alles steht auf 0

habe von dem 3dr modul mit usb das rx/tx abgefasst 2.pin 3. pin von links
protokoll ist uavtalk
habe auch cleanfligt mal getestet via multiwii protokoll da kommt genau das selbe
empfang ja aber alles auf 0 kein fix kein 3d keine koodrinaten

sg eve
 

Kubschi

Neuer Benutzer
#91
Moin Leute,

bin gerade am Ghettostationbau. kann mir einer sagen wie ich den Kompass einbauen soll? Also in welche richtung und wird er mit dem LCD Board parallel geschaltet? Kann man sich vielleicht die Daten vom Kompass anzeigen lassen?

Danke
 

Kubschi

Neuer Benutzer
#92
Moin Leute,

bin gerade am Ghettostationbau. kann mir einer sagen wie ich den Kompass einbauen soll? Also in welche richtung und wird er mit dem LCD Board parallel geschaltet? Kann man sich vielleicht die Daten vom Kompass anzeigen lassen?

Danke
 

papahp

Erfahrener Benutzer
#95
Nabend...

Problem gelöst sorry ;)

Lag schlicht an der Arduino Version die man hatte.

Es läuft :)

MFG
Chris
 
Zuletzt bearbeitet:
#96
Moin Leute,
hat jemand eventuell Interesse mein Ghettostation Projekt fortzusetzen? Ich habe hier soweit alles rumliegen um den fertigen Tracker zu bauen aber habe einfach nicht die Zeit um das ganze anzugehen. Ich kann ja mal schreiben wie weit ich war:

-Ghetto Station Case inkl Mechanik 3D gedruckt und zusammengebaut
-Arduino Mega komplett verkabelt mit Display und Knöpfen
-Servos verbaut (die machen Probleme und ich weiss nicht wodran das liegt, kann sein, dass die getauscht werden müssen)
-2 FSK Modems und Ghettoproxy gebaut und geflasht (habe noch Teile für 3 weitere FSK Modems hier liegen)

Das ist es soweit. Momentan ist natürlich alles eher provisorisch verkabelt weil das ganze im Versuchsstadium ist. Falls aber jemand interesse an dem Projekt hat und keine Lust hat alles aus 20 Shops zusammen zu kaufen bin ich gerne bereit das ganze zu einem fairen Preis zu übergeben.

Gruß Christian
 

Fräse

Neuer Benutzer
#98
Guten Abend @all,

ich lese ab und zu mal mit in diesem Forum wenn ich nach einer Problemlösung suche. Heute kommt es zu meinem 1. Post hier im Forum glaube ich. Kurze Vorstellung von mir: Michael, 42 Jahre, komme aus dem Raum Magdeburg, wohne seit 2005 in Stuttgart, betreibe den Modellsport seit ca. 1996 ohne Verein, bin reiner Wildflieger, beruflich als CAD-CAM Programmierer im Motorsport tätig.

Nun zu meiner Frage bzw. Problem...
Ich habe sämtliche Hardware für die Ghettostation verdrahtet und die File's kompiliert und hochgeladen. Soweit funktioniert alles ausser das die Station sagt sie wartet auf GPS-Daten. Ich betreibe folgende Hardware:
Arduino Mega, 433 MHz Telemetrie (Mavlink), FRSky, Ardupilot 2.6, OLED-Display

Ich habe mir ein Brett genommen auf dem ich das Ardupilot mit GPS, FRSky Sender und 433 MHz Telemetrie-Airmodul gebaut habe. Die Verbindung zum Computer funktioniert auch über 2 Airmodule. Bekomme auch alle Daten GPS-Anzahl etc. angezeigt vom Ardupilot. Nun stecke ich das Airmodul an den Mega über TX vom Airmodul auf RX1 (19) am Mega. Eingestellt habe ich Bank 2 (5,8 GHz), als Protokoll Mavlink mit 57600 Baud. Die 2 Airmodule kommunizieren miteinander den die grüne Lampen leuchten dauerhaft und die roten blinken.
Meine Einstellungen in der Config.h habe ich vorher durchgenommen. Das Display muss ich unter der Adresse 0x3C ansprechen.
Jetzt weiß ich leider nicht mehr weiter und frage deshalb euch um Hilfe.
Würde mich über Tips sehr freuen.

Grüße
 

IdefixRC

FPV, RC und mehr......
#99
Kann sein das die Ghettostation die Verbindung nicht initialisiert. Probier mal folgendes:
- APM an und ueber die 433 modems mit PC verbunden
- APM und Airside 433 an lassen, am Boden das 433 modem vom PC abklemmen und an die Ghettostation anschließen.
- Ghettostation einschalten und schauen ob die Daten kommen.

Damit sollte der PC die Verbindung initialisiert haben und der APM daten schicken. Wenn es dann geht bedeutet das die Ghettostation die Datenübertragung nicht initialisiert - nochmal die TX Kabel überprüfen und die Einstellungen in der config datei = passiv aus (ich hatte bei meiner ein BT Modul mit eingebaut und die Daten gleichzeitig am handy mit empfangen - Ghettostation hört nur mit).
Sollte es nicht gehen dann denke ich hast du ein Problem mit der Verkabelung oder den Einstellungen auf der Station (Mavlink, baud, pins, passiv)
 
Hallo Fräse,
zum einen gib wilkommen hier.
zu deinem Problem, kanst du den in der Ghettostation alle grundeinstellungen machen also Servowege einstellen und der gleichen.

mach mal folgendes.
Nimm vom APM -Telemetrie anschluss Masse und TX und verbinde es mit der Ghettostation RX1 (19) am Mega und masse.
dann sollte es etwas anzeigen,
im nächsten Schritt kannst du das AirModul anschliessen RX UND TX,
jetzt wieder TX auf den RX pin 19 im Mega
wenn es etwas anzeigt gehst du weiter. trenne die direkte TX-leitung so das nur das Airmodul drann ist und setze in der Station auch das modul ein.
Prüffe nochmal ob auf allen Modulen die Greiche Firmware drauf ist, hab es schon erlebt das die Module so aussahen als würden sie Komunizieren haben aber auf grund der unterschiedlichen FW nicht die Daten übertragen.

LG Peter
 
RCLogger

FPV1

Banggood

Banggood

Oben