Umstieg auf AutoQuad

#41
so habe das jetzt auch im Mode 2 hinbekommen, irgendwie waren in der Funke noch Mixer eingestellt

wenn ich die Funke ausschalte bleiben alle Ausschläge wie sie zuletzt waren - ist das so ok?
Was macht die Signalqualität? Die muss auf NULL gehen, dann wird ein SINGAL LOSS erkannt und die entsprechenden Aktionen (z.B. RTH, LAND) werden eingeleitet.
Wenn du die Funke ausschaltest und die Signalqualität nicht auf NULL geht ist das Failsafe deines TX/RX noch aktiv --> abschalten.
 

keilie

Erfahrener Benutzer
#42
So nachdem ich mir mal ein Testkopter zusammengebaut habe und die "Simple Onboard DIMU Calibration" durchgeführt und die ESC's kalibriert habe sieht soweit ert mal alles gut aus.

Bin nur etwas verwundert, dass ich sehr schlecht ein GPS fix bekomme. ich habe eine 35mm Antenne von Taoglas dran und bekomme bei mir im Zimmer kein fix und auf dem überdachten Balkon auch kein stabilen 3D fix.

Mit meinem Handy wie auch mit meinem Garmin und auch mit meiner Wookong und NAZA bekomme ich sofort auch im Zimmer ein guten 3D fix.

Gibt es für den AutoQuad vielleicht ein GPS Monitor oder kann ich da noch irgendwo was testen und einstellen?

Ach ja da fällt mir noch was ein: Wie bekomme ich schnell und einfach die Motoren wieder aus? Bei DJI brauch ich die Steuerknüppel ja einfach nur runter und zur Seite machen.
 
#43
So nachdem ich mir mal ein Testkopter zusammengebaut habe und die "Simple Onboard DIMU Calibration" durchgeführt und die ESC's kalibriert habe sieht soweit ert mal alles gut aus.

Bin nur etwas verwundert, dass ich sehr schlecht ein GPS fix bekomme. ich habe eine 35mm Antenne von Taoglas dran und bekomme bei mir im Zimmer kein fix und auf dem überdachten Balkon auch kein stabilen 3D fix.

Mit meinem Handy wie auch mit meinem Garmin und auch mit meiner Wookong und NAZA bekomme ich sofort auch im Zimmer ein guten 3D fix.

Gibt es für den AutoQuad vielleicht ein GPS Monitor oder kann ich da noch irgendwo was testen und einstellen?

Ach ja da fällt mir noch was ein: Wie bekomme ich schnell und einfach die Motoren wieder aus? Bei DJI brauch ich die Steuerknüppel ja einfach nur runter und zur Seite machen.
Was hast du denn für eine Antenne? Eine GPS oder eine GNNS?

Mit dem M4 kannst du das uBlox uCenter Tool nutzen; die USB/UART muss auf 1200 im “Receiver” menu eingestellt werden.
Download ist hier https://www.u-blox.com/en/product-s...ation-tools-a-software/u-center/u-center.html

Wieso Motor schnell aus? Ist doch wie (fast) überall:
Armen: Gas runter, Ruder rechts für 3 Sekunden
Dis-arming: Gas runter, Ruder links für 3 Sekunden
AQ_arming.png

Das geht natürlich nur wenn die Flight Mode switches auf MANUAL sind (Im Bild unten FLAP auf Manual, AUX2 auf normal)
AQ_Switches1-1024x236.png

Oder was ist genau die Problematik?
 

keilie

Erfahrener Benutzer
#44
ok danke, das mit dem MANUAL Mode habe ich nicht beachtet

Muss ich bei dem uBlox Center noch irgendwas außer Port und Baudrate einstellen?
Und ist in der QGC noch Parameter umstellen?
 

keilie

Erfahrener Benutzer
#51
Nachdem ich bis dato die Graupner HoTT Funktionen mit der AQ HoTT Firmware eingearbeitet habe und soweit auch alles funktioniert, will ich nun auch den Strom auf der Funke sichtbar machen.

Also habe ich die Mav2HoTT Variante mit Current Sensor angeschlossen.
Leider habe ich es noch nicht geschafft den Strom zur Anzeige zu bringen und als Zweites zeigt die Funke immer Low Batt - LAND!
Welche Parameter muß ich alle anpassen?
Habe 4s und aktuell 15,7V die auch richtig auf der Funke angezeigt werden
In der Mav2Hott.h habe ich LOW_BATT auf 3.3 und LOW_BATT_2 auf 3.0 gesetzt
In der FrameConfigs.h habe ich die Spannung pro A, den Offset und die Eingangsspannung richtig eingestell
 
#52
Nachdem ich bis dato die Graupner HoTT Funktionen mit der AQ HoTT Firmware eingearbeitet habe und soweit auch alles funktioniert, will ich nun auch den Strom auf der Funke sichtbar machen.
Sorry, verstehe ich nicht. Nutzt du Mennos HOTT Firmware oder hast du die eine eigene gebaut?


Also habe ich die Mav2HoTT Variante mit Current Sensor angeschlossen.
Leider habe ich es noch nicht geschafft den Strom zur Anzeige zu bringen und als Zweites zeigt die Funke immer Low Batt - LAND!
Welche Parameter muß ich alle anpassen?
Habe 4s und aktuell 15,7V die auch richtig auf der Funke angezeigt werden
In der Mav2Hott.h habe ich LOW_BATT auf 3.3 und LOW_BATT_2 auf 3.0 gesetzt
In der FrameConfigs.h habe ich die Spannung pro A, den Offset und die Eingangsspannung richtig eingestell
Was hast du denn angeschlossen? Bilder sagen mehr als 1000 Worte und ohne zu wissen wovon du redest wird es schwierig, sorry.

Piept deine Funke? Dann solltest du die Warnschwelle dort auch anpassen.
 

keilie

Erfahrener Benutzer
#53
Sorry, verstehe ich nicht. Nutzt du Mennos HOTT Firmware oder hast du die eine eigene gebaut?
Habe keine eigene Firmware gebaut, meine diese hier http://autoquad.org/software-downloads/?did=153


Was hast du denn angeschlossen? Bilder sagen mehr als 1000 Worte und ohne zu wissen wovon du redest wird es schwierig, sorry.
Piept deine Funke? Dann solltest du die Warnschwelle dort auch anpassen.
Habe wie hier im Wiki http://autoquad.org/wiki/wiki/autoq...ns/telemetry-xbee/mavlink-led-signaling-hott/ bechrieben ein Arduino Pro Mini Atmega328 (5V 16MHz) board mit der dazugehörigen Software http://autoquad.org/software-downloads/?did=82 und einem 200A, ACS770ECB-200B-PFF-T Current Hall Sensor angeschlossen.

Die Funke piept nicht, da ist alles ok.
 

keilie

Erfahrener Benutzer
#54
Habe mal noch eine Frage an die Experten hier:
Bin am überlegen mir eine Spektrum Funke zuzulegen um den internen Empfänger vom M4 zu nutzen. Bekomme ich dann auch Telemetriedaten auf meine Spektrum Funke oder brauche ich da auch noch irgendwelche Erweiterungrn?
Der Hintergrund meiner Frage ist, dass ich ein möglichst leichten FC incl. Empfänger suche aber mindestens die Flugakkuspannung überwachen möchte.
Danke Reiner
 

r0sewhite

Erfahrener Benutzer
#55
Nein, kriegst Du nicht. Es gibt eine Telemetriemöglichkeit über Spektrum aber nicht mit einem einfachen Satelliten. Jörg kann Dir dazu aber sicher mehr erzählen.
 
#58
ist schade - da kann ich ja bei Graupner bleiben

wer ist Jörg?
Yep, that's me!

Also:
1.) der Onboard RX des M4 (entweder Deltang (auf den M4r5) oder Cypress (auf den M4r6)) kann keine Telemtrie
2.) Spektrum Telemetrie verlangt immer nach einen Telemetriesender (TM1000; der TM1100 ist für uns nicht zu gebrauchen)

Ein Video von der Spektrum Telemetrie mit Autoquad (zeigt die AQ6, geht aber genauso mit dem M4) ist hier :
[video=youtube;8lFXvs7odrE]https://www.youtube.com/watch?v=8lFXvs7odrE[/video]

3.) du brauchst aber noch was 'dazwischen' was die die AQ-Telemtrie in ein für den TM1000 verständliches Telemetrieprotokoll wandelt. Ich hatte dafür einen Arduino benutzt. Infos zum Protokoll sind inzwischen öffentlich: http://www.spektrumrc.com/ProdInfo/Files/SPM_Telemetry_Developers_Specs.pdf

Gruss
Jörg
aBUGSworstnightmare
 

keilie

Erfahrener Benutzer
#59
Jörg danke für die ausführliche Antwort.
Telemetrie mit einem Arduino nutze ich ja bereits mit meiner Graupnerfunke
Ich habe einfach gehofft Komponen einzusparen wenn ich auf Spektrum wechsle, das scheint aber wohl nichts zu werden wenn ich auf Telemetrie nicht verzichten will.

Reiner
 
Zuletzt bearbeitet:
RCLogger

FPV1

Banggood

Banggood

Oben