FrSky Taranis - kurze Frage, kurze Antwort

kreidler

Erfahrener Benutzer
Funktioniert die SPort Kommunikation, z.B. die SXR LUA Scripte, und die Bindeoptionen mit 151223?
Ja, ich habe die Version immer noch auf meiner X9D+ mit SxR-Empfängern im Einsatz. Alle Scripte funktionieren ohne Einschränkung mit otx2.2.2 sowie den 180328-Firmware-Versionen (muss auch, da ich keinen STK-Stick habe:)).
Für F-Port ist wenn ich mich recht entsinne auch 170317 nötig
Interessante Frage (auch wenn es nur Empfänger-Ding sein sollte). FPort ist nur bei Sohnemanns QX7 (damit 170317) im Einsatz. Ich könnte aber die Tage mal einen Rx passend flashen und versuchen mit der 151223 zu binden.
 
Ja, ich habe die Version immer noch auf meiner X9D+ mit SxR-Empfängern im Einsatz. Alle Scripte funktionieren ohne Einschränkung mit otx2.2.2 sowie den 180328-Firmware-Versionen (muss auch, da ich keinen STK-Stick habe:)).
OK, hätte ich nicht gedacht, also bleiben erstmal nur die Bindeoptionen, die mit 151223 noch nicht gehen.
 

olex

Der Testpilot
Die Optionen hat man zumindest auf den "großen" X6R/X8R Empfängern auch verfügbar, indem man bestimmte Kanäle beim Binden mit Jumper verbindet. Details dazu stehen in den Empfänger-Anleitungen. Ist natürlich einfacher direkt auf der Funke auszuwählen.
 

kreidler

Erfahrener Benutzer
Hmm,
die Bindeoptionen hinsichtlich Telemetrie und PWM sind im OpenTX vorhanden und werden auch angezeigt. Woher soll auch otx wissen welche HF-FW im Einsatz ist.

Ich habe auf den "Quatsch"-Post mal eben zum ersten Mal versucht "Tele ON CH9-16" zu binden, was dazu führte, dass ich den Empfänger neu flashen musste, damit erneutes Binden möglich war.

Somit muss ich verbessern: Bindeoptionen in aktueller OpenTX vorhanden, aber ohne Funktion in Verbindung mit XJT-Firmware 151223.

P.S.: Dann muss ich wohl doch demächst updaten...
 
Hallo, kurze Frage: Kann man an dem S-Port (alter Sender Taranis X9D) irgndwie Einstellungen bezüglich der Übertragung bzw. der Übertragungsgeschwindigkeit vornehmen?
Mein Problem... alle original S-Port Frsky Sensoren funktionieren natürlich perfekt.
Jetzt habe ich aber einen Matek F405 Wing neueste firmware 2.01 mit INAV programmiert und da kommen alle S-Port Sensor-Daten nur sporadisch an. Zum Teil blinken die Sternchen da nur mal alle 2 sec oder so.
Das geht für die Akkuspannung ja gerade noch, aber das Vario kannst da nicht wirklich gebrauchen.
 

olex

Der Testpilot
Da würde ich das Problem bzw. Lösungsansätze eher auf der Seite von iNav suchen, da die Telemetriedaten komplett von der Software erstellt und übertragen werden, die Fernsteuerung kann daran nichts beeinflussen. Früher gab es solche Probleme bei iNav mit F.Port, lag an überladenem seriellen Port - das wurde aber mit 2.0.0 behoben soweit ich mich erinnere; vielleicht hat sich in 2.0.1 und/oder in dem F405-Wing Build ein neuer Fehler eingeschlichen...
 
ok, vielen Dank für die schnelle Antwort. Leider habe ich keine so guten englischkenntnisse und bin zum großteil auf deutsche Foren angewiesen. Nur da scheinen sich noch nicht sooo viele Leute mit dem F405Wing zu beschäftigen. Hab diesbezüglich noch nichts gefunden. Wenn das nicht gelöst wird, werde ich wohl bei meinem alten System FY-41AP lite und den ganzen Zusatz-Sensoren bleiben. Wäre halt schön gewesen, hätte das zusätzliche BEC, den Stromsensor, das Vario und das zusätzliche GPS gespart.
 
Nochmals Danke für die Antworten an olex und bendh.
Hab gerade herausgefunden, dass der F405Wing scheinbar keine anderen Sensoren neben sich duldet. Zumindest bei meiner alten Taranis DX9. Die Horus scheint das allerdings zu schaffen, hat ein Kollege berichtet.
Auf Deutsch, ich hatte immer den Frsky Lipo - Einzelzellen Sensor zusätzlich dran. wenn ich den raus nehme läuft die Übertragung der Daten vom F405Wing.
Darauf könnte man theoretisch auch verzichten, nur befürchte ich, dass dann auch kein anderer Sensor, wie z.B. Motordrehzahl und Temperaturen, den ich normalerweise auch nutze, leider nicht funktionieren.
Da ich gerade keinen hier habe und keinen aus einem Modell ausbauen möchte, kann ich das leider noch nicht genau sagen.
 

devil

Erfahrener Benutzer
Nochmals Danke für die Antworten an olex und bendh.
Hab gerade herausgefunden, dass der F405Wing scheinbar keine anderen Sensoren neben sich duldet. Zumindest bei meiner alten Taranis DX9. Die Horus scheint das allerdings zu schaffen, hat ein Kollege berichtet.
Auf Deutsch, ich hatte immer den Frsky Lipo - Einzelzellen Sensor zusätzlich dran. wenn ich den raus nehme läuft die Übertragung der Daten vom F405Wing.
Darauf könnte man theoretisch auch verzichten, nur befürchte ich, dass dann auch kein anderer Sensor, wie z.B. Motordrehzahl und Temperaturen, den ich normalerweise auch nutze, leider nicht funktionieren.
Da ich gerade keinen hier habe und keinen aus einem Modell ausbauen möchte, kann ich das leider noch nicht genau sagen.

OB die Taranis Alt oder Neu ist spielt dabei aber keine Rolle oder ob du die X 10 oder X12 verwendest.
Du kannst mal deine Taranis auf die Neueste OPenTX flashen 2.22 dann bist du mit der Horus gleichauf.

Wenn du den FLVSS zusammen mit einem Anderen Sensor anschließt und dann geht nix mehr, hast du vermutlich einen ID Konflikt, diesen Kannst du ganz leicht mit dem Servo Channel Changer beheben.
Das geht bei Servos sowie bei original Frsky Sensoren
die ID des FLVSS ändern muss ich auch immer wieder mal machen wenn ich einen Neuen Sensor hinzufüge da kommt es öfter mal zu dem von dir beschriebenen Verhalten.
 
Ok, OpenTX 2.22 v. 28.07.2018 hab ich drauf.
Allerdings denke ich.... kann auch ein Irrtum sein, dass die alten Anlagen weniger Speicher zur Verfügung haben. Ich verwende z.B. auch aufwendige LUA script. da kommt der Speicher ebnfalls sehr oft an seine Grenzen.
Und das mit der ID werde ich probieren
Gruß
Frank
 
RCLogger

FPV1

Banggood

Banggood

Oben