FY41AP released

funfex

Erfahrener Benutzer
Ich bin immer noch bei der Ersteinrichtung.

Ich hänge am Regler, der nach dem Anschalten nur dauerhaft piepst.
Wenn der Regler am Empfänger steckt, macht er, was er soll....ist also intakt.

Die Kanalanzeige am GCS zeigt, was ich mit dem Gasknüppel mache....ist wohl aber nur eine Inputanzeige.

Den Regler über den FY anlernen geht nicht, immer nur Piepsen...

Was hab ich vergessen oder übersehen ?

(Der FY ist natürlich die ganze Zeit im manuellen Modus)

DANKE !
 
Hi,
Du hast aber mächtige Startschwierigkeiten mit dem FY! Wir müssen uns wahrscheinlich mal treffen...

Das der Regler ohne den FY angelernt werden muss, kenne ich auch.
Liegt wohl an der verzögerten Signalausgabe des FY beim Kaltatart. Wenn das Signal weitergeleitet wird, ist der Regler schon nicht mehr im Programmiermodus.

Bei Dir hört es sich so an, das der Regler über den FY nicht das Signal für "kein Gas" (1000us) bekommt das er angelernt hat, sondern einen höheren Wert. Daher initialisiert der Regler nicht, solange nicht das entsprechende Signal kommt.

Versuche mal den Regler anzulernen(ohne FY) mit verschiedenen Trimmungen des Gaskanals.
 

funfex

Erfahrener Benutzer
EBEN hab ich die Lösung von Cartman aus RCGROUPS bekommen:
Verbindung Powermodul - ESC trennen, Akku dran und damit FY einschalten, dann Vollgas und Regler wieder an Powermodul stecken. Gas runter, fertig.
Voila, angelernt ! :)
Eigentlich müsste man auch selber drauf kommen....

Deine Vermutung mit der Verzögerung war schon richtig.
 
So, damit ich nicht extra einen Thread auf mache....

Also ich fliege eine Solius mit FPV und FY41ap Light.
Stabi Mod´s funktionieren alle 1A, nur RTH will nicht so wirklich, habe Failsaife auf 100% Gas Programmiert und in den Einstellungen von der FY41AP den Gain auf 90%.
Aber jedes mal eiert der rum, zieht die Nase hoch damit er höhe hält und die Strömung reist ab, der Autopilot gibt einfach nicht vollgas!
Ich fliege nur mit GPS ohne Staurohr, ich verstehe das nicht...
Hin und wieder gehts dann gibt er Vollgas und fliegt auch mir gut 80-90kmh zurück.

Hat da sonst noch zufällig jemand Probleme mit?
 
@ freefrank

Das müsste ich doch mal testen, ich frage mich nur was es für einen sinn hat, gerade wenn ich segel und der Empfang weg ist kann ich ja schlecht noch mal Gas geben....
Oder ich muss wirklich den AS dran machen, ist nur blöd wegen der teilbaren Fläche.
 
Während RTH, also wenn bereits aktiviert kannst Du die Funke auch ausmachen.
Die Navi basierten Flugmodi sind voll autonom! Knüppelsignale werden ignoriert.

Entscheidend ist die Gasstellung vor aktivieren von RTH. Gilt für ohne Airspeedgeber!
Mit Airspeedgeber regelt er den Speed selber.
 
@ tribort

Du hast vollkommen recht. Ist schlecht gemacht.

Versuche doch mal als Failsave beim Empfänger RTH und Gas auf z.B. 75% zu setzen.
Evt. nimmt der FY41 den Gasbefehl ja noch an bevor er auf RTH geht...

Um sicher zu gehen immer mit Airspeedgeber.
 
Ja das weiß ich, da nimmt die Fy41 ja auch keine Befehle mehr an.
Nur wenn ich doch Segel dann ist vor RTH z.B bei Signalverlust ja 0% wie soll er denn dann nach Hause kommen?
 
kannst Du nicht bei Deinem Empfänger mehrere Aktionen für Failsafe setzen?
1. Gas auf einen vorbestimmten Wert
2. RTH aktivieren

Die Gasstellung beim Signalverlust ist doch dann nicht mehr relevant.
 

nor

Neuer Benutzer
@ tribort
Huch .. da sind ja erstaunlicherweise jede Menge Beiträge eingegangen während ich schrieb und abschickte . Deshalb ist meiner jetzt wohl eh veraltet / nicht mehr relevant .
Ich schrieb :

Nun ja.... normalerweise macht der FY-41 AP (lite) solche Zicken wenn das Staurohr dran ist .
Da ist eh allgemein (noch ) der Wurm drin .
Aber
Hab das Staurohr auch nicht dran .
Und trotzdem kann von gänzlich autonomer (und gar noch passender ) Gassteuerung des FY-42AP Lite im RTH-Modus auch bei mir nicht so wirklich die Rede sein .
Sondern was er da gasmäßig so macht , hängt dann immer noch entscheidend davon ab wie der Gasknüppel VOR Aktivierung von RTH steht :
Ist der auf null , gibt der FY-42AP Lite mit ( manuell per Schalter !) aktiviertem RTH gar nur gelegentlich etwas Gas , der Flieger eiert auch nur so kurz vor dem Abschmieren rum und sinkt immer weiter .
Steht der Gasknüppel dagegen vor Aktivieren von RTH auf Halbgas , passt´s einwandfrei .
.... Das deckt sich dann auch mit der Hersteller-Empfehlung , für Failsafe erstens natürlich die Schalterstellung für RTH zu speichern , aber zweitens gleichzeitig auch eine Stellung des Gasknüppels von etwa 50 bis 60 Prozent !
Hab zwar die automatische RTH Auslösung durch FailSafe bis jetzt noch nicht getestet . Den Sender im Flug abzuschalten war mir bisher zu riskant .
Aber
zum manuell per Schalter "auf Wunsch" ausgelösten RTH besteht da zumindest rein logisch eh kein Unterschied ! ( Auch FailSafe macht letztendlich nichts anderes als halt lediglich den RTH Schalter zu betätigen . )
Also
dürfte es beim FY-41AP wohl "serienmäßig" und normal sein , dass RTH halt einfach nicht richtig funktioniert wenn der Gasknüppel bei RTH Aktivierung (egal ob durch Failsafe oder manuell) auf Null steht !
Ich persönlich hab das jetzt halt mal so akzeptiert .
Und auch im FY-41AP Lite Setup den Gain-Wert für Gas noch auf Standard .... Bzw. weiss noch nicht mal wie der standardmäßig überhaupt steht , geschweige denn dass ich den jemals verstellt hätte :)
Weil :
Scheint laut Foren eh nichts zu bringen .... Bzw. nur manchmal eventuell , je nach Laune des FY-41 AP !?
Vielleicht kriegt Feyu-Tech das ja mit einer neuen Firmware noch "irgendwann" in den Griff ...
Zu grosser Enthusiasmus scheint da aber nicht angebracht :
So wirklich "bewegende" / verbessernde Updates der Firmware hat´s ja praktisch seit Erscheinen des AP-41 Lite noch nicht gegeben . In letzter Zeit eh gar keine mehr .
Und das Gleiche gilt auch für die ziemlich zickige , veraltete GCS Software , die z.b. "für gewöhnlich" manche Setup Veränderungen eh nicht abspeichert .
... Was bei mir allerdings eh "kein Problem" war , weil sie unter Win 7 Ultimate 64 bit sowieso schon beim Öffnen sofort mit Appcrash abstürzte .

Von solchen Kleinigkeiten abgesehen ist der FY-41 AP (Lite) aber andererseits vor Allem in den Automatik Modi einer der bzw. der Zuverlässigste und erlaubt sich keine groben Fehler . So manche andere Autopiloten
produzieren ja in den GPS Modi schon mal z.b. spektakuläre Todesspiralen u.ä. ... oder nehmen "Return to Home" allzu wörtlich und machen sich dann gleich frohgemut auf den Rückweg nach China .
 
Zuletzt bearbeitet:
Also mein Failsafe (MX12 mit GR16) habe ich auf 100% Gas und RTH Aktiviert.
Der RTH Aktiviert sich auch, aber er gibt kein Gas, was eigentlich das große Problem ist...

Kann man den Regler Stecker nicht einfach weg lassen aus der Fy41AP und direkt in den Empfänger stecken?
Dann ist Failsafe ja das was ich eingestellt habe.
 

nor

Neuer Benutzer
Hast Du Fail-Safe auch nicht auf "Hold" gelassen , sondern die entsprechenden Kanäle (bzw. am Besten alle Kanäle ) auf "Position" gesetzt !?
Tritt dann der Fail-Safe Fall ein , stellt der Empfänger ALLE auf "Position" gesetzten Kanäle / Schalter / den Gasknüppel auf die Positionen die Du vorher in Fail-Safe ( unten rechts mit "STO" )abgespeichert hast .

Also wird auch RTH auf jeden Fall eingeschaltet .
Und das Gas ( so wie´s der FY-41AP ja will ) , auf ca. 60 Prozent ( bzw. wenn Du Gasknüppel 100 Prozent offen abgespeichert hast , natürlich auch das ) gestellt .
Ganz egal wie die zwei Dreiwege-Schalter für den Autopilot bzw. der Gasknüppel zum Zeitpunkt des Ausfalls grad stehen .
Hab´s zwar wie gesagt noch nicht getestet . ( Ob RTH bei FailSafe funktioniert kann man ja nur knallhart durch Ausschalten des Senders im Flug testen !? )
Aber
so MÜSSTE es praktisch zwangsläufig funktionieren !? ...
Weil es dann praktisch ja auch nichts anderes ist als ob Du als Pilot diese Steuerbefehle gibst bzw. die Schalter betätigst !
Es sei denn der Autopilot schnallt den 60 Prozent Gasbefehl vom Fail-Safe wirklich nicht ? ... Kommt für den FY-41AP vielleicht zu schnell ?
In dem Fall dann mal die Verzögerung für die Auslösung in Fail-Safe entsprechend hochstellen !
 
Zuletzt bearbeitet:
Ich habe es anfangs mit etwa 60% versucht weil es nicht ging bin ich auf vollgas 100%.

Am Boden geht das Gas nicht an wenn ich RTH einschalte oder den Sender ausschalte, jedoch geht in der Luft das Gas an wenn ich RTH Aktiviere allerdings viel zu wenig, man hört auch das er etwas Regel, allerdings alles viel zu wenig und demzufolge versucht das s****ding die höhe zu halten wieso geht der nicht in einen Sinkflug und versucht die Geschwindigkeit so zu halten.
Ich finde da ist noch einiges an Nachbesserung nötig...

Gestern hatte ich das selbe Problem und hatte dann beim Gas den Gain hochgesetzt, da nach ging es gestern. Heute war wieder der Wurm drin, die Anleitung ist ja auch nicht wirklich zu etwas zu gebrauchen und schweigt sich zu so ziemlich allem aus.
 
Nicht gleich in die Luft gehen ;-)

Ich betreibe 3 FY41 und alle funktionieren. Man muss sich eben ein wenig einarbeiten!

- den Gain für Gas habe ich grundsätzlich auf 100%
- unter ca. 10m Höhe wird das Gas deaktiviert(Sicherheitsfunktion falls man aus Versehen am Boden z.B. RTH startet)
- bei RTH Auslösung wird die momentane Flughöhe gehalten bis der Homepoint erreicht ist. Dann sinkt er auf 80m und kreist
- das es bei Dir sporadisch funktioniert liegt wahrscheinlich an den unterschiedlichen Gasstellungen zum Zeitpunkt der RTH Auslösung (aber das hatten wir ja schon)
 
RCLogger

FPV1

Banggood

Banggood

Oben